<!DOCTYPE html>
<html itemscope itemtype="http://schema.org/Article">
<head>
    <title>Mother's Day 2017 Brunches in Fort Lauderdale | New Times Broward-Palm Beach</title>
<meta name="description" content="Top places offering Mother&#039;s Day brunch in Broward County."/>
<meta name="author" content="Alona Abbady Martinez"/>
<meta name="keywords" content="Mother&#039;s Day brunch Fort Lauderdale, Mother&#039;s Day Brunch Palm Beach"/><meta property="og:type" content="article"/>
<meta property="og:title" content="Best Broward Brunch Spots for Mother&#039;s Day 2017"/>
<meta property="og:description" content="A summary of the top places to take Mom to brunch this Mother&#039;s Day."/>
<meta property="og:url" content="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437"/>
<meta property="article:published_time" content="2017-05-08T13:08:00-04:00"/>
<meta property="article:modified_time" content="2017-05-08T13:08:50-04:00"/>
<meta property="article:section" content="Restaurants"/>
<meta property="article:tag" content="brunch"/>
<meta property="article:tag" content="Mother&#039;s day"/>
<meta property="article:tag" content="Broward"/>
<meta property="og:image" content="http://images1.miaminewtimes.com/imager/u/original/9313907/lbnutellawaffle.jpg"/>
<meta property="og:image:height" content="3456"/>
<meta property="og:image:width" content="5184"/>
<meta property="og:site_name" content="New Times Broward-Palm Beach"/><meta itemprop="headline" content="Best Broward Brunch Spots for Mother&#039;s Day 2017"/>
<meta itemprop="description" content="Top places offering Mother&#039;s Day brunch in Broward County."/>
<meta itemprop="image" content="http://images1.miaminewtimes.com/imager/u/original/9313907/lbnutellawaffle.jpg"/><meta property="twitter:title" content="Best Broward Brunch Spots for Mother&#039;s Day 2017"/>
<meta property="twitter:description" content="A summary of the top places to take Mom to brunch this Mother&#039;s Day."/>
<meta property="twitter:card" content="summary_large_image"/>
<meta property="twitter:image" content="http://images1.miaminewtimes.com/imager/u/745xauto/9313907/lbnutellawaffle.jpg"/>
<meta property="twitter:creator" content="@alonamartinez"/>
<meta property="twitter:site" content="@newtimesbroward"/><meta property="fb:app_id" content="154555581257317"/><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1"/><link href="/theme/bpb/apple-touch-icon.png" rel="apple-touch-icon" sizes="192x192"/>
<link href="/theme/bpb/apple-touch-icon.png" rel="icon" sizes="192x192"/><link href="/theme/bpb/apple-touch-icon.png" rel="shortcut icon" sizes="192x192"/>
<meta name="mobile-web-app-capable" content="yes"/>
<link href="/theme/bpb/favicon.ico" type="image/x-icon" rel="icon"/><link href="/theme/bpb/favicon.ico" type="image/x-icon" rel="shortcut icon"/>
<link rel="stylesheet" type="text/css" href="/css_cache/bpb-default.css?buildId=1494364743"/>
<link rel="stylesheet" type="text/css" href="/css_cache/content-view.css?buildId=1494364743"/>
<script type="text/javascript" src="/js_cache/default.js?buildId=1494364743"></script>
<link rel="canonical" href="http://www.miaminewtimes.com/restaurants/mothers-day-brunches-in-fort-lauderdale-9300118" /><meta name="theme-color" content="#0053b8"/>    
        <script type="text/javascript">
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-395255-25', {
            'siteSpeedSampleRate': 5
        });

        // Set dimensions for use with each hit
        
                ga('set', 'dimension1', 'http://www.browardpalmbeach.com/restaurants');
            

                ga('set', 'dimension2', 'Restaurants');
            

                ga('set', 'dimension7', 'Articles');
            

                ga('set', 'dimension3', '8606437');
            

                ga('set', 'dimension4', '2017-05-08 13:08:00');
            

                ga('set', 'dimension5', 'Lists');
            

                ga('set', 'dimension6', 'Alona Abbady Martinez');
            

        // Send for pageview hit type
        ga('send', 'pageview');

        </script>
        <script type="text/javascript" src="//native.sharethrough.com/assets/tag.js" async=""></script>



<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>


    <script type="text/javascript">
    if ('www.b' + 'rowar' + 'dpalm' + 'beach' + '.com' != document.location.host && document.location.host != 'web.a' + 'rchiv' + 'e.org'  && document.location.host != 'webci' + 'tatio' + 'n.org') {
                //document.location.host = 'www.b' + 'rowar' + 'dpalm' + 'beach' + '.com';
        document.location.host = 'http://microapp.vvmedia.com/destination/index.html';
    }
    </script>

</head>
<body class="bpb city-blue twitterTrue layout-lg">
        <div class="wrapper">
        <div class="ads frame" data-vmg-ad="Frame" data-vmg-format="normal"></div>                <div class="all-body">
            <a name="top"></a>
            <div class="slide-body container-fluid">
                <div class="sde-shadow">
                    <nav>
                        <div class="nav-search">
                            <form id="search-form" method="get" action="/search">
                                <fieldset>
                                    <input type="text" name="keyword" id="q" value="" />
                                    <input type="submit" value="Search" class="sprite" />
                                </fieldset>
                            </form>
                        </div>
                        <ul class="top-level">
    <li class="has-sub"><a href="/news">News</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/broward-news-6386470" >Broward County News</a></li><li><a href="/topic/palm-beach-news-6386437" >Palm Beach County News</a></li><li><a href="/topic/crime-6386331" >Crime</a></li><li><a href="/topic/wtflorida-6386474" >WTFlorida</a></li><li><a href="/longform" >Longform</a></li></ul></li><li class="has-sub"><a href="/music">Music</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/concert-review-6386291" >Concert Reviews</a></li><li><a href="/topic/concert-preview-6386295" >Upcoming Shows</a></li><li><a href="/topic/interviews-6386448" >Interviews</a></li><li><a href="/concerts" >Concert Calendar</a></li><li><a href="/restaurants/guide?bars=true" >Bars & Lounges</a></li><li><a href="/profile?source_id=8|55|1380" >Music Newsletter</a></li></ul></li><li class="has-sub"><a href="/restaurants">Food & Drink</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/topic/restaurant-reviews-6386318" >Restaurant Reviews</a></li><li><a href="/topic/beer-beer-beer-6386443" >Florida Beer News</a></li><li><a href="/topic/cheap-eats-6386377" >Cheap Eats</a></li><li><a href="/restaurants/guide" >Restaurant Guide</a></li><li><a href="/profile?source_id=8|55|1381" >Food & Drink Newsletter</a></li></ul></li><li class="has-sub"><a href="/arts">Arts & Culture</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/slideshows/arts" >Slideshows</a></li><li><a href="/profile?source_id=8|55|1382" >Arts & Culture Newsletter</a></li></ul></li><li class="has-sub"><a href="/calendar">Calendar</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/submit-event" >Submit an Event</a></li><li><a href="/concerts" >Concert Calendar</a></li><li><a href="/calendar" >Things To Do</a></li><li><a href="/profile?source_id=8|55|1379" >Things To Do Newsletter</a></li></ul></li><li class="has-sub"><a href="/movies">Film & TV</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/movies" >News & Interviews</a></li><li><a href="/movies/reviews" >Film Reviews</a></li><li><a href="/movies/showtimes" >Showtimes</a></li><li><a href="/movies/trailers" >Trailers</a></li><li><a href="/profile?source_id=8|55|1383" >Film & TV Newsletter</a></li></ul></li><li ><a href="/longform">Longform</a></li><li ><a href="/videos">Videos</a></li><li ><a href="/slideshows">Slideshows</a></li><li class="has-sub"><a href="/best-of">Best of Broward-Palm Beach<sup>&reg;</sup></a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/profile?source_id=8|55|1384" >Best Of Newsletter</a></li><li><a href="http://readerschoice.miaminewtimes.com/" >Readers' Poll 2017</a></li></ul></li><li class="has-sub"><a href="/promotions">Promotions</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/calendar?categories%5B%5D=Promotional%20Events" >Promotional Events</a></li><li><a href="/promotions/free-stuff" >Free Stuff</a></li><li><a href="/profile?source_id=8|55|1385" >Promotions Newsletter</a></li></ul></li><li class="has-sub"><a href="/classifieds">Classifieds</a><span class="sprite drop-trigger">V</span><ul class="sub-nav"><li><a href="/microsites/job-fair" >Job Fair</a></li><li><a href="http://adindex.browardpalmbeach.com" >Ad Index</a></li></ul></li></ul>
<p class="misc">
    <a href="/mobile">Apps</a>,
    <a href="/about">About Us</a>,
    <a href="/about/contact">Contact Us</a>,
    <a href="/about/staff">Staff</a>,
        <a href="/advertise">Advertise</a>,
    <a href="/about/flipbooks">E-Edition</a>,
    <a href="/about/privacy-policy">Privacy</a>,
    <a href="/about/terms-of-use">Terms</a>
</p>
                    </nav>
                    <div class="masthead sticky-bar"><!-- toggle .active on .hamburger click -->
                        <a class="logo" href="/"><img src="/theme/bpb/img/logo-150.png" alt="New Times BPB, LLC"/></a>
                        <div class="styro"><a id="hamburger"><span>menu</span></a></div>
                        <div class="sb-hidey" id="sectionContent">    <div class="story-nav bottom-nav sn1 active">
        <p class="trigger-box">
            <span class="hed">Best Broward Brunch Spots for Mother's Day 2017</span>
        </p>
    </div>
    </div>
                        <ul class="socials">
                            
        <style type="text/css">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</style>
        <div class="main-container" id='login-modal'>
            <p class="error" id="login-error"></p>
            <form id="login" method="POST">
                <input type="text" id="email" name="email" placeholder="Email"/>
                <input type="password" id="password" name="password" placeholder="Password"/>
                <input type="hidden" id="cid" name="cid" value="bpb"/>
                <div class="remember-forgot">
                    <div class="rem"><label for="rememberMe"><input type="checkbox" checked id="rememberMe" name="rememberMe"/> Remember Me</div>
                    <button type="submit">SIGN IN &rsaquo;</button><br/>
                    <a href="javascript:;" id="forgot" tabindex="4" class="city-color">Forgot Password?</a>
                </div>

            </form>

            <div id="social">
                <p>Or sign in with a social account:</p>
                <span data-omni-action="facebook|sid[8|23|]|slider[1]|anon[0]" class="facebook">FACEBOOK</span>
                <span data-omni-action="google|sid[8|23|]|slider[1]|anon[0]" class="google">GOOGLE +</span>
                <span data-omni-action="twitter|sid[8|23|]|slider[1]|anon[0]" class="twitter">TWITTER</span>
                <span data-omni-action="yahoo|sid[8|23|]|slider[1]|anon[0]" class="yahoo">YAHOO!</span>
            </div>
            <div class="line"> </div>
            <div class="footer">
                <p>
                    Don't have an account yet?
                    <span class="mvn-join-button">Sign Up &rsaquo;</span>
                </p>
                            </div>
        </div>
        <script type="text/javascript">
            $(function(){
                $('#login').on('submit', function(e){
                    $('#login-error').hide();
                    e.preventDefault();
                    var formData = $('#login').serialize();
                    MVN.sso.authUser(formData, function(resp){
                        $.ajax({
                            url: '/profile/authUser',
                            method: 'post',
                            data: formData,
                            success: function(){
                                window.MVN.user = resp.user;
                                location.reload();
                                $.modal.close();
                            }
                        });

                    }, function(e){
                        $('#login-error').html(e.message.error).show();
                    });
                });
                $('#forgot').click(function(){
                    $.ajax({
                        url: '/profile/ajaxForgot',
                        method: 'get'
                    }).done(function(d){
                        $('#login-modal').html(d);
                    })
                })
            });
            function social(network){
                if(ssoWindow)
                    ssoWindow.close();
                var winArr = ['status=0', 'toolbar=0', 'location=0', 'menubar=0', 'resizable=0', 'scrollbars=1'],
                    winW, winH;
                switch(network){
                    case 'yahoo':
                        winW = 500;
                        winH = 525
                        break;
                    case 'google':
                        winW = 875;
                        winH = 500;
                        break;
                    case 'twitter':
                        winW = 620;
                        winH = 675;
                        break;
                    case 'facebook':
                        winW = 640;
                        winH = 350;
                        break;
                    default:
                        return;
                }
                winArr.push('width='+winW, 'height='+winH);
                ssoWindow = window.open('/done.html', 'mvnSsoWin', winArr);
                ssoWindow.blur();
                if(navigator.userAgent.match(/iPad/i) != null){
                    window.parent.focus();
                }
            }
            if (typeof document.createElement("input").placeholder === 'undefined') {
                $(document.body).on('focus', 'input[placeholder]', function () {
                    if (this.value == $(this).attr('placeholder')) {
                        this.value = '';
                    }
                    $(this).removeClass('placeholder');
                }).on('blur', 'input[placeholder]', function () {
                    if (this.value == '') {
                        this.value = $(this).attr('placeholder');
                        $(this).addClass('placeholder');
                    } else {
                        $(this).removeClass('placeholder');
                    }
                });
                $('input[placeholder]').blur();
            }

            $('[data-omni-action]').on('click', function(){
                var call = $(this).data('omni-action');
                var action = call.split('|').slice(0,1).toString();
                switch(action){
                    case 'facebook':
                    case 'twitter':
                    case 'yahoo':
                    case 'google':
                        MVN_Server.client.action(call);
                        social(action);
                        break;
                    case 'anon':
                        MVN_Server.client.handleResponse({'status':'success', 'anon':true});
                        break;
                    default:
                        MVN_Server.client.action(call);
                        break;
                }
            });
            // updateModal();
        </script>        <style type="text/css">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</style>
        <div class="main-container" id='join-modal'>
        <span class="omni-icon-close"></span>
        <div id="join-step1">
            <div class="intro">
                <h1>Connect. Discover. Share.</h1>
                                <img title="Connect. Discover. Share." src="/img/mvn/1.jpg"/>
                                <p>
                    Get the most out of your experience with a personalized all-access pass to everything local on events, music, restaurants, news and more.
                </p>
            </div>
            <div class="line"></div>
            <p class="social">Enter your email or sign up with a social account to get started</p>
            <div id="social">
                <span data-omni-action="facebook|sid[8|23|]|slider[1]|anon[0]" class="facebook">FACEBOOK</span>
                <span data-omni-action="twitter|sid[8|23|]|slider[1]|anon[0]" class="twitter">TWITTER</span>
                <span data-omni-action="google|sid[8|23|]|slider[1]|anon[0]" class="google">GOOGLE+</span>
                <span data-omni-action="yahoo|sid[8|23|]|slider[1]|anon[0]" class="yahoo">YAHOO!</span>
            </div>
            <div class="login">
                <p class="error" id="join-error"></p>
                <form id="join" method="post">
                    <input type="text" placeholder="Enter Your Email" id="join-email" name="email">
                    <input type="hidden" value="bpb" name="cid"/>
                    <input type="hidden" value="8|23|" name="sid"/>
                    <div id="captcha">
                        <div id="join-recaptcha" data-key="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                    </div>
                    <a href="/about/privacyPolicy/" target="_top">Privacy Policy</a>
                    <button type="submit" >SIGN UP &rsaquo;</button>

                </form>
            </div>
            <div class="footer">
                <p>Already registered? <span class="mvn-login-button">Login &rsaquo;</span></p>
            </div>
        </div>
        <div id="join-step2">
        <style type="text/css">
    #demo {
        font: 12px/15px Arial,Verdana,sans-serif;
        margin: 0;
        padding: 0;
        overflow: hidden;
        background: transparent;
        max-width: 400px;
    }
    #demo a {
        cursor: pointer;
        color: #e40001;
        text-decoration: none;
    }
    #demo a:hover {
        text-decoration: underline;
    }
    #demo p {
        margin: 10px 0 0;
    }
    #demo p.error {
        color: red;
        background-color: #D6D6D6;
        padding: 3px 5px;
        clear: both;
        font-weight: bold;
        font-size: 12px;
        text-align: left;
    }
    #demo p.error:before {
        content: "\00D7";
        padding: 0 10px 0 5px;
    }
    #modal-demofields {
        margin: 0;
        padding: 0;
        display: inline-block;
    }
    #modal-demofields > ul {
        text-align: right;
        list-style-type: none;
        margin: auto 5px;
        padding: 0;
        display: block;
    }
    #modal-demofields > ul > li {
        float: left;
        padding-top: 10px;
        display: list-item;
    }
    #modal-demofields > ul > li label{
        clear: left;
        display: block;
        float: left;
        margin-right: 15px;
        padding-top: 5px;
        text-align: right;
        font: normal 14px/15px avalonWeb, sans-serif;
    }
    #modal-demofields > ul > li label > span{
        font-size: 16px;
        font-weight: bold;
        margin-right: 2px;
    }
    #modal-demofields > ul > li input[type=text],
    #modal-demofields > ul > li input[type=password]{
        clear: right;
        margin-bottom: 15px;
        width: calc(100% - 100px);
        border: 1px solid #444444;
        padding: 5px;
    }
    #modal-demofields > ul > li input[type=text].half {
        width: calc(50% - 52px);
    }
    #modal-demofields > ul > li input[type=image]{
        height: 24px;
    }
    #demo span#loading span {
        position: absolute;
        top: 0;
        left: 0;
        width: 100%;
        height: 100%;
    }
    #demo span#loading span.trans-50 {
        filter: alpha(opacity=50);
        -moz-opacity:0.5;
        -khtml-opacity: 0.5;
        opacity: 0.5;
        background-color: white;
    }
    #demo span#loading > span + span {
        background: url("/img/modal_spin_black.gif") no-repeat center center transparent;
    }
    #demo button {
        font: normal 14px/15px avalonWeb, sans-serif;
        display: block;
        width: 180px;
        background-color: #666;
        margin: 8px auto;
        color: white;
        border: none;
        cursor: pointer;
        text-align: center;
    }
    #modal-demoError{
        display:none;
    }
</style>
<div id="demo">
<form id="modal-demofields" method="post">
    <ul>
        <li>
            <div id="modal-demoError"></div>
            <label>*Email</label>
            <input type="text" id="modal-demofields-email" name="email" readonly="readonly" value="" disabled="disabled"/><br/>
            <input type="hidden" name="uid" id="modal-demofields-uid"/>
            <label for="username">*Username</label>
            <input type="text" id="modal-demofields-username" name="username" value="" maxlength="20"/><br/>
            <label for="password">*Password</label>
            <input type="password" id="modal-demofields-password" name="password" maxlength="64"/><br/>
            <label for="name">Name</label>
            <input type="text" id="modal-demofields-fname" name="f_name" placeholder="first name" value="" maxlength="45" class="half"/>
            <input type="text" id="modal-demofields-lname" name="l_name" placeholder="last name" value="" maxlength="45" class="half"/><br/>
            <label for="zipcode">*Zipcode</label>
            <input type="text" id="modal-demofields-zipcode" name="zipcode" value="" maxlength="5"/>
            <button type="submit">DONE</button>
        </li>
    </ul>
</form>
</div>
<script type="text/javascript">
	$(function(){
		window.MVN.queue(function(){
			if (typeof window.MVN.user !== 'undefined'){
				$.ajax({
					url: '/profile/ajaxRequestFullUser',
					data: {uid: window.MVN.user.id},
					method: 'POST',
					success: function(r){
						var user = r.data;
						$('#modal-demofields-uid').val(user.User.id);
						$('#modal-demofields-email').val(user.User.email);
						$('#modal-demofields-username').val(user.User.username);
						$('#modal-demofields-fname').val(user.UserDemographic.f_name);
						$('#modal-demofields-lname').val(user.UserDemographic.l_name);
						$('#modal-demofields-zipcode').val(user.UserDemographic.zipcode);
					}
				});
			}
			$('#modal-demofields').submit(function(e){
				e.preventDefault();
                $('#modal-demofields-email').attr('disabled', false);
				var formfields = $('#modal-demofields').serialize();
				MVN.sso.settings(formfields, function(r){
                    $.ajax({
                        url: '/profile/regSailThru',
                        data: formfields,
                        method: 'post'
                    }).success(function(e){
                        $('#modal-demoError').text('Registration is complete!').show();
                        $.modal.close();
                        window.location = "http://"+window.location.hostname+"/profile";
                    })
				}, function(r){
                    $('#modal-demoError').text('There was a problem with your information. Please check it and try again').show();
				})
			})
		})
	});
</script>        </div>
        </div>
        <script type="text/javascript">
            $(function(){
                VMG.captchaQueue.queue(function(){
                    grecaptcha.render('join-recaptcha',{
                        'sitekey' : $('#join-recaptcha').data('key')
                    })
                })
                $('#join-modal').on('click', '.omni-icon-close', function(){
                    $.modal.close();
                })
                $('#join-modal').on('focus', '#join-email',function(){
                    $('#captcha').show();
                });
                $('#join').submit(function(e){
                    $('#join-error').hide();
                    e.preventDefault();
                    var formData = $('#join').serialize();
                    MVN.sso.authUser(formData, function(r){
                        $.ajax({
                            url: '/profile/authUser',
                            method: 'post',
                            data: formData
                        });
                        $('#join-step1').toggle();
                        $('#join-step2').toggle();
                        $('.omni-icon-close').toggle();
                        window.MVN.user = r.user;
                        $('#modal-demofields-uid').val(r.user.id);
                        $('#modal-demofields-email').val(r.user.email);
                        $('#modal-demofields-username').val(r.user.username);
                        // location.reload();
                        // $.modal.close();
                    }, function(r){
                        $('#join-error').html(r.message.error).show();
                    });
                });
            })
        </script>

<script type="text/javascript">
	$(function(){
		$(".mvn-login-button").click(function(){
			$.modal.close();
			$("#login-modal").modal({focus: false});
		});
		$(".mvn-join-button").click(function(){
			$.modal.close();
			$("#join-modal").modal({focus: false});
		});
	});
</script>

<li class="mvn">
    <a class="sprite trigger" title="Connect. Discover. Share.">MVN</a>
    <div class="drop drop-mvn">
        <span class="mvn-login-button">Sign In &rsaquo;</span>
        <p>Don't have an account yet?</p>
        <span class="mvn-join-button">Sign Up &rsaquo;</span>
    </div>
</li>                            <li class="fb" title="Follow us on Facebook">
                                <a class="sprite trigger" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Facebook',  {'NonInteraction': 1});">Facebook</a>
                                <div class="drop drop-fb">
                                    <div class="fb-like-box" data-href="https://www.facebook.com/newtimesbpb" data-width="300" data-height="180" data-colorscheme="light" data-show-faces="true" data-header="false" data-stream="false" data-show-border="false"></div>
                                </div>
                            </li>
                            <li class="tw" title="Follow us on Twitter">
                                <a class="sprite trigger" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Twitter',  {'NonInteraction': 1});">Twitter</a>
                                <div class="drop drop-tw">
                                    <a href="https://twitter.com/newtimesbroward" class="twitter-follow-button" data-show-count="true">Follow @newtimesbroward</a>
                                </div>
                            </li>
                            <li class="other">
                                <a class="sprite trigger" onClick="ga('send', 'event', 'Sticky-Bar', 'Click', 'Other',  {'NonInteraction': 1});">Other</a>
                                <div class="drop drop-other">
                                    <div class="g-plusone" data-size="small" data-href="http://www.browardpalmbeach.com"></div>
                                                                                                        </div>
                            </li>
                        </ul>
                    </div><!-- /.masthead -->

                    <div class="leaderboard">
                        <div class="ads top" data-vmg-ad="Top" data-vmg-format="normal"></div>                    </div>
                    <!-- /.leaderboard -->
                </div><!-- /.sde-shadow -->

                <div class="content">
                    

<section class="content-view">
    <div class="schema">
        <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437">
        <meta itemprop="name" content="Best Broward Brunch Spots for Mother's Day 2017">
        <meta itemprop="datePublished" content="2017-05-08 13:08:00">
        <meta itemprop="dateModified" content="2017-05-08 13:08:50">
        <span itemprop="author" itemscope itemtype="http://schema.org/Person">
            <span itemprop="name">Alona Abbady Martinez</span>
        </span>
        <div itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
            <meta itemprop="name" content="New Times Broward-Palm Beach">
        </div>
    </div>

    <h1>Best Broward Brunch Spots for Mother's Day 2017</h1>

    <div class="article-info ">
        <div class="pub-ago">
            <span class="pubdate">Monday, May 8, 2017 at 1:08 p.m.</span>
        </div>
        <div class="by-auth">
            <span class="byline">By <a href="/authors/alona-abbady-martinez-8031767">Alona Abbady Martinez</a></span>
        </div>
    </div>

    <div class="clearAll"></div>
    
    <div class="the-story">
        
        <div class="img-box bulge first-image "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9315129/steak_954_-_the_layover_9_.jpg" alt="Cheers to Mom!"><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9315129/steak_954_-_the_layover_9_.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Cheers to Mom!</div>
<div class="cred">Courtesy of Steak 954</div>
</td> </tr></tbody></table></div>
</div></div><div class="cs-box">

    <div class="text-size">
        <a class="lg">A</a>
        <a class="sm">A</a>
    </div>

    <ul class="socials ai-socials">
                <li class="fb" title="Share this on Facebook"><a class="sprite share" target="_blank" data-popularity-track="Social">Facebook</a><div class="count">-</div></li>

        <li class="tw" title="Share this on Twitter">
            <a class="sprite share" target="_blank" data-popularity-track="Social">Twitter</a>
            <a data-url="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437" id="twca">
                <div class="count" title="Powered by Lead Stories' OpenShareCount">-</div>
            </a>
        </li>

        <li id="social-expand" class="other social-expand" title="More sharing options"><a class="sprite more" href="#">More shares</a>
            <ul class="content-socials">
                <li class="gp"><a class="share" target="_blank" data-popularity-track="Social">recommend</a></li>
                <li class="re"><a class="share" target="_blank" data-popularity-track="Social">reddit</a></li>
                <li class="em"><a class="share" target="_blank" href="mailto:?subject=BrowardPalmBeach.com%3A+Best+Broward+Brunch+Spots+for+Mother%27s+Day+2017&body=http%3A%2F%2Fwww.browardpalmbeach.com%2Frestaurants%2Fmothers-day-2017-brunches-in-fort-lauderdale-8606437">email</a></li>
            </ul>
        </li>

        <li class="com" title="Leave a comment"><a class="sprite fb-com" href="javascript:;"></a><div class="count fb-comments-count" data-href="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437">-</div></li>

        <li class="prnt" title="Print this article"><a class="sprite print" href="/content/printView/8606437" target="_blank">Print Article</a></li>
    </ul>

</div>
<p class="first-para"><span class="first-sen">Sure, maybe she was a bit of a nag while you were growing up (that room wasn't going to clean itself), and she might occasionally remind you she is still waiting for grandkids (the clock is ticking), but she's still your mother, and she's surely done a lot for you over the years.</span> This Mother's Day, say thanks by treating her to a kick-ass brunch. Here are some Broward hot spots that will make her happy. Reservations are strongly suggested, and gratuity and tax are not included in prix-fixe prices.</p><p><b>American Social</b><br><i> 10:30 a.m. to 2:30 p.m., bottomless specials 10:30 a.m. to 3 p.m., at&nbsp;721 E. Las Olas Blvd., Fort Lauderdale;<br> 954-764-7005; <a href="http://americansocialbar.com/las-olas/" target="_blank">americansocialbar.com/las-olas</a>.</i></p><div class="ads centered middle" data-vmg-ad="Middle" data-vmg-format="normal"></div><p>Enjoy a classic brunch buffet with made-to-order omelets, fresh-pressed Belgian waffles, prime rib, and chilled snow crab legs. Moms receive a complimentary glass of sparkling ros&eacute; and bottomless mimosas and bloody marys for an extra $12. Brunch costs $26.95.</p><div id="ym_927398799965101214" class="ads centered yieldmo ym" data-vmg-ad="Yieldmo" data-yieldmo-id="927398799965101214"></div><div class="img-box "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9315127/coco_asian_bistro-_crab_eggs_benedict_4_.jpg" alt="Crab eggs Benedict"><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9315127/coco_asian_bistro-_crab_eggs_benedict_4_.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Crab eggs Benedict</div>
<div class="cred">Courtesy of Cocoa Asian Bistro</div>
</td> </tr></tbody></table></div>
</div></div><p><b>Coco Asian Bistro</b><br><i> 11:30 a.m. to 3 p.m. at&nbsp;841 Cordova Rd., Fort Lauderdale;&nbsp;954-525-3541; </i><a href="http://cocoasianbistro.com" target="_blank"><i>cocoasianbistro.com.</i></a></p><p>Asian-inspired brunch includes variations on classics, such as crab eggs Benedict, pandan pancakes, and matcha mochi waffles. Prices range from $12 to $15. &nbsp;Unlimited mimosas and bloody marys are available for $19 per person. </p><div class="img-box "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9317403/council_oak_dining_room_lower_deck_3-2017_hi-res.jpg" alt="Mother's Day brunch at Council Oak Steaks &amp; Seafood offers unlimited Taittinger Brut La Fran&ccedil;aise."><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9317403/council_oak_dining_room_lower_deck_3-2017_hi-res.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Mother's Day brunch at Council Oak Steaks &amp; Seafood offers unlimited Taittinger Brut La Fran&ccedil;aise.</div>
<div class="cred">Courtesy of Council Oak Steaks &amp; Seafood</div>
</td> </tr></tbody></table></div>
</div></div><p><b>Council Oak Steaks &amp; Seafood</b><br><i> 10 a.m. to 2 p.m. at&nbsp;1 Seminole Way,&nbsp;Hollywood;&nbsp;954-327-7501; </i><a href="http://seminolehardrockhollywood.com" target="_blank"><i>seminolehardrockhollywood.com.</i></a></p><span class="inline-video" data-vmg-ad="Teads" data-vmg-track="2nd ad"></span><p>This classic steakhouse at the Seminole Hard Rock Hotel &amp; Casino offers Mother&rsquo;s Day brunch with unlimited Taittinger Brut La Fran&ccedil;aise by the glass. For $89 per person, guests can choose from an expansive buffet &mdash; offering omelets, Belgian waffles, bananas foster, carved meats, a full raw bar, pasta, and made-to-order sushi &mdash; as well as unlimited mimosas, bloody marys, sangria, bellinis, and spiked lemonade.</p><div class="img-box "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9313907/lbnutellawaffle.jpg" alt="Whole-grain waffle with Nutella."><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9313907/lbnutellawaffle.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Whole-grain waffle with Nutella.</div>
<div class="cred">Courtesy of Experimar</div>
</td> </tr></tbody></table></div>
</div></div><p><b>Louie Bossi Ristorante &amp; Pizzeria</b><br><i> 10 a.m. to 4 p.m. at&nbsp;1032 E. Las Olas Blvd., Fort Lauderdale;&nbsp;954-356-6699; and 120 E. Palmetto Park Rd., Boca Raton;&nbsp;561-336-6699; <a href="http://louiebossi.com" target="_blank">louiebossi.com</a>.</i></p><p>Snag a spot in the courtyard and enjoy favorites such as whole-grain Nutella waffles with toasted hazelnuts, chocolate, maple syrup, and butter ($12.50) or scrambled eggs on avocado toast with grilled artisan bread, arugula, and tomato salad ($13.50). Unlimited mimosas, bloody marys, Bossi bellinis, or Aperol spritzes cost $13 with purchase of an entr&eacute;e.</p><div class="img-box "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9317407/oceans_234_loungearea2.jpg" alt="Relax in Oceans 234 lounge.."><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9317407/oceans_234_loungearea2.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Relax in Oceans 234 lounge..</div>
<div class="cred">Courtesy of Oceans 234</div>
</td> </tr></tbody></table></div>
</div></div><p><b>Oceans 234</b> <br><i> 11:30 a.m. to 3 p.m. (complimentary family photos begin at 11 a.m.) at&nbsp;234 N. Ocean Dr., Deerfield Beach;&nbsp;954-428-2539; </i><a href="http://oceans234.com" target="_blank"><i>oceans234.com.</i></a></p><div class="ads middle placeholder" data-vmg-ad="Middle" data-vmg-format="lazy"></div><p>Complimentary family photos kick off Mother's Day brunch at this beachside eatery. Menu highlights include a very berry pancake stack with Knob Creek maple syrup, whipped wild-berry butter, and fresh berries ($13); sweet potato hash with poached eggs, turkey sausage, bell pepper, feta, kale, and multigrain toast ($14); lobster mac n' cheese with a half-pound lobster tail, rigatoni, and mascarpone cheese sauce ($37); macadamia mahi-mahi with coconut basmati, garlic green beans, and papaya mango salsa; and a crab-cake BLT.</p><p><b>Rocco's Tacos</b><br><i> 11:30 a.m. to 2:30 p.m. at&nbsp;1313 E. Las Olas Blvd., Fort Lauderdale;&nbsp;954-524-9550;&nbsp;additional locations at <a href="http://roccostacos.com" target="_blank">roccostacos.com</a>.</i></p><p>Enjoy brunch Mexican-style with huevos rancheros divorciados ($13) and a wet burrito con huevos ($12). For $12, add endless mimosas or bloody marys.</p><div class="img-box "><div class="inner-img-box">
<img src="http://images1.miaminewtimes.com/imager/u/745xauto/9317766/100.jpg" alt="Brunch with a view at Shooters."><a class="expand-link sprite" href="http://images1.miaminewtimes.com/imager/u/original/9317766/100.jpg" target="_blank" title="CLICK FOR FULL SIZE">EXPAND</a><div class="insert"><table><tbody><tr>
<td>
<div class="cap">Brunch with a view at Shooters.</div>
<div class="cred">Courtesy of Shooter's</div>
</td> </tr></tbody></table></div>
</div></div><p><b>Shooters Waterfront</b><br><i> 10 a.m. to 8 p.m. at&nbsp;3033 NE 32nd Ave., Fort Lauderdale;&nbsp;954-566-2855; <a href="http://shooterswaterfront.com" target="_blank">shooterswaterfront.com</a>.</i></p><p>Treat Mom to scenic views, a complimentary mimosa, and an assortment of artisanal cheesees, antipasto, salads, a prime-rib carving station, an omelet station, pancakes, desserts, and other goodies. Brunch costs $59 plus $20 for bottomless mimosas and bloody marys. Complimentary valet parking and boat docking are available.</p><p><b> Steak 954</b><br><i>11 a.m. to 3 p.m. at&nbsp;401 N. Fort Lauderdale Beach Blvd., Fort Lauderdale;&nbsp;954-414-8333; <a href="http://steak954.me" target="_blank">steak954.me</a>.</i></p><p>This classy waterfront spot is offering savory dishes such as a crab and avocado Benedict with tomato hollandaise ($18), short-rib Benedict on potato pancake ($15), Cuban-style egg sandwich ($14), and vanilla French toast with dulce de leche ($14). Steak 954 also has some new cocktails, including the Layover, made with Sailor Jerry spiced rum, house cold-brew, ginger, and lime ($14); Thames Lemonade, containing Fords gin, Dolin Genepy, basil, blackberry, and lemon bitters ($14); and Le Japonais, with VSOP Armagnac, Orgeat, Angostura, and&nbsp;Veuve Clicquot&nbsp;($14).<br></p>
                    </div>



    <div class="article-footer no-author">
        <div class="authorInfo">
                <ul class="follows">
        <!-- author -->
              

        <!-- section -->
            
                                    <li class="legend cityOnly">Follow:</li>
                
                                    <li class="fb fb-s">
                        <a href="https://www.facebook.com/cleanplatecharlie" target="_blank" title="facebook">New Times Broward-Palm Beach Food &amp Drink</a>
                    </li>
                    
                                    <li class="tw tw-s">
                        <a href="http://www.twitter.com/NewTimesBPBFood" target="_blank" title="twitter">New Times Broward-Palm Beach Food &amp Drink</a>
                    </li>
                
                    </ul>

        <div class="bottom-tabs">
            <div class="slider-tabs">
                <!-- get the topic objid to relate to the topicname using solr and use for these sliders -->
                <ul>
                    <li class="legend">Read More:</li>
                    <li><a class="active" href="/restaurants">Restaurants</a></li>
                                                                        <li><a class="city-color-back" href="/topic/lists-6386369">Lists</a></li>
                                                            </ul>
            </div>
        </div>
    </div>
</div>
    
        




    
    
    <div id="comments" class="comments">
    <a class="comment-bar fb-comment-bar" href="javascript:;"><span class="fb-comments-count" data-href="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437" ></span> Comment<span id="comS">s</span></a>
    <div id="fb-comment-data"
        data-href="http://www.browardpalmbeach.com/restaurants/mothers-day-2017-brunches-in-fort-lauderdale-8606437"
        data-width="100%"
        data-numposts="5"
        data-colorscheme="light">
    </div>
</div>

    <div class="vmgs widget subscribe" data-vmgs-widget="subscribe">
    <div class="welcome">
        <h3 data-vmgs-element="welcome-header">
            <span>Get the Food & Drink Newsletter</span>
                    </h3>
        <div data-vmgs-element="errors" data-vmgs-action-collapse="hide"></div>
        <p data-vmgs-element="welcome-message">Find out about upcoming events and special offers happening in the South Florida dining scene.</p>
    </div>
    <form action="javascript:;" method="post" id="subscribe-form">
        <input type="hidden" name="source_primary" value="8" />
        <input type="hidden" name="source_sub" value="23" />
        <fieldset>
                <div class="signup" data-vmgs-element="form">
                    <input type="hidden" name="section" value="restaurants" />
                    <input type="hidden" name="subs[]" value="14" />
                    <input type="text" name="email" data-vmgs-element="email" placeholder="someones.name@mail.com" tabindex="1" />
                    <button data-vmgs-element="expand" data-vmgs-action-expand="hide" data-vmgs-action-collapse="show">GO</button>
                </div>

                <div class="captcha-container hidden" data-vmgs-element="recaptcha" data-vmgs-action-expand="show" data-vmgs-action-collapse="hide">
                    <div id="inarticle-captcha" class="g-recaptcha" data-sitekey="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                </div>

                <div class="row hidden buttons" data-vmgs-action-expand="show" data-vmgs-action-collapse="hide">
                    <div class="col size-6">
                        <a href="javascript:;" class="button" data-vmgs-element="cancel" tabindex="4">Cancel</a>
                    </div>
                    <div class="col size-6">
                        <a href="javascript:;" class="button" data-vmgs-element="submit" tabindex="3">Submit</a>
                    </div>
                </div>
        </fieldset>
    </form>
</div>
<script type="text/javascript">
    if (typeof VMGSConfig == 'undefined') {
        VMGSConfig = {};
    }
    VMGSConfig.CityId      = 'bpb';
    VMGSConfig.MvnHostname = 'www.myvoicenation.com';
    VMG.captchaQueue.queue(function(){
        VMG.activeCaptcha = grecaptcha.render('inarticle-captcha',{
            'sitekey' : $('#inarticle-captcha').data('sitekey')
        });
    });
</script>
<script type="text/javascript" src="/v_m_g_s/js/vmgs.js"></script>
            <!-- wibbitz div -->
        <div class="wibbitz-wrap">
            <div wibbitz="embed-player-widget"></div>
        </div>
    
</section>



    <div class="city-color-back-superlight bottomBlock">
    <!-- bottom lists for demo per jh -->
        <div class="bottom-lists">
            <div class="bottom-list incase">
                    <h2>In Case You Missed It</h2>
    <ul>
                    <li>
                <a class="headline" href="/restaurants/ten-best-taco-tuesday-deals-in-broward-and-palm-beach-6933938" onClick="ga('send', 'event', 'VMG-Widget', 'Click', 'Article-VMG-Restaurants-ICYMI',  {'NonInteraction': 1});">Ten Best Taco Tuesday Deals in Broward and Palm Beach</a>
            </li>
                    <li>
                <a class="headline" href="/restaurants/tim-swanky-glazner-explores-tiki-culture-and-rare-cocktails-in-mai-kai-history-and-mystery-of-the-iconic-tiki-restaurant-8045463" onClick="ga('send', 'event', 'VMG-Widget', 'Click', 'Article-VMG-Restaurants-ICYMI',  {'NonInteraction': 1});">Tim "Swanky" Glazner Explores Tiki Culture and Rare Cocktails in...</a>
            </li>
                    <li>
                <a class="headline" href="/restaurants/big-storm-brewing-sues-due-south-brewing-asks-judge-for-clarification-on-the-word-category-8038978" onClick="ga('send', 'event', 'VMG-Widget', 'Click', 'Article-VMG-Restaurants-ICYMI',  {'NonInteraction': 1});">Big Storm Brewing Sues Due South Brewing, Asks Judge for...</a>
            </li>
                    <li>
                <a class="headline" href="/restaurants/create-your-own-poke-bowl-or-sushi-burrito-at-raw-poke-bar-in-fort-lauderdale-8001269" onClick="ga('send', 'event', 'VMG-Widget', 'Click', 'Article-VMG-Restaurants-ICYMI',  {'NonInteraction': 1});">Create Your Own Poke Bowl or Sushi Burrito at Raw Poke Bar in Fort...</a>
            </li>
            </ul>
            </div>
            <div class="bottom-list tmaster justPop">
                    <h2>Popular Stories</h2>
    <ul>
            <li>
            <a href="/restaurants/march-2017s-south-florida-restaurant-openings-and-closings-8532189">March 2017's Fort Lauderdale and Palm Beach Restaurant Openings...</a>
        </li>
            <li>
            <a href="/restaurants/twelve-new-breweries-opening-in-fort-lauderdale-and-west-palm-beach-8520262">Twelve New Breweries in Broward and Palm Beach Counties to Look...</a>
        </li>
            <li>
            <a href="/restaurants/point-royal-at-diplomat-beach-resort-in-hollywood-florida-restaurant-review-8547419">Geoffrey Zakarian's Point Royal at the Diplomat Is Not a Typical...</a>
        </li>
            <li>
            <a href="/restaurants/noor-bakery-and-deli-in-fort-lauderdale-restaurant-review-8593334">Humble, Hearty Flatbreads at Fort Lauderdale's Noor Bakery and Deli</a>
        </li>
        </ul>
            </div>
            <div class="bottom-list relaround">
        <h2 class="no-show">&nbsp;</h2>
    <ul>
            <li>
            <a href="/restaurants/doordash-expands-service-in-miami-and-broward-8565660">Food Delivery Service DoorDash Expands to North Miami and Broward</a>
        </li>
            <li>
            <a href="/restaurants/michael-schulsons-japanese-restaurant-monkitail-opens-at-diplomat-beach-resort-in-hollywood-florida-8583677">A Sneak Peak Into Michael Schulson's Monkitail, Opening...</a>
        </li>
            <li>
            <a href="/restaurants/the-ten-best-margaritas-in-south-florida-8449137">The Ten Best Margaritas in South Florida</a>
        </li>
            <li>
            <a href="/restaurants/april-2017-south-florida-restaurant-openings-and-closings-8593343">April 2017's Broward and Palm Beach Restaurant Opening and...</a>
        </li>
        </ul>
            </div>
        </div>

        <div class="bottomlinks">
                <div id="rcjsload_1"></div>
    <script type="text/javascript">
    (function() {
    var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
    var rcel = document.createElement("script");
    rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
    rcel.type = 'text/javascript';
    rcel.src = "http://trends.revcontent.com/serve.js.php?w=14341&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
    rcel.async = true;
    var rcds = document.getElementById("rcjsload_1"); rcds.appendChild(rcel);
    })();
    </script>
        </div><!-- /.bottomlinks -->

        <div class="sharethrough-placement">
            <div class="ads sharethrough" data-vmg-ad="Sharethrough" data-vmg-format="normal" data-vmg-text="Sharethrough"></div>        </div>
                        <div class="convert-media-placement">
            <div class="convert-media-ad">
    <hr class="convert-media-hr" />
    <p class="convert-media-sponsored">Sponsor Content</p>
        <script type="text/javascript">var pran = Math.floor(Math.random()*99999999999);var ppstn = "ENTER_PLACEMENT_ID_HERE";var purl = "//15.basebanner.com/BidRHanSer?oid=15&width=728&height=90&pubid=155467&tagid=930557&revmod=INSERT_CONTENT_TYPE&encoded=1&callback=document.write&urlonly=1";document.write ("<scr"+"ipt type='text/javascript' src='"+purl);document.write ('&amp;pstn=' + ppstn);document.write ('&amp;cb=' + pran);var cisrf = "";var cirf = document.referrer;var win = window;try {while (win != win.top) {win = win.top;}if (win.location.href) {cirf = win.location.href; cisrf=win.document.referrer}} catch (e) {}document.write ("&amp;cirf=" + encodeURIComponent(cirf));document.write ("&amp;cisrf=" + encodeURIComponent(cisrf));document.write ("'></scr"+"ipt>");</script>
</div>
        </div>
        
                <div class="kitara-placement">
            <div class="kitara-ad">
	<script type="text/javascript">var pran = Math.floor(Math.random()*99999999999);var ppstn = "ENTER_PLACEMENT_ID_HERE";var purl = "//15.basebanner.com/BidRHanSer?oid=15&width=4,728&height=4,15&pubid=155467&tagid=892827&revmod=INSERT_CONTENT_TYPE&encoded=1&callback=document.write&urlonly=1";document.write ("<scr"+"ipt type='text/javascript' src='"+purl);document.write ('&amp;pstn=' + ppstn);document.write ('&amp;cb=' + pran);var cisrf = "";var cirf = document.referrer;var win = window;try {while (win != win.top) {win = win.top;}if (win.location.href) {cirf = win.location.href; cisrf=win.document.referrer}} catch (e) {}document.write ("&amp;cirf=" + encodeURIComponent(cirf));document.write ("&amp;cisrf=" + encodeURIComponent(cisrf));document.write ("'></scr"+"ipt>");</script>
</div>
        </div>
        
    </div>







<!-- next article load here, include .content-view section -->




<script type="text/javascript" src="//cdn4.wibbitz.com/broward_palm_beach/embed.js" async></script>
                </div><!-- /.content -->

                <div class="footer">

    <div class="ads bottom" data-vmg-ad="Bottom" data-vmg-format="normal"></div>
    <p>&copy;2017 New Times BPB, LLC. All rights reserved.</p>

</div>
<script type='text/javascript' data-sailthru-setup="true" src='http://ak.sail-horizon.com/onsite/personalize.v0.0.4.js'></script>

<script type='text/javascript'>
	VMG.Components.Adblock = true;
</script>
	<script type='text/javascript'>
$(function(){
	VMG.Components.PersonalizeComponent.SPM = Sailthru.SPM;
	VMG.Components.PersonalizeComponent.SPM.setup("b09c5f4a0da5ce54e5ccccb6a407cd6e");
	if (VMG.Components.PersonalizeComponent.blocks.length > 0){
		VMG.Components.PersonalizeComponent.personalize();
	}
});
</script>

            </div><!-- /.container-fluid -->
        </div><!-- /.all-body -->
    </div><!-- /.wrapper -->

    
            
            <script type="text/javascript" data-vmg-ad-script="">
                if (VMG && VMG.Ads) {
                    VMG.Ads.init({"url":"oascentral.browardpalmbeach.com","positions":["Middle","Sharethrough","Frame","Top","Bottom"],"site_page":"www.browardpalmbeach.com/restaurants","query":"XE&Category=Restaurants&Subcategory=Articles&XE","debug":0,"sharethroughKeys":{"desktop":"d8dca4d1","tablet":"d8dca4d1","mobile":"3e9d0b0e"},"sharethroughPlacement":"article"});
                }
            </script>
        
            <script type="text/javascript" src="/js_cache/content-view.js?buildId=1494364743"></script><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><script type="text/javascript">
var pidChange;
var site_pathname = window.top.location.pathname;
if (site_pathname.match(/restaurants/g)) {
  pidChange = 50451;
} else if (site_pathname.match(/film/g)) {
  pidChange = 50450;
} else if (site_pathname.match(/news/g)) {
  pidChange = 50449;
} else if (site_pathname.match(/music/g)) {
  pidChange = 50448;
} else if (site_pathname.match(/arts/g)) {
  pidChange = 50447;
} else {
  pidChange = 43012;
}

if(pidChange == 55555) {
    $.ajax({
      url: 'https://embed.tidal.com/tidal-embed.js',
      dataType: 'script',
      async: true
    });
    document.getElementsByClassName('inline-video')[0].innerHTML = '<div class="tidal-embed" data-type="v" data-id="69999052"></div>';
 } else {
window._ttf = window._ttf || [];
_ttf.push({
       pid          : pidChange
       ,lang        : "en"
       ,slot        : ".content-view .the-story > p + p"
       ,format      : "inread"
       ,avoidSlot   : { slot: '.ads, .rel-stories, .img-box, .pullquote, .side-tmaster', dist: 20 }
       ,components  : { skip: {delay : 0}}
       ,css         : "margin: 0px auto 10px; max-width: 550px;"
});

(function (d) {
        var js, s = d.getElementsByTagName('script')[0];
        js = d.createElement('script');
        js.async = true;
        js.src = '//cdn.teads.tv/media/format.js';
        s.parentNode.insertBefore(js, s);
})(window.document);
}
</script><script type="text/javascript">

    if (!window.VMG) {
        window.VMG = {};
    }
    if (!window.VMG.params) {
        window.VMG.params = {};
    }
    window.VMG.params.social = {"title":"Best Broward Brunch Spots for Mother's Day 2017","url":"http:\/\/www.browardpalmbeach.com\/restaurants\/mothers-day-2017-brunches-in-fort-lauderdale-8606437","twitterUser":"NewTimesBPBFood","twitterHashtag":""};

    window.VMG.params.pubName = 'New Times Broward-Palm Beach';
    window.VMG.params.domainName = 'browardpalmbeach.com';
</script>
<script type="text/javascript" src="/js_cache/ads.js?buildId=1494364743"></script>    <script type="text/javascript" src="http://assets.myvoicenation.com/load/js/2/omni.js"></script>
    <script type="text/javascript">
   if (typeof Popularity === 'undefined') {
       var Popularity = {};
   }
   Popularity.item = {"ObjId":"8606437","ObjectType":"Content","PubId":"bpb","PublishDate":"2017-05-08","CategoryId":"6386285","CategoryName":"Clean Plate Charlie","SectionId":"6305867","SectionName":"Restaurants","Topics":{"6386369":"Lists"},"Authors":{"8031767":"Alona Abbady Martinez"}};
</script>        <script type="text/javascript" src="/js_cache/omni-bindings.js?buildId=1494364743"></script>    <script type="text/javascript">
    var omniInitialConfig = {"cid":"bpb","sid":"8|24|","localPath":"\/","authDomain":"www.myvoicenation.com","appId":"af0de900cb1523cff511678c56886255"};
    if(window.MVN){
        MVN.onReady(function(){
                        MVN.init(omniInitialConfig);
        });
    }
</script>        
    <div id="fb-root"></div>
    <script>(function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=154555581257317&version=v2.3";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, 'script', 'facebook-jssdk'));
    </script>
    <script>
        !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');
    </script>
    <script type="text/javascript">
$('document').ready(function() {
    if (typeof(Storage) !== "undefined") {
        // Only do ticketmaster national calls if sessionStorage is possible.
        window.VMG.nationalTM = {
            storageKey: 'vmg-bpb-nat-tm',
            results: {},
            natTmClickrefs: [],
            natTmSections: [],
            render: function(tmKey, data) {
                if (data === null || data == '') {
                    return;
                }
                $('.nat-tm[data-clickref='+tmKey+']').parent().find('h2').html('Events Near You');
                $('.nat-tm[data-clickref='+tmKey+']').html(data);
            },
            getDistanceFromLatLonInMi: function (lat1,lon1,lat2,lon2) {
              var R = 3963; // Radius of the earth in miles
              var dLat = this.deg2rad(lat2-lat1);
              var dLon = this.deg2rad(lon2-lon1);
              var a =
                Math.sin(dLat/2) * Math.sin(dLat/2) +
                Math.cos(this.deg2rad(lat1)) * Math.cos(this.deg2rad(lat2)) *
                Math.sin(dLon/2) * Math.sin(dLon/2);
              var c = 2 * Math.atan2(Math.sqrt(a), Math.sqrt(1-a));
              var d = R * c; // Distance in km
              return d;
            },
            deg2rad: function (deg) {
              return deg * (Math.PI/180);
            }
        };
        window.VMG.nationalTM.results = JSON.parse(sessionStorage.getItem(window.VMG.nationalTM.storageKey));
        if ($('.nat-tm:visible').length == 0) {
            return;
        }
        if (!window.VMG.nationalTM.results) {
            window.VMG.nationalTM.results = {};
        }
        window.VMG.nationalTM.natTmClickrefs = $('.nat-tm:visible').map(function() { return $(this).data('clickref'); });
        window.VMG.nationalTM.natTmSections = $('.nat-tm:visible').map(function() { return $(this).data('section'); });
        // Make sure a ticket section actually exists on the page, add nat-tm class or something to them.

        if (window.VMG.Utils.checkGeoSupported()) {
            window.VMG.Utils.getGeoLocation(function(clientLat, clientLng) {
                var distance = window.VMG.nationalTM.getDistanceFromLatLonInMi(
                    clientLat, clientLng,
                    26.51033, -80.23864);
                if (distance > 100) {
                    for (var i=0; i < window.VMG.nationalTM.natTmClickrefs.length; i++) {
                        var tmKey = window.VMG.nationalTM.natTmClickrefs[i];
                        var tmSection = window.VMG.nationalTM.natTmSections[i];
                        if (typeof window.VMG.nationalTM.results[tmKey] == 'undefined') {
                            $.ajax(
                                "/national/ticketmaster",
                                {
                                    dataType: 'json',
                                    data: {
                                        section: tmSection,
                                        clickref: tmKey,
                                        page: i+1
                                    },
                                    success: function(data) {
                                        window.VMG.nationalTM.results[data.tmKey] = data.data;
                                        window.VMG.nationalTM.render(data.tmKey, window.VMG.nationalTM.results[data.tmKey]);
                                        sessionStorage.setItem(window.VMG.nationalTM.storageKey, JSON.stringify(window.VMG.nationalTM.results));

                                    }
                                }
                            );
                        } else {
                            window.VMG.nationalTM.render(tmKey, window.VMG.nationalTM.results[tmKey]);
                        }
                    }
                }
            },
            function() {
                // do nothing if we don't have geolocation stuff
            });
        }
    }
});
</script>
    <script src="https://apis.google.com/js/platform.js" async defer></script>
    <script type="text/javascript" src="https://www.google.com/recaptcha/api.js?onload=captchaCallback&render=explicit" async defer></script>
        
<div style="display: none">


<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '578316758957526'); // Insert your pixel ID here.
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=578316758957526&ev=PageView&noscript=1"/></noscript>

        <script data-cfasync="false" type="text/javascript">(function(s,o,l,v,e,d){if(s[o]==null&&s[l+e]){s[o]="loading";s[l+e](d,l=function(){s[o]="complete";s[v+e](d,l,!1)},!1)}})(document,"readyState","add","remove","EventListener","DOMContentLoaded");(function(){var s=document.createElement("script");s.type="text/javascript";s.async=true;s.src="//cdn.engine.4dsply.com/Scripts/infinity.js.aspx?guid=f8c2ee54-4a57-46c2-b87c-bb23aaa81d66";s.id="infinity";s.setAttribute("data-guid","f8c2ee54-4a57-46c2-b87c-bb23aaa81d66");s.setAttribute("data-version","async");var e=document.getElementsByTagName('script')[0];e.parentNode.insertBefore(s,e)})();</script>




<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    var _sf_async_config = {};
    _sf_async_config.uid = 10424;
    _sf_async_config.domain = 'browardpalmbeach.com';
    _sf_async_config.useCanonical = true;
        _sf_async_config.sections = '/restaurants';
        _sf_async_config.authors = 'Alona Abbady Martinez';
    (function() {
       function loadChartbeat() {
           window._sf_endpt = (new Date()).getTime();
           var e = document.createElement('script');
           e.setAttribute('language', 'javascript');
           e.setAttribute('type', 'text/javascript');
           e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
           document.body.appendChild(e);
       }
       var oldonload = document.ready;
       document.ready = (typeof document.ready != 'function') ? loadChartbeat : function() {
           oldonload();
           loadChartbeat();
       };
   })();
</script>
<!--  Quantcast Tag -->
<script>
 var ezt = ezt ||[];

 (function(){
   var elem = document.createElement('script');
   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem,scpt);
 }());


 ezt.push({qacct: 'p-a4LDpi_DEopn-',
       uid: ''
           });
</script>
<noscript>
  <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast Tag -->


</div>
    



    


<div id="desktopSubModal" class="desktopSubModal">

    <div id="main-container" class="subscribe-modal-main">
        <div class="modalClose closeMod"></div>
        <img src="/theme/bpb/img/logo-black.png" class="header" title="Get Connected!" alt=""/>        <h2>Newsletters</h2>
        <form id="subscribe">
            <div id="left">
                <p>All-access pass to the top stories, events and offers around town.</p>
                <ul class="subscriptions">
                    <li class="topStories">Top Stories
                        <div class="checkboxes">Send: 
                        </div>
                    </li>
                </ul>
            </div>
            <!-- right -->
            <div id="right">
                <input type="text" placeholder="email..." id="email" name="email">
                <div class="captcha">
                    <div id="subscribe-recaptcha" data-sitekey="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                </div>

                <div class="buttons">
                    <button type="button" id="sign-up">Sign Up <span>&gt;</span></button>
                    <button type="button" id="remind-me-later" class="closeMod remindLater">Remind Me Later <span>&gt;</span></button>
                    <button type="button" id="no-thanks" class="closeMod">No Thanks <span>&gt;</span></button>
                </div>
                <a href="/about/privacyPolicy/" class="privacyPolicy" target="_blank">Privacy Policy</a>
            </div>
        </form>
    </div>
</div>
<script type="text/javascript">
    window.VMG.hasDailyNL = 0;
    $('#desktopSubModal #email').on('focus', function(e){
        $('.subscribe-modal-main .captcha').show();
    })
    VMG.captchaQueue.queue(function(){
        grecaptcha.render('subscribe-recaptcha',{
            'sitekey' : $('#subscribe-recaptcha').data('sitekey')
        })
    })
</script>
    

    <div class="mobileSubModal">
        <div class="modalClose closeMod"></div>
        <h1 class="newsletters">Newsletters</h1>
        <p>All-access pass to top stories, events and offers around town.</p>
        <div class="sub_selections">
            <ul class="mob-sub-mod-subs">
            </ul>
        </div>
        <div id="desktop_modal">
            <div class="input-contain">
                <input type="text" name="subEmail" placeholder="email address" id="subEmail" />
            </div>
        </div>
        <h2>
            <a class="subFormLink" href="/profile/mobileSubscribe?url=http%3A%2F%2Fwww.browardpalmbeach.com%2Frestaurants%2Fmothers-day-2017-brunches-in-fort-lauderdale-8606437">Sign Up &gt;</a>
        </h2>
        <h4 class="closeMod">No Thanks!</h4>
        <div class="subRemind">
            <h3 class="remindLater closeMod">Remind Me Later &gt;</h3>
        </div>
    </div>

    

</body>
</html>
