





























































    
         
    <!DOCTYPE html>
<html class="uk-root" lang="en">
<head>
<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=6906e7bba601d78e3c25fe2d85f0fc38" />
<script src="/fdn-system/assets/pub/scripts/uikit.js"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.js"></script>
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta charset="UTF-8">
<meta name="layout" content="Content Default - Multiple (Responsive, Air)" />
<meta name="oid" content="11767450" />
<script>
window.__FOUNDATION_RESPONSIVE__ = true
// 
window.__FBAPIv__ = 'v3.2'
// 
</script>
<!--[if lte IE 8]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
<![endif]-->
<script>
if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
</script>
<script src="/foundation/scripts/common.js?cb=f9da370d9abb1a7a958b18b185e9e139"></script>
<script src="/foundation/scripts/foundation-air.js?cb=f9da370d9abb1a7a958b18b185e9e139"></script>
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: Whole Site" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: Music Section" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml?oid=6305870" />
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: County Grind" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml?oid=6386287" />
<script>
// rrr - What is this? 
fixupProfileLinks("https:\/\/www.browardpalmbeach.com\/browardpalmbeach\/Profile", "https:\/\/posting.browardpalmbeach.com\/browardpalmbeach\/MyProfile");
</script>
<meta name="google-signin-client_id" content="8236563300-isg7q42t0f897pmj090770umn1c5t1dt.apps.googleusercontent.com">
<!-- include: admin -->
<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Oswald:wght@300;400;700&family=Roboto+Condensed:wght@300;400;700&family=Roboto+Slab:wght@400;700&family=Roboto:wght@100;300;400;500;700&display=swap" rel="stylesheet">
<style>
:root {
--primary-color: #009;
--alt-primary-color: #900;
}
</style>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<!-- Pelcro init. -->
<script>
var Pelcro = window.Pelcro || (window.Pelcro = {});
Pelcro.siteid = "1022";
Pelcro.environment = {
"ui": "https://js.pelcro.com/ui/plugin/west-word/main.min.js"
};
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.Pelcro = window.Foundation.Pelcro || {};
Foundation.Pelcro.init = function () {
if (typeof(Foundation.Pelcro.user) === 'undefined' &&
typeof(Pelcro) === "object" &&
typeof(Pelcro.user) === "object" &&
Pelcro.user.isAuthenticated()) {
var user = Pelcro.user.read();
if (typeof(user) === "object" && !jQuery.isEmptyObject(user)) {
Foundation.Pelcro.user = user;
if (typeof(Foundation.Pelcro.user.subscriptions) === "object" &&
!jQuery.isEmptyObject(Foundation.Pelcro.user.subscriptions) &&
Foundation.Pelcro.user.subscriptions.length > 0) {
var subscription = Foundation.Pelcro.user.subscriptions[0];
if (subscription.status == "active") {
Foundation.Pelcro.subscription = subscription.plan.product.name;
}
}
jQuery(document).ready(function($) {
$(".pelcro-logout-button").click(function() {
Pelcro.user.logout();
});
$(".pelcro-logged-in").show();
$(".pelcro-logged-out").hide();
var email = Foundation.Pelcro.user.email;
if (email) {
var username = email;
if (username.length > 26) {
username = username.split("@", 1)[0];
}
$(".pelcro-user-name").html(username);
}
});
}
}
return (typeof(Foundation.Pelcro.user) === "object");
};
document.addEventListener("PelcroUserLogin", function (e) {
});
document.addEventListener("PelcroUserLogout", function (e) {
});
document.addEventListener("PelcroUserLoaded", function (e) {
Foundation.Pelcro.init();
});
</script>
<script async="" src="https://js.pelcro.com/sdk/main.min.js" type="text/javascript"></script>
<!-- End Pelcro init. -->
<!-- Pelcro default styles. -->
<style>
.pelcro-logged-in {display:none;}
</style>
<!-- End Pelcro default styles. -->
<style>
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn {
background: #900 !important;
border-color: #900 !important;
background-image: none !important;
}
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:focus,
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:hover
{
background: #900 !important;
border-color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-link, #pelcro-app .pelcro-prefix-view a{
color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval .active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-plan-item.active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval button {
color: #900 !important;
}
</style>
<script>
// 
var Foundation = window.Foundation || {};
Foundation.Pelcro = window.Foundation.Pelcro || {};
Foundation.Pelcro.pollCount = 0;
Foundation.Pelcro.pollForUser = setInterval(function() {
// 
if (Foundation.Pelcro.init() || Foundation.Pelcro.pollCount >= 100) {
// 
if (Foundation.Pelcro.init()) {
// 
var email = Foundation.Pelcro.user.email;
if (email) {
// 
jQuery(function() {
jQuery.get("https://posting.browardpalmbeach.com/browardpalmbeach/API/Sailthru/User", {"email": email}).done(function(data) {
// 
var newsletters = data.newsletters;
if (Array.isArray(newsletters) &&
newsletters.length > 0) {
jQuery("div.MySubscriptions input[type='checkbox'][name='newsletter']").each(function (i, v) {
var e = jQuery(v);
var oid = e.data("fdnOid");
if (oid) {
e.prop("checked", (jQuery.inArray(oid, newsletters) !== -1)).change();
e.closest(".fdn-subscriptions-special-member-placement").toggleClass("fdn-subscriptions-special-member-placement", (jQuery.inArray(oid, newsletters) === -1));
}
});
}
// 
var token = data.token;
if (token) {
// 
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
var oid = jQuery(this).data("fdnOid");
if (oid) {
var request = {
"token": token
};
request[this.checked?"subscribe":"unsubscribe"] = oid;
jQuery.post(
"https://posting.browardpalmbeach.com/browardpalmbeach/API/Sailthru/User",
request
);
}
}).prop('disabled', false);
}
});
});
}
}
// 
else {
// 
}
clearInterval(Foundation.Pelcro.pollForUser);
if (Foundation.Pelcro.subscription == "Member" ||
Foundation.Pelcro.subscription == "Donor") {
jQuery("div.MySubscriptions .fdn-subscriptions-special-member-placement").removeClass("fdn-subscriptions-special-member-placement");
}
// 
if (Foundation.Pelcro.subscription == "Member") {
jQuery('[fdn-ad-component]').remove()
// One more time on document ready
jQuery(function() { jQuery('[fdn-ad-component]').remove() });
// 
}
// 
else {
if(window.Foundation && Foundation.ApnAds && typeof Foundation.ApnAds.setup === 'function') {
Foundation.ApnAds.setup();
}
// 
}
}
// 
else {
Foundation.Pelcro.pollCount++;
}
}, 30);
// 
jQuery(document).on("PelcroUserLogin", function (e) {
setTimeout(function() {
console.log(jQuery('body').removeClass('pelcro-modal-open').attr('class'))
}, 10);
});
// 
jQuery(function() {
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
jQuery(this).siblings('.fdn-subscriptions-column-item-subscribed-header').text(this.checked?'Subscribed':'Unsubscribed');
}).change();
});
</script>
<meta name="ir-site-verification-token" value="-1062343762"/>
<meta property="fb:pages" content="68098170202"/>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<!-- AdMacros.html: /Macros/Ads/bpb/Home -->
<script>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</script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-395255-25', { 'siteSpeedSampleRate': 5 });
ga('set', 'dimension2', 'Music');
ga('set', 'dimension3', '11767450');
ga('set', 'dimension4', '2021-07-16 11:20:00');
ga('set', 'dimension5', 'Lists%Music Festivals%Things To Do');
ga('set', 'dimension6', 'Tony M. Centeno');
ga('set', 'dimension7', 'Articles');
ga('send', 'pageview');
</script>
<!-- include: layout -->
<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.SailthruSPM = window.Foundation.SailthruSPM || (window.Foundation.SailthruSPM = {});
Foundation.SailthruSPM.Personalize = function(options) {
const selector = options.selector;
const data = options.data;
const template = (typeof(options.template) === "function") ? options.template : (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`;
if (!selector) {
return;
}
else if (data.length == 0) {
return;
}
const elements = document.querySelectorAll(selector);
if (elements.length == 0) {
return;
}
const articles = JSON.parse(data.json);
const count = options.count ? options.count : articles.length;
const html = articles.slice(0, count).map(template);
elements.forEach(
element => {
if (!element.classList.contains("sailthruSPMLoaded")) {
element.innerHTML = html.join('');
element.classList.add("sailthruSPMLoaded");
}
}
);
}
Sailthru.init({
"isCustom": true,
"customerId": "b09c5f4a0da5ce54e5ccccb6a407cd6e"
});
</script>
<!-- include: section -->
<!-- include: category -->
<!-- include: page -->
<!-- include: microsite -->
<!-- include: content -->
<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Rolling Loud 2021: Ten Best Miami Rappers at the Festival | New Times Broward-Palm Beach" />
<meta name="description" content="From Rick Ross to City Girls and Ski Mask the Slump God, there are plenty of Miami rappers on the Rolling Loud 2021 lineup." />
<meta name="keywords" content="Rolling Loud Miami, Hard Rock Stadium, tickets, music festival, City Girls, Rick Ross, Hood Brat, Tafia, FSO Dinero, Ski Mask the Slump God" />
<title>Rolling Loud 2021: Ten Best Miami Rappers at the Festival | New Times Broward-Palm Beach</title>
<meta name="date" content="2021-07-16 11:20:00" />
<meta name="author" content="Tony M. Centeno">
<meta name="news_keywords" content="rolling loud miami, hard rock stadium, tickets, music festival, city girls, rick ross, hood brat, tafia, fso dinero, ski mask the slump god" />
<link rel="image_src" href="https://media2.fdncms.com/bpb/imager/u/slideshow/11767439/10-south-florida-artists-performing-rolling-loud.jpeg" />
<meta name="thumbnail" content="https://media2.fdncms.com/bpb/imager/u/slideshow/11767439/10-south-florida-artists-performing-rolling-loud.jpeg" />
<link rel="canonical" href="https://www.miaminewtimes.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-12473340" />
<link rel="amphtml" href="https://www.browardpalmbeach.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450?media=AMP+HTML" />
<meta property="og:url" content="https://www.miaminewtimes.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-12473340" />
<meta property="fb:app_id" content="835681050493442" />
<meta property="og:site_name" content="New Times Broward-Palm Beach" />
<meta property="og:title" content="Rolling Loud 2021: Ten Best Miami Rappers at the Festival | New Times Broward-Palm Beach" />
<meta property="og:image" content="https://media2.fdncms.com/bpb/imager/u/slideshow/11767439/10-south-florida-artists-performing-rolling-loud.jpeg" />
<meta property="og:image:width" content="1524" />
<meta property="og:image:height" content="980" />
<meta property="og:description" content="From Rick Ross to City Girls and Ski Mask the Slump God, there are plenty of Miami rappers on the Rolling Loud 2021 lineup." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.fdncms.com/bpb/imager/u/slideshow/11767439/10-south-florida-artists-performing-rolling-loud.jpeg">
<meta name="twitter:creator" content="@_tonymc">
<meta name="twitter:site" content="@newtimes_bpb">
<meta name="twitter:title" content="Rolling Loud 2021: Ten Best Miami Rappers at the Festival | New Times Broward-Palm Beach">
<meta name="twitter:description" content="Rolling Loud was born and raised in the county of Dade.">
<!--
<PageMap>
<DataObject type="foundation">
<Attribute name="oid">11767450</Attribute>
<Attribute name="class">Content</Attribute>
<Attribute name="lastmodified">20210716112038</Attribute>
<Attribute name="creationdate">20210716111953</Attribute>
</DataObject>
<DataObject type="document">
<Attribute name="releasedatetime">20210716112000</Attribute>
<Attribute name="releasedate">20210716</Attribute>
<Attribute name="releaseepoch">1626448800</Attribute>
<Attribute name="title">Rolling Loud 2021: Ten Best Miami Rappers at the Festival | New Times Broward-Palm Beach</Attribute>
<Attribute name="author">11295986</Attribute>
<Attribute name="authorname">Tony M. Centeno</Attribute>
<Attribute name="authorsortname">Centeno, Tony M.</Attribute>
</DataObject>
</PageMap>
-->
<script type="application/ld+json">
{
"mainEntityOfPage": {
"@type": "WebPage",
"@id":"https:\/\/www.browardpalmbeach.com\/music\/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450"
},
"headline": "Ten South Florida Artists to Watch at Rolling Loud 2021",
"description": "Rolling Loud was born and raised in the county of Dade.",
"image": {
"url": "https:\/\/media2.fdncms.com\/bpb\/imager\/u\/original\/11767439\/10-south-florida-artists-performing-rolling-loud.jpeg",
"width": 1400,
"height": 900,
"@type": "ImageObject"
},
"datePublished": "2021-07-16T11:20:00",
"dateModified": "2021-07-16T11:20:38",
"author": {
"name": "Tony M. Centeno",
"@type": "Person"
},
"publisher": {
"name": "New Times Broward-Palm Beach",
"logo": {
"url": "https:\/\/www.browardpalmbeach.com\/imager\/b\/google-amp-logo\/808579\/99a2\/binary-viewer.png",
"width": 1320,
"height": 816,
"@type": "ImageObject"
},
"@type": "Organization"
},
"@context": "https://schema.org",
"@type": "NewsArticle"
}
</script>
<script>window.twttr = (function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0],
t = window.twttr || {};
if (d.getElementById(id)) return t;
js = d.createElement(s);
js.id = id;
js.src = "https://platform.twitter.com/widgets.js";
fjs.parentNode.insertBefore(js, fjs);
t._e = [];
t.ready = function(f) {
t._e.push(f);
};
return t;
}(document, "script", "twitter-wjs"));</script>
</head>
<script src="/fdn-system/assets/pub/scripts/ResizeSensor.js"></script>
<script src="/fdn-system/assets/pub/scripts/ElementQueries.js"></script>
<script>
ElementQueries.listen();
</script>
<body id="Content" class="ContentDefault countygrind music RespOneCol">
<script>
ElementQueries.init();
</script>
<div id="fdn-navigation-dropdown-hook" style="width:100%;height:0;position:fixed;"></div>
<div id="fb-root"></div>
<script>
(function () {
var app = new Foundation.Facebook.Application();
app.receiveAuthNotifications();
app.receiveLikeNotifications();
})();
</script>
<script>
(function () {
var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
//if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
}.bind(this), function(){
if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
})
})()
</script>
    





<div id="ContentDefault" class="grid-resp-1 page layout-ContentDefault">
  <div class="ev-grid-layout ev-clamp@m ev-clamp@l">

    <div class="ev-grid-zone ev-leader-zone">
      <div class="ev-grid-col uk-width-1-1" data-ev-zone="Leader">
        
      </div>
    </div>

    <div class="ev-grid-zone ev-header-zone">
      <div class="ev-grid-col uk-width-1-1" data-ev-zone="GlobalHeader">
        



  
    
    
    <div uk-sticky class="GlobalHeader ContentDefaultMultiple   uk-root fdn-margin-vert SiteHeaderGrid comp-shell-siteheader" data-component-id="SiteHeaderGrid">
<div class="fdn-site-header-flex">
<div class="fdn-site-header-nav-toggle-narrow uk-hidden@sm">
<a href="#offcanvas-slide-navigation" 
class="fdn-nav-toggle uk-button" uk-toggle>
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="offcanvas-slide-navigation" uk-offcanvas="overlay: true">
<div id="site-nav-target" class="fdn-nav-panel-block uk-offcanvas-bar">
<ul class="site-nav-source uk-width-1-1 uk-nav uk-nav-parent-icon" uk-nav="multiple: false;">
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestNews">
<a href="https://www.browardpalmbeach.com/news" onclick="ga("send", "event", "Nav", "Click", "Latest News")" target="_self">News<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/news" onclick="ga("send", "event", "Nav", "Click", "Latest News")"  target="_self" title="">Latest News</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/coronavirus-10624039" onclick="ga("send", "event", "Nav", "Click", "Coronavirus")"  target="_self" title="">Coronavirus</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/environmental-6386358" onclick="ga("send", "event", "Nav", "Click", "Environmental")"  target="_self" title="">Environmental</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/politics-6386326" onclick="ga("send", "event", "Nav", "Click", "Politics")"  target="_self" title="">Politics</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestFoodDrink">
<a href="https://www.browardpalmbeach.com/restaurants" onclick="ga("send", "event", "Nav", "Click", "Latest Food & Drink")" target="_self">Food &amp; Drink<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/restaurants" onclick="ga("send", "event", "Nav", "Click", "Latest Food & Drink")"  target="_self" title="">Latest Food &amp; Drink</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/food-news-6386468" onclick="ga("send", "event", "Nav", "Click", "Food News")"  target="_self" title="">Food News</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/cocktails-and-spirits-6386450" onclick="ga("send", "event", "Nav", "Click", "Cocktails & Spirits")"  target="_self" title="">Cocktails &amp; Spirits</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/openings-and-closings-6386445" onclick="ga("send", "event", "Nav", "Click", "Openings")"  target="_self" title="">Openings</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" onclick="ga("send", "event", "Nav", "Click", "Restaurant Guide")"  target="_self" title="">Restaurant Guide</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/best-miami-restaurants" onclick="ga("send", "event", "Nav", "Click", "Required Eating 2021")"  target="_blank" title="">Required Eating 2021</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/miami-best-bars" onclick="ga("send", "event", "Nav", "Click", "Drink Here 2021")"  target="_blank" title="">Drink Here 2021</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902044" onclick="ga("send", "event", "Nav", "Click", "Food & Drink Newsletter")"  target="_self" title="">Food &amp; Drink Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestArtsCulture">
<a href="https://www.browardpalmbeach.com/arts" onclick="ga("send", "event", "Nav", "Click", "Latest Arts & Culture")" target="_self">Arts &amp; Culture<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/arts" onclick="ga("send", "event", "Nav", "Click", "Latest Arts & Culture")"  target="_self" title="">Latest Arts &amp; Culture</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?narrowByDate=today&sortType=date&v=g" onclick="ga("send", "event", "Nav", "Click", "Calendar")"  target="_self" title="">Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/art-6386373" onclick="ga("send", "event", "Nav", "Click", "Art")"  target="_self" title="">Art</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/MovieTimes" onclick="ga("send", "event", "Nav", "Click", "Movie Times")"  target="_self" title="">Movie Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902051" onclick="ga("send", "event", "Nav", "Click", "Arts & Culture Newsletter")"  target="_self" title="">Arts &amp; Culture Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestMusic">
<a href="https://www.browardpalmbeach.com/music" onclick="ga("send", "event", "Nav", "Click", "Latest Music")" target="_self">Music<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/music" onclick="ga("send", "event", "Nav", "Click", "Latest Music")"  target="_self" title="">Latest Music</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/concerts-6386466" onclick="ga("send", "event", "Nav", "Click", "Concerts")"  target="_self" title="">Concerts</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/local-music-10849559" onclick="ga("send", "event", "Nav", "Click", "Local Music")"  target="_self" title="">Local Music</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?eventSection=6377142&feature=Concert&sortType=date&v=g" onclick="ga("send", "event", "Nav", "Click", "Concert Calendar")"  target="_self" title="">Concert Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902045" onclick="ga("send", "event", "Nav", "Click", "Music Newsletter")"  target="_self" title="">Music Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ThingstoDo">
<a href="https://www.browardpalmbeach.com/about" onclick="ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")" target="_self">More<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/things-to-do" onclick="ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")"  target="_self" title="">Things to Do/Tickets</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/best-of" onclick="ga("send", "event", "Nav", "Click", "Best of Miami")"  target="_self" title="">Best of Miami</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick="ga("send", "event", "Nav", "Click", "Cannabis")"  target="_blank" title="">Cannabis</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/SlideshowArchives" onclick="ga("send", "event", "Nav", "Click", "Slideshows")"  target="_self" title="">Slideshows</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/promotions" onclick="ga("send", "event", "Nav", "Click", "Promotions")"  target="_self" title="">Promotions</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/lists-6386369" onclick="ga("send", "event", "Nav", "Click", "Lists")"  target="_self" title="">Lists</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/flipbooks" onclick="ga("send", "event", "Nav", "Click", "Flipbook Archives")"  target="_self" title="">Flipbook Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902047" onclick="ga("send", "event", "Nav", "Click", "Things To Do Newsletter")"  target="_self" title="">Things To Do Newsletter</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902050" onclick="ga("send", "event", "Nav", "Click", "Best Of Newsletter")"  target="_self" title="">Best Of Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-MiamiNewTimes">
<a href="https://www.voicemediagroup.com/" onclick="ga("send", "event", "Nav", "Click", "Miami New Times")" target="_self">Voice Media Group<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick="ga("send", "event", "Nav", "Click", "Miami New Times")"  target="_blank" title="">Miami New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick="ga("send", "event", "Nav", "Click", "Dallas Observer")"  target="_blank" title="">Dallas Observer</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/" onclick="ga("send", "event", "Nav", "Click", "Houston Press")"  target="_blank" title="">Houston Press</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick="ga("send", "event", "Nav", "Click", "Phoenix New Times")"  target="_blank" title="">Phoenix New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick="ga("send", "event", "Nav", "Click", "Westword")"  target="_blank" title="">Westword</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick="ga("send", "event", "Nav", "Click", "Coupons Captain")"  target="_blank" title="">Coupons Captain</a>
</li>
</ul>
</li>
</ul>
<div class="fdn-site-header-search-block">
<form action="https://www.browardpalmbeach.com/browardpalmbeach/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text" 
name="keywords" 
autocomplete="off" 
type="search"
class="fdn-site-header-search-input" 
placeholder="Search"
>
<button class="fdn-site-header-search-submit" type="submit"><i class="far fa-search fa-flip-horizontal"></i></button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="fdn-site-header-nav-toggle-wide uk-visible@sm">
<a class="fdn-nav-toggle uk-button">
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="fdn-site-header-nav-toggle-wide-modal" class="fdn-site-header-nav-wide" 
uk-drop="mode: click; boundary: #fdn-navigation-dropdown-hook; boundary-align: true; pos: bottom-justify; offset: 100;">
<div class="uk-width-1-1 fdn-site-header-nav-wide-columns uk-modal-dialog">
<div class=" uk-flex uk-flex-wrap fdn-site-header-nav-wide-column-wrap">
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/news" onclick="ga("send", "event", "Nav", "Click", "News")" target="_self" title="">
News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/news" onclick="ga("send", "event", "Nav", "Click", "Latest News")" target="_self" title="">
Latest News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/coronavirus-10624039" onclick="ga("send", "event", "Nav", "Click", "Coronavirus")" target="_self" title="">
Coronavirus
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/environmental-6386358" onclick="ga("send", "event", "Nav", "Click", "Environmental")" target="_self" title="">
Environmental
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/politics-6386326" onclick="ga("send", "event", "Nav", "Click", "Politics")" target="_self" title="">
Politics
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/restaurants" onclick="ga("send", "event", "Nav", "Click", "Food & Drink")" target="_self" title="">
Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/restaurants" onclick="ga("send", "event", "Nav", "Click", "Latest Food & Drink")" target="_self" title="">
Latest Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/food-news-6386468" onclick="ga("send", "event", "Nav", "Click", "Food News")" target="_self" title="">
Food News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/cocktails-and-spirits-6386450" onclick="ga("send", "event", "Nav", "Click", "Cocktails & Spirits")" target="_self" title="">
Cocktails &amp; Spirits
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/openings-and-closings-6386445" onclick="ga("send", "event", "Nav", "Click", "Openings")" target="_self" title="">
Openings
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" onclick="ga("send", "event", "Nav", "Click", "Restaurant Guide")" target="_self" title="">
Restaurant Guide
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/best-miami-restaurants" onclick="ga("send", "event", "Nav", "Click", "Required Eating 2021")" target="_blank" title="">
Required Eating 2021
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/miami-best-bars" onclick="ga("send", "event", "Nav", "Click", "Drink Here 2021")" target="_blank" title="">
Drink Here 2021
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902044" onclick="ga("send", "event", "Nav", "Click", "Food & Drink Newsletter")" target="_self" title="">
Food &amp; Drink Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/arts" onclick="ga("send", "event", "Nav", "Click", "Arts & Culture")" target="_self" title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/arts" onclick="ga("send", "event", "Nav", "Click", "Latest Arts & Culture")" target="_self" title="">
Latest Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?narrowByDate=today&sortType=date&v=g" onclick="ga("send", "event", "Nav", "Click", "Calendar")" target="_self" title="">
Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/art-6386373" onclick="ga("send", "event", "Nav", "Click", "Art")" target="_self" title="">
Art
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/MovieTimes" onclick="ga("send", "event", "Nav", "Click", "Movie Times")" target="_self" title="">
Movie Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902051" onclick="ga("send", "event", "Nav", "Click", "Arts & Culture Newsletter")" target="_self" title="">
Arts &amp; Culture Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/music" onclick="ga("send", "event", "Nav", "Click", "Music")" target="_self" title="">
Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/music" onclick="ga("send", "event", "Nav", "Click", "Latest Music")" target="_self" title="">
Latest Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/concerts-6386466" onclick="ga("send", "event", "Nav", "Click", "Concerts")" target="_self" title="">
Concerts
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/local-music-10849559" onclick="ga("send", "event", "Nav", "Click", "Local Music")" target="_self" title="">
Local Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?eventSection=6377142&feature=Concert&sortType=date&v=g" onclick="ga("send", "event", "Nav", "Click", "Concert Calendar")" target="_self" title="">
Concert Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902045" onclick="ga("send", "event", "Nav", "Click", "Music Newsletter")" target="_self" title="">
Music Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/about" onclick="ga("send", "event", "Nav", "Click", "More")" target="_self" title="">
More
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/things-to-do" onclick="ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")" target="_self" title="">
Things to Do/Tickets
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/best-of" onclick="ga("send", "event", "Nav", "Click", "Best of Miami")" target="_self" title="">
Best of Miami
</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick="ga("send", "event", "Nav", "Click", "Cannabis")" target="_blank" title="">
Cannabis
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/SlideshowArchives" onclick="ga("send", "event", "Nav", "Click", "Slideshows")" target="_self" title="">
Slideshows
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/promotions" onclick="ga("send", "event", "Nav", "Click", "Promotions")" target="_self" title="">
Promotions
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/lists-6386369" onclick="ga("send", "event", "Nav", "Click", "Lists")" target="_self" title="">
Lists
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/flipbooks" onclick="ga("send", "event", "Nav", "Click", "Flipbook Archives")" target="_self" title="">
Flipbook Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902047" onclick="ga("send", "event", "Nav", "Click", "Things To Do Newsletter")" target="_self" title="">
Things To Do Newsletter
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902050" onclick="ga("send", "event", "Nav", "Click", "Best Of Newsletter")" target="_self" title="">
Best Of Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.voicemediagroup.com/" onclick="ga("send", "event", "Nav", "Click", "Voice Media Group")" target="_self" title="">
Voice Media Group
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick="ga("send", "event", "Nav", "Click", "Miami New Times")" target="_blank" title="">
Miami New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick="ga("send", "event", "Nav", "Click", "Dallas Observer")" target="_blank" title="">
Dallas Observer
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.houstonpress.com/" onclick="ga("send", "event", "Nav", "Click", "Houston Press")" target="_blank" title="">
Houston Press
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick="ga("send", "event", "Nav", "Click", "Phoenix New Times")" target="_blank" title="">
Phoenix New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick="ga("send", "event", "Nav", "Click", "Westword")" target="_blank" title="">
Westword
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick="ga("send", "event", "Nav", "Click", "Coupons Captain")" target="_blank" title="">
Coupons Captain
</a>
</li>
</ul>
</div>
</div>
<div class="fdn-site-header-search-block">
<form action="https://www.browardpalmbeach.com/browardpalmbeach/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text"
name="keywords" 
autocomplete="off" 
type="search"
class="fdn-site-header-search-input" 
placeholder="Search browardpalmbeach.com">
<button class="fdn-site-header-search-submit" type="submit">
<i class="far fa-search fa-flip-horizontal"></i>
</button>
</div>
</form>
</div>
</div>
</div>
<div class="fdn-site-header-logo">
<div class="GlobalHeader SiteLogoresponsive  uk-root SiteLogo comp-shell-logo" data-component-id="SiteLogo">
<div class="uk-margin-remove">
<a class="uk-logo" href="https://www.browardpalmbeach.com/" title="New Times Broward-Palm Beach">
<img src="/images/bpb-main-logo.png"
alt="New Times Broward-Palm Beach">
</a>
</div>
</div>
</div>
<div class="fdn-site-header-text-block">
<div class="uk-flex uk-flex-wrap uk-flex-middle">
<a class="uk-width-auto fdn-site-header-support-button" 
href="https://www.browardpalmbeach.com/i-support" 
onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-VMG-ISupport-Header',  {'NonInteraction': 1});">
Support Us
</a>
<p class="uk-width-2-3@sm uk-width-1-2 fdn-site-header-slogan uk-margin-remove">
South Florida's independent<br>
source of local news and culture
</p>
</div>
</div>
<div class="uk-flex uk-flex-middle fdn-site-header-login-block">
<p class="uk-margin-remove uk-button">
<i class="fas fa-2x fa-user"></i>
<span class="uk-visible@sm">account</span>
<i class="fas fa-chevron-right"></i>
</p>
<div class="uk-padding-small" uk-dropdown="mode:click">
<ul class="uk-nav uk-nav-default uk-dropdown-nav">
<li class="pelcro-logged-in uk-nav-header">Welcome,<br/><span class="pelcro-user-name">Insider</span></li>
<li class="pelcro-logged-out"><a href="#" class="pelcro-login-button" data-vmgs-psource="Toolbar|Music" data-vmgs-section="Music">Login</a></li>
<li class="pelcro-logged-in"><a href="/profile">My Newsletters</a></li>
<li class=""><a href="/contribute">Contribute</a></li>
<li class=""><a href="/about/contact">Contact Us</a></li>
<li class="pelcro-logged-in pelcro-logout-button"><a href="">Sign out</a></li>
</ul>
</div>
</div>
</div>
</div>
  


      </div>
    </div>

    <div class="ev-grid-zone ev-primary-zone">
      <div class="ev-grid-col fdn-grid-main-single fdn-primary" data-ev-zone="MainTop">

        

        



























































































































  

    <div class="ZoneA ContentDefaultMultiple  uk-inline uk-margin-remove-top uk-root fdn-margin-vert ContentRowMultiple comp-content-contentmultirow" data-component-id="ContentRowMultiple">
      
      
        <div class="content-multiple-item" 
      fdn-content-multi-item="11767450"
      fdn-content-multi-item-headline="Ten South Florida Artists to Watch at Rolling Loud 2021"
      fdn-content-multi-item-permalink="/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450"
      fdn-content-multi-item-canonical="https://www.miaminewtimes.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-12473340"
      fdn-content-multi-item-title="Ten South Florida Artists to Watch at Rolling Loud 2021"
      fdn-content-multi-item-thumb="https://media2.fdncms.com/bpb/imager/u/slideshow/11767439/10-south-florida-artists-performing-rolling-loud.jpeg?cb=1626448794"
      fdn-content-multi-item-thumb-width="1524"
      fdn-content-multi-item-thumb-height="980"
      ga-dimension2="Music" ga-dimension3="11767450" ga-dimension4="2021-07-16 11:20:00" ga-dimension5="Lists%Music Festivals%Things To Do" ga-dimension6="Tony M. Centeno" ga-dimension7="Articles"
      >
        <div class="ZoneA StoryHeaderCustomresponsive   uk-root fdn-margin-vert StoryHeaderCustom comp-content-storyheader" data-component-id="StoryHeaderCustom">
      <div class="fdn-custom-story-header"> 
        
        
          <p class="fdn-custom-story-header-topic uk-margin-remove-top uk-margin-small-bottom">
            <a href="https://www.browardpalmbeach.com/topic/lists-6386369">
              Lists
            </a>
          </p>
        

        
        
        
        <div class="uk-position-relative uk-visible-toggle">
          <div class="uk-hidden-hover uk-position-top-right uk-padding-xsmall uk-position-absolute">
            
          </div>

          <h1 class="fdn-content-headline uk-margin-remove">
            Ten South Florida Artists to Watch at Rolling Loud 2021
          </h1>        

          <p class="fdn-content-infoline">
            
              
              <span class="fdn-custom-story-header-author">
                <a href="https://www.browardpalmbeach.com/author/tony-m-centeno" rel="author">
                    Tony M. Centeno
                  </a>
              </span>
            

            <span class="fdn-custom-story-header-date">
              July 16, 2021
            </span>

            <span class="fdn-custom-story-header-time">
              11:20AM
            </span>

          </p>
        </div>
      </div>
    </div>

  <div class="uk-width-1-1 uk-flex uk-flex-row">

    
    <div class="uk-width-expand uk-flex uk-flex-column" main-column>

      
      
        <div class="uk-width-1-1">
          <div class="uk-margin-remove-top fdn-magnum-block uk-clearfix">
      <img uk-img="" 
           data-src="https://media2.fdncms.com/bpb/imager/u/magnum/11767439/10-south-florida-artists-performing-rolling-loud.jpeg?cb=1626448794"
           alt="Rick Ross, City Girls, and Kodak Black"
           width="1320"
           height="849"
           class="" />

      
        <div class="fdn-caption-block uk-flex uk-flex-middle uk-flex-row">
          
            <span class="fdn-image-caption">Rick Ross, City Girls, and Kodak Black</span>
          
          
            <span class="fdn-image-credit">Photo by Amanda Barona/Marcelo Cantu/ShotByXeno</span>
          
        </div>
      
    </div>
        </div>
      

      <div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-middle uk-flex-left uk-grid-small fdn-content-multi-row-share-tools-small "  uk-grid>
    
    
    <div fdn-share-button-facebook="">
      <a href="https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&app_id=835681050493442" 
         onClick="window.open('https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&app_id=835681050493442','_blank','resizable,height=700,width=600'); return false;"
         target="_blank" 
         uk-tooltip="title: Share on Facebook" 
         aria-expanded="false"> 
        <span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:facebook; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="facebook"><path d="M11,10h2.6l0.4-3H11V5.3c0-0.9,0.2-1.5,1.5-1.5H14V1.1c-0.3,0-1-0.1-2.1-0.1C9.6,1,8,2.4,8,5v2H5.5v3H8v8h3V10z"></path></svg></span>
      </a>
    </div>

    
    
    <script> dnLoadScript("https://platform.twitter.com/widgets.js", true); </script>
    <div class="" fdn-share-button-twitter="">
      <a href="https://twitter.com/intent/tweet?url=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&text=Ten%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021" 
         onClick="window.open('https://twitter.com/intent/tweet?url=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fmusic%2Frolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450&text=Ten%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021','_blank','resizable,height=700,width=600'); return false;"
         uk-tooltip="title: Share on Twitter" 
         aria-expanded="false">
         <span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:twitter; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="twitter"><path d="M19,4.74 C18.339,5.029 17.626,5.229 16.881,5.32 C17.644,4.86 18.227,4.139 18.503,3.28 C17.79,3.7 17.001,4.009 16.159,4.17 C15.485,3.45 14.526,3 13.464,3 C11.423,3 9.771,4.66 9.771,6.7 C9.771,6.99 9.804,7.269 9.868,7.539 C6.795,7.38 4.076,5.919 2.254,3.679 C1.936,4.219 1.754,4.86 1.754,5.539 C1.754,6.82 2.405,7.95 3.397,8.61 C2.79,8.589 2.22,8.429 1.723,8.149 L1.723,8.189 C1.723,9.978 2.997,11.478 4.686,11.82 C4.376,11.899 4.049,11.939 3.713,11.939 C3.475,11.939 3.245,11.919 3.018,11.88 C3.49,13.349 4.852,14.419 6.469,14.449 C5.205,15.429 3.612,16.019 1.882,16.019 C1.583,16.019 1.29,16.009 1,15.969 C2.635,17.019 4.576,17.629 6.662,17.629 C13.454,17.629 17.17,12 17.17,7.129 C17.17,6.969 17.166,6.809 17.157,6.649 C17.879,6.129 18.504,5.478 19,4.74"></path></svg></span>
      </a>
    </div>

    
    
    
    
    <div class="" fdn-share-button-email="">
      <a href="mailto:?subject=New%20Times%20Broward-Palm%20Beach%3A%20Ten%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021&body=%0A%0ATen%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021%0A%0Ahttps://www.browardpalmbeach.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450%0A%0A%0A" onclick="mailto:?subject=New%20Times%20Broward-Palm%20Beach%3A%20Ten%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021&body=%0A%0ATen%20South%20Florida%20Artists%20to%20Watch%20at%20Rolling%20Loud%202021%0A%0Ahttps://www.browardpalmbeach.com/music/rolling-loud-2021-ten-best-miami-rappers-at-the-festival-11767450%0A%0A%0A" uk-tooltip="title: Share via Email" aria-expanded="false" rel="nofollow">
         <i class="fal fa-envelope fa-lg"></i>
      </a>
    </div>

    
    <div class="" fdn-share-button-print>
      <a href="https://www.browardpalmbeach.com/browardpalmbeach/Print?oid=11767450" target="_blank" uk-tooltip="title:Print" title="" aria-expanded="false">
        <i class="fal fa-print fa-lg"></i>
      </a>
    </div>

    
    <div class="" fdn-share-button-text-size>
      <a class="fdn-text-size-toggle" href="#size" uk-tooltip="title:Change Font Size" aria-expanded="false" uk-toggle="target: .fdn-content-body;cls: fdn-content-body-large;">
       <i class="fas fa-text-size fa-lg"></i>
      </a>
    </div>
  </div>

      <div class="uk-width-1-1 uk-flex uk-flex-row">
        
        <div class="uk-width-expand fdn-content-multi-row">
          <div class="ZoneA StoryLayoutresponsive   uk-root fdn-margin-vert StoryLayout comp-content-storylayout" data-component-id="StoryLayout">
      

      <div class="fdn-content-body">
        

        
        
          <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767439/10-south-florida-artists-performing-rolling-loud.jpeg"                   rel="contentImg_gal-11767450"                   title="Rick Ross, City Girls, and Kodak Black - PHOTO BY AMANDA BARONA/MARCELO CANTU/SHOTBYXENO"                   data-caption="<span>Rick Ross, City Girls, and Kodak Black</span>&nbsp;&nbsp;            <em>Photo by Amanda Barona/Marcelo Cantu/ShotByXeno</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767439/10-south-florida-artists-performing-rolling-loud.jpeg?cb=1626448794"                        alt="Rick Ross, City Girls, and Kodak Black - PHOTO BY AMANDA BARONA/MARCELO CANTU/SHOTBYXENO"                        width="700"                       height="450" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Rick Ross, City Girls, and Kodak Black                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by Amanda Barona/Marcelo Cantu/ShotByXeno                                              </div>                  </div>                                                        </div>  Rolling Loud was born and raised in the county of Dade, so, naturally, the festival's lineup is going to feature artists from the crib. 

          
        
          <br>
           <br>
           Since its inaugural show in 2015, South Florida artists have always been included, no matter how mainstream or independent they are. Over the years, <i>New Times</i> has witnessed some unforgettable sets from some of South Florida's most revered artists. Trick Daddy and Trina made their debut at Rolling Loud 2018 with 99 Jamz's DJ Nasty 305 backing them up. The following year, Ice Billion Berg held it down for Miami on the Monster Energy stage.

          
        
          <br>
      <br>
      And those are just the previous legends who have taken the stage. 

          
        
          <br>
           <br>
           Over the years, underground artists like Prez P, IndigoChildRick, Smokepurrp, and other well-known acts have infiltrated every stage within Rolling Loud's extensive compound. Local artists like Pouya, Fat Nick, Robb Bank$, Members Only, and Wisifuneral have not only performed at the in-person festival but also the Loud Stream shows on Twitch that popped up during the pandemic. 

          

            
            <div class="uk-padding-remove fdn-override-width-1-1">
              <div class="ZoneA RelatedStoriesSupportUsComboInlineContentresponsive   uk-root fdn-margin-vert RelatedStoriesInlineContent comp-content-relatedstories" data-component-id="RelatedStoriesInlineContent">
  
    
    

    
      <h3 class="uk-heading-line uk-text-uppercase">
        <span>Related Stories</span></h3>
      <ul class="uk-list fdn-list-bullet">
        <li><a href="https://www.browardpalmbeach.com/music/rolling-loud-2021-the-hip-hop-festival-finally-returns-to-miami-july-23-25-11767430">Rolling Loud Needed Only One Thing to Survive the Pandemic: The Fans</a></li>
      </ul>
    
  


  

  









<div class="MicroComponent RelatedStoriesSupportUsComboInlineContentresponsive   uk-root fdn-margin-vert SupportUsExpandedState comp-shell-supportus" data-component-id="SupportUsExpandedState">
  <div class="fdn-support-us-block">
    <div class="fdn-support-us-start-row fdn-support-us-wrap" >

      <div class="uk-flex uk-flex-wrap uk-flex-center uk-width-4-5@s uk-width-1-1 fdn-support-us-flasher-row">
        <h2 class="uk-margin-remove">I support</h2>
        <div class="fdn-support-us-flasher-box uk-width-1-2@m uk-width-2-3">
            <div uk-slider="autoplay: true;autoplay-interval: 710">
              <div class="uk-slider-container">
                <div class="uk-child-width-1-1 uk-slider-items"> 
                  <div class="fdn-slider-delayed">
                    <img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
                  </div>
                  <div class="fdn-slider-delayed">
                    <img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
                  </div>
                  <div>Local</div>
                  <div>Community</div>
                  <div>Journalism</div>
                </div>
            </div>
          </div>
        </div>
     </div>

     <div class="uk-flex uk-flex-center uk-flex-wrap fdn-support-us-start-row-text">
       <div class="uk-margin-small-right uk-width-2-3@m uk-width-1-2@s uk-padding-small uk-padding-remove-vertical">
         Support the independent voice of South Florida and 
  help keep the future of New Times free.
       </div>

       

       <div class="uk-padding-small fdn-support-us-support-button">
         <a href="https://www.browardpalmbeach.com/i-support" 
            onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-Article-VMG-ISupport-Leader',  {'NonInteraction': 1});">
          Support Us
        </a>
       </div> 
     </div>  
    </div>

    <div class="fdn-support-us-toggle-row fdn-support-us-wrap" hidden>
      <div class="uk-flex uk-flex-middle uk-flex-wrap uk-flex-center">
        <div class="uk-margin-small-right">
          <h2 class="uk-margin-remove-vertical uk-text-center">
            Keep New Times Free.
          </h2>
        </div>
        <div class="uk-padding-small fdn-support-us-support-button">
          <a href="https://www.browardpalmbeach.com/i-support">Support Us</a>
        </div>   
      </div>
    </div>

    <div class="fdn-support-us-toggle-button">
      <a href="#" uk-toggle="target: .fdn-support-us-wrap">
      
      <i class="fas fa-chevron-up fa-lg"></i>
      </a>  
    </div>
  </div>
</div>

</div>
            </div>
            
          
        
          <br>
           <br>
           Twenty-twenty-one will have plenty of artists not just from South Florida but from across the entire Sunshine State. Tallahassee's own T-Pain will have his own set, as will other Florida natives like SpottemGottem, Rod Wave, Danny Towers, Hotboii, Bobby Fishscale, and West Palm Beach resident $not, just to name a few. In total, 29 artists who hail from various counties throughout the state will hit the stage at Rolling Loud. 

          
        
          <br>
          <br>
          Here are ten artists from South Florida that you should look out for during Rolling Loud weekend, July 23-25.<br>
          <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media1.fdncms.com/bpb/imager/u/original/11767440/city_girls_-_flicksbyedd2.jpeg"                   rel="contentImg_gal-11767450"                   title="Yung Miami and JT of City Girls - PHOTO BY FLICKSBYEDD"                   data-caption="<span>Yung Miami and JT of City Girls</span>&nbsp;&nbsp;            <em>Photo by FlicksByEdd</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media1.fdncms.com/bpb/imager/u/blog/11767440/city_girls_-_flicksbyedd2.jpeg?cb=1626448794"                        alt="Yung Miami and JT of City Girls - PHOTO BY FLICKSBYEDD"                        width="700"                       height="467" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Yung Miami and JT of City Girls                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by FlicksByEdd                                              </div>                  </div>                                                        </div>               
<h2 class="subhead">City Girls</h2>
   You can’t escape the City Girls these days. Yung Miami and JT have the nation on lock with their raw and uncut lyricism over twerktastic beats. During the pandemic, fans were blessed with notable bops from the duo’s <i>City on Lock</i> album, which features Lil Baby, Doja Cat, Lil Durk, and Yo Gotti. The Miami natives kept their foot on the gas with remixes to their single “Pussy Talk” and BRS Kash’s “Throat Baby.” The Quality Control signees waited for the perfect time to strike in 2021 with their '80s-inspired jam “Twerkulator,” which will likely echo throughout the Sunshine State all summer long. While the duo has been popping up at clubs and events around the nation these past few months, it’s been a while since City Girls have appeared on the Rolling Loud stage. Prepare to watch Caresha and Jatavia bring hits like “Twerk,” “Act Up,” and &nbsp;“Where the Bag At” to their hometown — <i>period</i>.<br>
      <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media1.fdncms.com/bpb/imager/u/original/11767441/fcg_heem_insurgovisuals_229_of_229_.jpeg"                   rel="contentImg_gal-11767450"                   title="FCG Heem - PHOTO BY INSURGOVISUALS"                   data-caption="<span>FCG Heem</span>&nbsp;&nbsp;            <em>Photo by insurgovisuals</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media1.fdncms.com/bpb/imager/u/blog/11767441/fcg_heem_insurgovisuals_229_of_229_.jpeg?cb=1626448794"                        alt="FCG Heem - PHOTO BY INSURGOVISUALS"                        width="700"                       height="450" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        FCG Heem                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by insurgovisuals                                              </div>                  </div>                                                        </div>       
<h2 class="subhead">FCG Heem</h2>
   FCG Heem is the latest artist from the crib to break into the rap game. Hailing from Fort Lauderdale, Heem has been relentless for the past few years, dropping music like his debut project, <i>Letter to My People</i>. While some artists went radio silent, Heem took advantage of his time off during the pandemic and flourished. Soon after dropping his pandemic-inspired EP, <i>Street Virus</i>, he began working on his major-label debut, <i>Neighborhood Poetry</i>. The 14-track LP, which dropped in May via Republic Records, features standout tracks like “Believe in Me” and “Peace &amp; Positivity.” It also holds fresh collaborations with NoCap, Pooh Shiesty, and Toosii. Fans will definitely want to see Heem perform his latest bangers live during his Rolling Loud debut.<br>
     <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767442/fso_dinero-_954_live.jpeg"                   rel="contentImg_gal-11767450"                   title="F$O Dinero - PHOTO BY @954_LIVE"                   data-caption="<span>F$O Dinero</span>&nbsp;&nbsp;            <em>Photo by @954_Live</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767442/fso_dinero-_954_live.jpeg?cb=1626448794"                        alt="F$O Dinero - PHOTO BY @954_LIVE"                        width="700"                       height="481" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        F$O Dinero                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by @954_Live                                              </div>                  </div>                                                        </div>      
<h2 class="subhead">F$O Dinero</h2>
   F$O Dinero’s upcoming set at Rolling Loud is a win for his whole team. After signing to Slip-N-Slide in 2018, the Oakland Park native hit the ground running, dropping solo music and dope collaborations with some of the biggest artists in the game. On his 2019 project, <i>Color Money</i>, Dinero connected with Zoey Dollaz, City Girls, and OTF’s Lil Durk — all of whom will be at the festival. Throughout the pandemic and for the first half of 2021, the 22-year-old rapper released a handful of bangers, from “Lost Sauce” featuring F$O Sauce to his most recent single, “Vye Neg,” which dropped a few days before Haitian Flag Day. The FSO (short for “Fly Shit Only”) crew will be on the scene, but there’s no telling what surprises Dinero has in store for the fans.<br>
                    <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media1.fdncms.com/bpb/imager/u/original/11767443/hood_brat_-_shotbyxeno.jpeg"                   rel="contentImg_gal-11767450"                   title="Hood Brat - PHOTO BY SHOTBYXENO"                   data-caption="<span>Hood Brat</span>&nbsp;&nbsp;            <em>Photo by ShotByXeno</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media1.fdncms.com/bpb/imager/u/blog/11767443/hood_brat_-_shotbyxeno.jpeg?cb=1626448794"                        alt="Hood Brat - PHOTO BY SHOTBYXENO"                        width="700"                       height="481" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Hood Brat                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by ShotByXeno                                              </div>                  </div>                                                        </div>               
<h2 class="subhead">Hood Brat</h2>
   It’s Hood Brat’s time to shine. The Overtown native has been enticing fans since before she was cast to appear in VH1’s <i>Love &amp; Hip-Hop: Miami</i>. When the cameras aren't following her, the 30-year-old rapper is in the studio cranking out songs like her latest single, “Pam.” The pandemic may have blocked her and the rest of the lineup from performing at Rolling Loud last year, but it couldn’t stop her from doing what she loves. Hood Brat delivered her 14-track project, <i>Hood Baby</i>, featuring Brisco and Vicky Vee at the height of the lockdown. Although she’s been performing at events everywhere, Hood Brat is finally ready to hit the stage and deliver her wide range of new tracks and others from her <i>Vonda</i> days.  <br>
       <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767444/jackboy-_shotbyxeno.jpeg"                   rel="contentImg_gal-11767450"                   title="Jackboy - PHOTO BY SHOTBYXENO"                   data-caption="<span>Jackboy</span>&nbsp;&nbsp;            <em>Photo by ShotByXeno</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767444/jackboy-_shotbyxeno.jpeg?cb=1626448795"                        alt="Jackboy - PHOTO BY SHOTBYXENO"                        width="700"                       height="481" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Jackboy                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by ShotByXeno                                              </div>                  </div>                                                        </div>               
<h2 class="subhead">Jackboy</h2>
   In recent years, a mob of talented artists has emerged from the edge of County Line Road in Miramar to North Lauderdale, including Jackboy. The Pompano Beach native has delivered plenty of alluring records over the past year alone. In 2020, he released three projects, including a self-titled album and two follow-ups, <i>Living In History</i> and <i>Love Me While I’m Here</i>. The Sniper Gang rapper recently collaborated with the likes of WizDaWizard and Russ before dropping his most recent single, “Protecting My Energy.” With Rolling Loud quickly approaching, Jackboy is more than prepared to put on an unforgettable set featuring all of his new music for his fans who’ve waited so long to see him. <br>
      <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767445/kodak_black_shotbyxeno.jpeg"                   rel="contentImg_gal-11767450"                   title="Kodak Black - PHOTO BY SHOTBYXENO"                   data-caption="<span>Kodak Black</span>&nbsp;&nbsp;            <em>Photo by ShotByXeno</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767445/kodak_black_shotbyxeno.jpeg?cb=1626448795"                        alt="Kodak Black - PHOTO BY SHOTBYXENO"                        width="700"                       height="481" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Kodak Black                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by ShotByXeno                                              </div>                  </div>                                                        </div>            
<h2 class="subhead">Kodak Black</h2>
   The last time Kodak Black was set to perform at Rolling Loud, the young rapper was whisked away by the Miami Police Department in handcuffs. Now that he’s served his time behind bars and obtained his pardon from former President Donald Trump, Kodak is ready to dominate the stage once again. Since his release, the Pompano Beach native has released a handful of projects, including <i>Bill Israel</i>, <i>Haitian Boy Kodak</i>, and his most recent EP, <i>Happy Birthday Kodak</i>. With those works plus collaborations with NLE Choppa, Mike Smiff, and Pooh Shiesty, Kodak’s got plenty of fresh material that has yet to be performed on a global stage. Rap fans will be more than hype to finally catch Kodak perform all of his new songs and the classics that propelled him to stardom.<br>
        <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media1.fdncms.com/bpb/imager/u/original/11767446/rick_ross_amanda_barona.jpeg"                   rel="contentImg_gal-11767450"                   title="Rick Ross - PHOTO BY AMANDA BARONA"                   data-caption="<span>Rick Ross</span>&nbsp;&nbsp;            <em>Photo by Amanda Barona</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media1.fdncms.com/bpb/imager/u/blog/11767446/rick_ross_amanda_barona.jpeg?cb=1626448795"                        alt="Rick Ross - PHOTO BY AMANDA BARONA"                        width="700"                       height="467" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Rick Ross                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by Amanda Barona                                              </div>                  </div>                                                        </div>             
<h2 class="subhead">Rick Ross</h2>
   It’s a celebration whenever the bawse pulls up to the scene. Rick Ross is always ready to set any stage ablaze with his presence, and Rolling Loud won’t be any different. The Carol City Cartel cofounder is guaranteed to play his array of hits, from as far back as his breakthrough single “Hustlin’” all the way up to his latest collaborations with DJ Khaled (“This Is My Year”) and Guapdad 4000 (“How Many [Remix]”). And don't be surprised if Rozay drops a new song during his set. His long-awaited album, <i>Richer Than I've Ever Been</i>, is expected to arrive sometime soon. Clearly, he has the opportunity to preview some new music. Since he’ll be performing in his hometown, it’s possible he might bring out a famous friend or two.<br>
    <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767447/ski_mask_amanda_barona.jpeg"                   rel="contentImg_gal-11767450"                   title="Ski Mask The Slump God - PHOTO BY AMANDA BARONA"                   data-caption="<span>Ski Mask The Slump God</span>&nbsp;&nbsp;            <em>Photo by Amanda Barona</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767447/ski_mask_amanda_barona.jpeg?cb=1626448795"                        alt="Ski Mask The Slump God - PHOTO BY AMANDA BARONA"                        width="700"                       height="450" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Ski Mask The Slump God                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by Amanda Barona                                              </div>                  </div>                                                        </div>                             
<h2 class="subhead">Ski Mask the Slump God</h2>
   It’s been two and a half years since we received a fresh, full work from Broward native Ski Mask the Slump God. Since dropping his major-label debut, <i>Stokely</i>, in 2018, the rapper has kept busy, releasing his 2019 single “Carbonated Water” and jumping on his friend DJ Scheme’s <i>Family</i> album in 2020. Earlier this year, Ski Mask delivered two EPs, each featuring five songs, which were meant to appear on his first studio album, including collaborations with Lil Baby, Lil Yachty, and the late Juice Wrld. At Rolling Loud, the Slump God is also likely to perform fresh joints off his new project, <i>Sin City the Mixtape</i>. Fans can expect an exhilarating performance with a mix of new and classic records from his Very Rare/Members Only days. <br>
         <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media1.fdncms.com/bpb/imager/u/original/11767448/tafia.3.jpeg"                   rel="contentImg_gal-11767450"                   title="Tafia - PHOTO BY MACKINLEY MADHERE"                   data-caption="<span>Tafia</span>&nbsp;&nbsp;            <em>Photo by Mackinley Madhere</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media1.fdncms.com/bpb/imager/u/blog/11767448/tafia.3.jpeg?cb=1626448795"                        alt="Tafia - PHOTO BY MACKINLEY MADHERE"                        width="700"                       height="534" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Tafia                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by Mackinley Madhere                                              </div>                  </div>                                                        </div>               
<h2 class="subhead">Tafia</h2>
   Tafia has had a hell of a year, and it's only July. The Dream Chasers signee has spent the first half of 2021 enticing his fanbase with tough freestyles and fresh music from his latest project, <i>Street Clarity</i>, hosted by DJ Drama. The Haitian rapper has been scheduled to hit the stage at the biggest hip-hop festival in the land since last year before the pandemic hit. After everything he’s been through, from his shocking car accident to finally dropping new music, his set at the festival will be the cherry on top of a successful stretch. You won’t want to miss out on his set and the surprises he’s got in store. He can serve up a whole range of records, from his recent <i>Fanci No. 9 </i>mixtape with Major Nine all the way back to his early project <i>Gorilla Drippin</i>. <br>
                   <div uk-lightbox class="uk-position-relative fdn-content-image-center contentImageCenter">                                                        <a href="https://media2.fdncms.com/bpb/imager/u/original/11767449/zoey_dollaz_royaleeyz.jpeg"                   rel="contentImg_gal-11767450"                   title="Zoey Dollaz - PHOTO BY ROYALEEYZ"                   data-caption="<span>Zoey Dollaz</span>&nbsp;&nbsp;            <em>Photo by Royaleeyz</em>"                   class="uk-display-block uk-position-relative uk-visible-toggle">                  <span class="fdn-button-enlarge uk-position-absolute                    uk-position-top-right uk-hidden-hover">        click to enlarge      </span>                  <img src="https://media2.fdncms.com/bpb/imager/u/blog/11767449/zoey_dollaz_royaleeyz.jpeg?cb=1626448795"                        alt="Zoey Dollaz - PHOTO BY ROYALEEYZ"                        width="700"                       height="481" />                 </a>                                                                                            <div class="fdn-caption-block uk-margin-auto"                                       style="max-width: 700px"                                      >                    <div class="fdn-image-caption">                        Zoey Dollaz                      </div>                                                                                                                    <div class="fdn-image-credit">                                                  Photo by Royaleeyz                                              </div>                  </div>                                                        </div>               
<h2 class="subhead">Zoey Dollaz</h2>
   There’s no stage where Zoey Dollaz can’t dominate. The Haitian spitta is a Rolling Loud veteran with a lengthy catalog of fan favorites that will incite any crowd to go wild. Prior to the pandemic, Zoey delivered <i>Last Year Being Humble</i>, a nine-track EP featuring Future, Gunna, Nav, and Ink. After he dropped his project via Freebandz in 2019, Zoey collaborated with the likes of SoFlo’s own F$O Dinero and Dallas rapper 10k.Caash, while focusing on his new business venture, Aegis, a bulletproof car service. Earlier this year, Zoey dropped his latest single, “Broad Day Light,” via Littville, and he probably can’t wait to perform it live at the festival.

          

            <hidden hidden>
            <div class="uk-padding-remove fdn-override-width-1-1">
              <br><br>
<div class="ZoneA AirMediumRectangleInlineContentMobileDisplaySizeresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleInlineContentMobileDisplaySize comp-" data-component-id="AirMediumRectangleInlineContentMobileDisplaySize"
     fdn-ad-component>
  <div apn-ad-hook="rectangle" display-targets="mobile">
        <script>
        if (typeof apntag === 'object') {
          apntag.anq.push(function() {
            if (typeof Foundation.ApnAds.fillAds === 'function') {
              Foundation.ApnAds.fillAds()
            }
          })
        }
        </script>
      </div>
</div>
            </div>
            </hidden>
          
        
          <br>
   <br>
   <b>Rolling Loud.</b> <i>Friday, July 23, through Sunday, July 25, at Hard Rock Stadium, 347 Don Shula Dr., Miami Gardens; 305-943-8000; <a href="http://hardrockstadium.com" target="_blank">hardrockstadium.com</a>. Sold out; join the waitlist for tickets at <a href="https://rollingloudwaitlist.shop.ticketstoday.com/calendar.aspx" target="_blank">rollingloud.com</a>. </i>

          
        

        
        
          

          
        
          

          
            <hidden hidden>
            <div class="uk-padding-remove fdn-override-width-1-1">
              <div class="ZoneA AirBillboardInlineContentresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirBillboardInlineContent comp-" data-component-id="AirBillboardInlineContent"
     inline-content-billboard
     style="width:1040px;"
     fdn-ad-component>
  
  <div class="uk-visible@m uk-flex uk-flex-row uk-width-1-1 uk-flex uk-flex-center" style="
      width:1040px;
      border-top: thin solid #ccc;
      margin-top: 30px !important;
      padding-top: 30px;
      border-bottom: thin solid #ccc; 
      margin-bottom: 0px;
      padding-bottom: 30px;">
    <div apn-ad-hook="billboard" display-targets="desktop|tablet">
        <script>
        if (typeof apntag === 'object') {
          apntag.anq.push(function() {
            if (typeof Foundation.ApnAds.fillAds === 'function') {
              Foundation.ApnAds.fillAds()
            }
          })
        }
        </script>
      </div>
  </div>
</div>
            </div>
            </hidden>
        
      </div>

      
      

      
      

    </div>
        </div>
      </div>

      <div class="uk-width-1-1">
        



<div class="ZoneA KeepFreeresponsive   uk-root fdn-margin-vert KeepFree comp-content-keepfree" data-component-id="KeepFree">
  <div class="uk-position-relative uk-overflow-hidden">
    <div class="fdn-keep-free-blue-bar-top" uk-scrollspy="cls: fdn-animation-blue-bar-top; delay: 300;"></div>
    <div class="fdn-keep-free-blue-bar-left" uk-scrollspy="cls:fdn-animation-blue-bar-left; delay:1500"></div>

    <div class="fdn-keep-free-body">
      <strong>KEEP NEW TIMES BROWARD-PALM BEACH FREE...</strong> 
  Since we started <i>New Times Broward-Palm Beach</i>, it has been defined as the free, independent voice of South Florida, and we'd like to keep it that way. With local media under siege, it's more important than ever for us to rally support behind funding our local journalism. You can help by participating in our "I Support" program, allowing us to keep offering readers access to our incisive coverage of local news, food and culture with no paywalls.
    </div>

    <div class="uk-position-relative fdn-keep-free-link">
      <a href="https://www.browardpalmbeach.com/i-support"
         onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-VMG-ISupport-AfterArticle',  {'NonInteraction': 1});">
        Make a one-time donation today for as little as $1. 
      </a>
      <div class="fdn-keep-free-text-mask" uk-scrollspy="cls:fdn-animation-text-mask"></div>
    </div>
  </div>
</div>


        

        <div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-content-footer-row">
          <div class="uk-first-column text-links-hook">
            


  
  

  <div class="ZoneA SailthruRecommendationsresponsive  uk-width-medium@s uk-margin-remove SailthruRecommendations-11767450 uk-root fdn-margin-vert SailthruRecommendations comp-content-sailthrurecommendations" data-component-id="SailthruRecommendations">
    <h3 class="uk-margin-remove uk-heading-line uk-text-uppercase">
      <span>
        Trending Music
      </span>
    </h3>

    <ul class="uk-list fdn-list-bullet">      
      
        <li><a href="https://www.browardpalmbeach.com/music/top-20-sexiest-randb-songs-from-the-90s-to-today-6435154" data-objid="6435154" title="Top 20 Sexiest R&amp;B Songs from the &#39;90s to Today">Top 20 Sexiest R&B Songs from the '90s to Today</a></li>
      
        <li><a href="https://www.browardpalmbeach.com/music/young-nudists-at-sunsport-gardens-naturist-resort-reveal-more-than-bare-asses-nsfw-6408679" data-objid="6408679" title="Young Nudists at Sunsport Gardens Naturist Resort Reveal More Than Bare Asses (NSFW)">Young Nudists at Sunsport Gardens Naturist Resort Reveal More Than Bare Asses (NSFW)</a></li>
      
        <li><a href="https://www.browardpalmbeach.com/music/ten-most-wtf-kanye-west-lyrics-of-all-time-6419585" data-objid="6419585" title="Ten Most WTF Kanye West Lyrics of All Time">Ten Most WTF Kanye West Lyrics of All Time</a></li>
      
        <li><a href="https://www.browardpalmbeach.com/music/ten-best-stripper-dance-moves-of-exxxotica-2013-in-animated-gifs-nsfw-6403385" data-objid="6403385" title="Ten Best Stripper Dance Moves of Exxxotica 2013 in Animated GIFs (NSFW)">Ten Best Stripper Dance Moves of Exxxotica 2013 in Animated GIFs (NSFW)</a></li>
      
    </ul>

    
    
    
      
      <script>
      jQuery(document).ready(function($) {

        Sailthru.personalize({
          "sections": [
        
          {
            "id":  "74f5d204-7f6b-11e6-83a4-002590d1a2f6",
            "selector": ".SailthruRecommendations-11767450 > ul",
            "onSuccess":  function(response) {
              Foundation.SailthruSPM.Personalize({
                "selector": ".SailthruRecommendations-11767450 > ul", 
                "data": response,
                
                  "count": 4,
                
                "template": (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`
              });
            }
          }
        
      ],
          "vars": {
            "placed": "11767450"  
          }
        });
      });
    </script>
    
 
  </div>


          </div>

          <div class="uk-width-expand@s fdn-content-placeholder avantis-hook">
            <div class="ZoneA ConnatixPlayerContentQueryDynamicresponsive  uk-width-1-1 uk-flex uk-flex-center uk-margin-remove-top uk-root fdn-margin-vert ConnatixPlayerContentQueryDynamic comp-" data-component-id="ConnatixPlayerContentQueryDynamic">
  <script id="ConnatixPlayerContentQueryDynamic-11767450">
    console.log('connatix widget', document.currentScript)
    if(typeof cnxps != "undefined") {
      cnxps.cmd.push(function () {
        cnxps({
          playerId: 'fa1a7bec-bdf3-40b6-b664-eda00fc9dc98'
        }).render('ConnatixPlayerContentQueryDynamic-11767450');
      });
    }
  </script>
</div>
          </div>
        </div>

        











<div class="ZoneA NewsletterSignup657responsive   uk-root fdn-margin-vert NewsletterSignup657 comp-newsletter-newslettersignup" data-component-id="NewsletterSignup657">
  <div class="uk-flex uk-flex-wrap uk-width-1-1 fdn-newsletter-signup-medium">
    <div class="uk-flex uk-flex-wrap fdn-newsletter-signup-main">
      <div class="fdn-newsletter-signup-logo">
        <img src="/images/air/newsletter-icon-bpb.png" alt="">
      </div>

      <div class="uk-flex uk-flex-wrap fdn-newsletter-signup-text-block">
        <div class="fdn-newsletter-signup-text">
          <div class="fdn-newsletter-signup-text-large-only">
            Don't Miss Out
          </div>
          <strong>SIGN UP</strong> for the latest 
          
            Music
          
          news, free stuff and more!
        </div>

        <div class="fdn-newsletter-signup-button-block">
          
          <div class="pelcro-logged-out">
            <a href="#newsletterSignUp"
               class="pelcro-subscribe-button fdn-newsletter-signup-button" 
               data-product-id="553" 
               data-vmgs-psource="In-Article Sign Up|Music"
               data-vmgs-section="Music"
               onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-Music', {'NonInteraction': 1});">
              Join Today <i class="fas fa-caret-right"></i>
            </a>
          </div>

          
          <div class="pelcro-logged-in">
            <a href="/profile" 
               class="fdn-newsletter-signup-button"
               onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-Music', {'NonInteraction': 1});">
              Sign Up
            </a>
          </div>
        </div>
      </div>
    </div>

    <div class="uk-flex uk-flex-wrap fdn-newsletter-signup-secondary">
      <div class="fdn-newsletter-signup-secondary-text">
        Become a member to support the independent voice of South Florida 
  and help keep the future of New Times <strong>FREE</strong>
      </div>
      <div class="fdn-newsletter-signup-secondary-link-block uk-flex uk-flex-wrap uk-flex-middle uk-width-1-1">
        <a href="/i-support" class="fdn-newsletter-signup-secondary-link">I Support
        <img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach"> 
      </a>
        <a href="/i-support" class="fdn-newsletter-signup-secondary-link-learn-more">Learn More</a>
      </div>
    </div>
  </div>
</div>

        
        




      </div>
    </div>

    
    <div class="uk-width-auto uk-visible@sm uk-margin-left" style="width: 300px;" distribute-right-column-items>
      <div class="beforeBillboard uk-flex uk-flex-column">
    
    <div class="stickCeption1" style="z-index: 10;" 
         uk-sticky="
           offset: 100;
           bottom: true;">
      
      <script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=8d95866a&key=c6ef7031ed64f8991f3be28247bfcfac&req=js&vrd=2&vri=2&pid=music" async></script>
    </div>

    <div class="stickCeption2 uk-margin-remove" style="z-index: 1;"
         uk-sticky="
           offset: 395;
           bottom: true;">
      <hidden hidden>
<div class="ZoneA AirRectangleTopRightColumnresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirRectangleTopRightColumn comp-" data-component-id="AirRectangleTopRightColumn"
     fdn-ad-component>
  <div apn-ad-hook="rectangleTop" display-targets="desktop">
        <script>
        if (typeof apntag === 'object') {
          apntag.anq.push(function() {
            if (typeof Foundation.ApnAds.fillAds === 'function') {
              Foundation.ApnAds.fillAds()
            }
          })
        }
        </script>
      </div>
</div>
</hidden>
    </div>
  </div>

  <div class="billboardSpacer" style="pointerEvents: none;"></div>

  <div class="afterBillboard uk-flex uk-flex-column">
    <div class="stickCeption"style="z-index: 1;"
         uk-sticky="
           offset: 100;
           bottom: true;">
      
      


















      
  

  
      <div class="ZoneA LatestInCategoryresponsive  fdn-component-related-items uk-root fdn-margin-vert LatestInCategory comp-content-latestincategory" data-component-id="LatestInCategory">
        <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Latest Stories
        
      </h3>

      

      
    </div>
        <ul class="pres-ContentListSquareBrief uk-list uk-list-divider">
    
    

    <li class="">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.browardpalmbeach.com/music/eric-clapton-and-van-morrison-coming-to-hard-rock-live-in-hollywood-florida-11630063">
          <p class="fdn-teaser-headline">
            Two COVID-Denying Rockers Are Bound for the Hard Rock Live 
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Jose D. Duran
            </p>
          

          <time>
            Jun 21, 2021
          </time>
        </div>

      </div>

      
        <div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
          <a href="https://www.browardpalmbeach.com/music/eric-clapton-and-van-morrison-coming-to-hard-rock-live-in-hollywood-florida-11630063">
            <img uk-img="" 
           data-src="https://media2.fdncms.com/bpb/imager/u/r-bigsquare/11630062/eric_clapton_2021_1.jpg?cb=1624025677"
           alt="Eric Clapton"
           width="400"
           height="400"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.browardpalmbeach.com/music/seth-troxler-talks-about-his-twitch-channel-dream-access-tv-11567882">
          <p class="fdn-teaser-headline">
            Public Access 2.0 
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Harry Levin
            </p>
          

          <time>
            Jun 10, 2021
          </time>
        </div>

      </div>

      
        <div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
          <a href="https://www.browardpalmbeach.com/music/seth-troxler-talks-about-his-twitch-channel-dream-access-tv-11567882">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/bpb/imager/u/r-bigsquare/11567879/seth_tv_01.jpg?cb=1623338173"
           alt="Seth Troxler&#39;s new Twitch channel, Dream Access TV, is a venue for dance-music artists to express themselves in different ways."
           width="400"
           height="400"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
    

    <li class="">
    <div class="uk-flex">
      <div class="uk-flex-1 uk-margin-remove">

        

        <a href="https://www.browardpalmbeach.com/music/interview-with-miami-rapper-freese-cola-11559057">
          <p class="fdn-teaser-headline">
            Freese Cola Bounces Back 
          </p>
        </a>

        <div class="fdn-teaser-infoline fdn-inline-split-list">
          
            <p>
              By Tony M. Centeno
            </p>
          

          <time>
            Jun  9, 2021
          </time>
        </div>

      </div>

      
        <div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
          <a href="https://www.browardpalmbeach.com/music/interview-with-miami-rapper-freese-cola-11559057">
            <img uk-img="" 
           data-src="https://media1.fdncms.com/bpb/imager/u/r-bigsquare/11559052/freese-cola.jpeg?cb=1623248522"
           alt="4Blocc Records founder Freese Cola"
           width="400"
           height="400"
           class="" />
          </a>
        </div>
      
    </div>
  </li>

    
  
        </ul>
        <div class="uk-margin-small uk-clearfix uk-text-right ">
      <a class="uk-align-right uk-margin-remove fdn-more-link uk-flex-inline uk-flex-middle" href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?category=6386287">
        More &raquo;
      </a>
    </div>
      </div>
    




      
      <hidden hidden>
<div class="ZoneA AirMediumRectangleRightColBelowBillboardresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleRightColBelowBillboard comp-" data-component-id="AirMediumRectangleRightColBelowBillboard"
     fdn-ad-component>
  <div apn-ad-hook="rectangle" display-targets="desktop">
        <script>
        if (typeof apntag === 'object') {
          apntag.anq.push(function() {
            if (typeof Foundation.ApnAds.fillAds === 'function') {
              Foundation.ApnAds.fillAds()
            }
          })
        }
        </script>
      </div>
</div>
</hidden>
    </div>
  </div>
    </div>

  </div>
        </div>
      

      
      
        
        <div class="content-multiple-item" 
      fdn-content-multi-item="11767430"
      fdn-content-multi-item-headline="Rolling Loud Needed Only One Thing to Survive the Pandemic: The Fans"
      fdn-content-multi-item-permalink="/music/rolling-loud-2021-the-hip-hop-festival-finally-returns-to-miami-july-23-25-11767430"
      fdn-content-multi-item-canonical="https://www.miaminewtimes.com/music/rolling-loud-2021-the-hip-hop-festival-finally-returns-to-miami-july-23-25-12499656"
      fdn-content-multi-item-title="Rolling Loud Needed Only One Thing to Survive the Pandemic: The Fans"
      fdn-content-multi-item-thumb="https://media1.fdncms.com/bpb/imager/u/slideshow/11767426/deathrow_rolling_loud.jpg?cb=1626448450"
      fdn-content-multi-item-thumb-width="1524"
      fdn-content-multi-item-thumb-height="1270"
      ga-dimension2="Music" ga-dimension3="11767430" ga-dimension4="2021-07-16 11:17:00" ga-dimension5="Music Festivals%Interviews" ga-dimension6="Tony M. Centeno" ga-dimension7="Articles"
      fdn-content-multi-item-loader="fetch">
        </div>
      
        
        <div class="content-multiple-item" 
      fdn-content-multi-item="11712639"
      fdn-content-multi-item-headline="Can Yeison Jiménez Take Colombia's Música Popular International?"
      fdn-content-multi-item-permalink="/music/things-to-do-in-miami-yeison-jimenez-at-charles-f-dodge-city-center-july-3-2021-11712639"
      fdn-content-multi-item-canonical="https://www.miaminewtimes.com/music/things-to-do-in-miami-yeison-jimenez-at-charles-f-dodge-city-center-july-3-2021-12452720"
      fdn-content-multi-item-title="Can Yeison Jiménez Take Colombia's Música Popular International?"
      fdn-content-multi-item-thumb="https://media1.fdncms.com/bpb/imager/u/slideshow/11712636/yeison_jimenez_1200.jpg?cb=1625153506"
      fdn-content-multi-item-thumb-width="1524"
      fdn-content-multi-item-thumb-height="1143"
      ga-dimension2="Music" ga-dimension3="11712639" ga-dimension4="2021-07-01 11:34:00" ga-dimension5="Concerts%Interviews" ga-dimension6="Luis Gomez" ga-dimension7="Articles"
      fdn-content-multi-item-loader="fetch">
        </div>
      

      
      <script
        src="https://code.jquery.com/jquery-1.12.4.min.js"
        integrity="sha256-ZosEbRLbNQzLpnKIkEdrPv7lOy9C27hHQ+Xp8a4MxAQ="
        crossorigin="anonymous"></script>

      <script>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</script>
    </div>
  


      </div>
    </div>
      
    <div class="ev-grid-zone ev-column-zone uk-flex uk-flex-wrap uk-child-width-1-2@m"> 
      <div class="ev-grid-col" data-ev-zone="ZoneB">
        
      </div>

      <div class="ev-grid-col" data-ev-zone="ZoneC">
        
      </div>
    </div> 

    <div class="ev-grid-zone ev-secondary-zone" data-ev-zone="ZoneD">
      <div class="ev-grid-col uk-width-1-1">
        
      </div>
    </div> 

    <div class="ev-grid-zone ev-footer-zone" data-ev-zone="GlobalFooter">
      <div class="ev-grid-col uk-width-1-1">
        



<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert NewsletterModal comp-newsletter-newslettermodal" data-component-id="NewsletterModal">
  
  

  <div id="NewsletterModal" class="uk-flex-top" uk-modal>
    <div class="uk-modal-dialog uk-modal-body uk-padding-remove">
      <div class="uk-flex uk-flex-right">
        
        <button class="uk-modal-close-default uk-position-top-right" type="button" uk-close onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'CloseX', {'nonInteraction': 1});"></button>
      </div>

      <div class="uk-flex fdn-newsletter-modal-wrap">
        <div class="fdn-newsletter-modal-left uk-flex uk-flex-middle">
          <p class="uk-margin-auto">Join the New Times community and help support independent 
  local Journalism in South Florida.</p>
        </div>

        <div class="fdn-newsletter-modal-right uk-flex-1 uk-flex uk-flex-column uk-flex-wrap uk-padding-small">
          <div class="fdn-newsletter-modal-logo uk-flex uk-flex-bottom uk-margin-medium-top uk-margin-medium uk-margin-small">
            <img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
            <span>Insiders</span>
          </div>

          <div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
            <p class="uk-margin-xsmall">
              Get the latest updates in news, food, music and culture, and receive special offers direct to your inbox.
            </p>
            <div class="uk-flex uk-flex-wrap fdn-newsletter-modal-sign-up-block">
              <a href="#newsletterSignUp"
                 class="pelcro-subscribe-button fdn-newsletter-modal-sign-up-link"
                 data-product-id="553"
                 data-vmgs-psource="Pop Up|Music"
                 data-vmgs-section="Music"
                 onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'Music', {'NonInteraction': 1});">
                Sign Up Now <i class="far fa-sm fa-chevron-right"></i>
              </a>

              
              <a href="#noThanks" class="fdn-newsletter-modal-no-thanks-link uk-modal-close" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'NoThanks', {'nonInteraction': 1});">
                No Thanks
              </a>
            </div>
          </div>

          <div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
            <p class="uk-margin-xsmall">
              Become a member and go ad-free!
            </p>
            <div class="uk-flex uk-width-1-1">
              <a href="/i-support" class="fdn-newsletter-modal-support-link" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'Pelcro-Support', {'NonInteraction': 1});">
                Support Our Journalism <i class="far fa-sm fa-chevron-right"></i>
              </a>
            </div>
          </div>

          <div class="fdn-newsletter-modal-footer uk-text-right uk-margin-auto-top">
            <a href="/about/privacy-policy" target="_blank">Privacy Policy</a>
          </div>
        </div>
      </div>
    </div>
  </div>

  <script>
  jQuery(document).on('PelcroSiteLoaded', function (e) {
    var modalElement = jQuery('#NewsletterModal')

    var modalCookieKey = 'fdn_nlmc'
    var modalCookieValue = null
    var modalCookieValueDisplayed = 'displayed'
    var modalCookieValueClosed = 'CloseX'
    var modalCookieValueNoThanks = 'NoThanks'

    var closeForDays = 15
    var closeForDaysInSeconds = 60 * 60 * 24 * closeForDays
    var closeForDaysMaxAge = 'max-age=' + closeForDaysInSeconds

    var dateNow = new Date()
    var dateInTwoCenturies = new Date(dateNow.setFullYear(dateNow.getFullYear() + 200))
    var dateExpiresLongTime = 'expires=' + dateInTwoCenturies

    var cookieList = document.cookie.split('; ')
    var modalCookie = cookieList.find(item => item.startsWith(modalCookieKey))

    if (modalCookie) {
      modalCookieValue = modalCookie.split('=')[1]
    }

    var alreadyShown = new RegExp(`^${modalCookieValueDisplayed}|${modalCookieValueClosed}|${modalCookieValueNoThanks}$`)

    var modalTimeout = setTimeout(function () {
      if (window.Foundation && Foundation.Pelcro && Foundation.Pelcro.init) {
        // Make sure pelcro is ready so signup links work
        if (typeof(Pelcro) === "object") {
          if (modalCookieValue && modalCookieValue?.match(alreadyShown)) {
            // console.log('Newsletter signup modal already displayed.')
            return
          }
          else {
            UIkit.modal(modalElement).show();
            document.cookie = `${modalCookieKey}=${modalCookieValueDisplayed}`
          }
        }
      }
    }, 5000)

    modalElement.on('click', '[uk-close]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueClosed}; ${closeForDaysMaxAge}`
    })

    modalElement.on('click', '[href=#noThanks]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueNoThanks}; ${dateExpiresLongTime}`
    })

    // modalElement.on('click', '[href=#newsletterSignUp]', function () {
    //   UIkit.modal(modalElement).hide()
    // })
  })
  </script>
</div>















<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert CookieConsent comp-shell-cookieconsent" data-component-id="CookieConsent">
  <link rel="stylesheet" type="text/css" href="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.css" />
  <script src="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.js" data-cfasync="false"></script>
  <script>
  window.cookieconsent.initialise({
    "palette": {
      "popup": {
        "background": "#000"
      },
      "button": {
        "background": "#f1d600"
      }
    },
    "content": {
      
        "message": "We use cookies to collect and analyze information \n  on site performance and usage, and to enhance and \n  customize content and advertisements. \n  By clicking 'Got it' or continuing to use the site, \n  you agree to allow cookies to be placed. \n  To find out more, visit our \n  <a href=\"\/about\/cookies\">cookies policy<\/a> and our \n  <a href=\"\/about\/privacy-policy\">privacy policy<\/a>.",
      
      

      
        "link": "",
        "href": ""
      
    }
  });
  </script>
</div>




<div class="GlobalFooter ContentDefaultMultiple  uk-margin-remove uk-root fdn-margin-vert SiteFooterCustom comp-shell-sitefooter" data-component-id="SiteFooterCustom">
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-wide uk-visible@s">
<div class="uk-flex uk-child-width-1-5 fdn-custom-footer-navigation-link-block-wide-columns">
<div class="fdn-custom-footer-navigation-link-block-column fdn-custom-footer-navigation-link-block-issue-block">
<a href="http://flipbook.browardpalmbeach.com/2021/07-15-2021/index.html" 
class="uk-display-block" 
onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'Music-VMG-Flipbook-Cover',  {'NonInteraction': 1});"
title="Where They Stood">
<img uk-img=""  
data-src="/imager/b/r-cover/11746345/208d/Cover18_07-15-21.jpeg"
alt="Where They Stood"
width="440"
height="496"
class="" />
<h4 class="uk-margin-small-top uk-margin-remove-bottom">
This Week's Issue
</h4>
</a>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/" 
title="" 
onclick="ga("send", "event", "Nav", "Click", "Editorial")"
>
Editorial 
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Homepage")"
title="">
Homepage
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/news" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "News")"
title="">
News
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/restaurants" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Food & Drink")"
title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/arts" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Arts & Culture")"
title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/music" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Music")"
title="">
Music
</a>
</li>
<li>
<a href="https://herbanplanet.com/" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Cannabis")"
title="">
Cannabis
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-of" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Best of Miami")"
title="">
Best of Miami
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-miami-restaurants" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Required Eating 2021")"
title="">
Required Eating 2021
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/miami-best-bars" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Best Bars 2020")"
title="">
Best Bars 2020
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Restaurant Guide")"
title="">
Restaurant Guide
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/promotions" 
title="" 
onclick="ga("send", "event", "Nav", "Click", "Marketing")"
>
Marketing 
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/promotions" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Promotions")"
title="">
Promotions
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/coupons" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Coupons")"
title="">
Coupons
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902046" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Promotions Newsletter")"
title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/flipbooks" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Flipbooks")"
title="">
Flipbooks
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/about" 
title="" 
onclick="ga("send", "event", "Nav", "Click", "More")"
>
More 
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "About Us")"
title="">
About Us
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/staff" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Staff")"
title="">
Staff
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/careers" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Careers")"
title="">
Careers
</a>
</li>
<li>
<a href="https://adindex.browardpalmbeach.com/" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Classifieds")"
title="">
Classifieds
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/advertise" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Local Advertising")"
title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/terms-of-use" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Terms of Use")"
title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/privacy-policy" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Privacy Policy")"
title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/contact" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Contact Us")"
title="">
Contact Us
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="#" 
title="" 
onclick="ga("send", "event", "Nav", "Click", "Back to Top")"
uk-totop uk-scroll>
Back to Top 
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "California Privacy Policy")"
title="">
California Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#CollectionNotice" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "California Collection Notice")"
title="">
California Collection Notice
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#DoNotSell" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Do Not Sell My Info")"
title="">
Do Not Sell My Info
</a>
</li>
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" 
href="https://www.facebook.com/newtimesbpb" 
onclick="ga("send", "event", "Nav", "Click", "Facebook")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" 
href="https://www.instagram.com/newtimesbroward/" 
onclick="ga("send", "event", "Nav", "Click", "Instagram")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" 
href="https://twitter.com/newtimes_bpb" 
onclick="ga("send", "event", "Nav", "Click", "Twitter")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-narrow uk-hidden@s">
<div class="fdn-custom-footer-navigation-link-block-narrow-rows">
<div class="fdn-custom-footer-navigation-link-block-row">
<ul class="uk-nav-default uk-nav-parent-icon" uk-nav="multiple: false">
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/" 
target="_self" 
class="fdn-custom-footer-navigation-link-block-row-header" >
Editorial 
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Homepage")"
title="">
Homepage
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/news" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "News")"
title="">
News
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/restaurants" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Food & Drink")"
title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/arts" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Arts & Culture")"
title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/music" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Music")"
title="">
Music
</a>
</li>
<li>
<a href="https://herbanplanet.com/" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Cannabis")"
title="">
Cannabis
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-of" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Best of Miami")"
title="">
Best of Miami
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-miami-restaurants" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Required Eating 2021")"
title="">
Required Eating 2021
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/miami-best-bars" 
target="_blank" 
onclick="ga("send", "event", "Nav", "Click", "Best Bars 2020")"
title="">
Best Bars 2020
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Restaurant Guide")"
title="">
Restaurant Guide
</a>
</li>
</ul>
</li>    
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/promotions" 
target="_self" 
class="fdn-custom-footer-navigation-link-block-row-header" >
Marketing 
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/promotions" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Promotions")"
title="">
Promotions
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/coupons" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Coupons")"
title="">
Coupons
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902046" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Promotions Newsletter")"
title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/flipbooks" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Flipbooks")"
title="">
Flipbooks
</a>
</li>
</ul>
</li>    
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/about" 
target="_self" 
class="fdn-custom-footer-navigation-link-block-row-header" >
More 
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/about" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "About Us")"
title="">
About Us
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/staff" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Staff")"
title="">
Staff
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/careers" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Careers")"
title="">
Careers
</a>
</li>
<li>
<a href="https://adindex.browardpalmbeach.com/" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Classifieds")"
title="">
Classifieds
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/advertise" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Local Advertising")"
title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/terms-of-use" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Terms of Use")"
title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/privacy-policy" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Privacy Policy")"
title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/contact" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Contact Us")"
title="">
Contact Us
</a>
</li>
</ul>
</li>    
<li class="uk-parent">
<a href="#" 
target="_self" 
class="fdn-custom-footer-navigation-link-block-row-header" uk-totop uk-scroll>
Back to Top 
</a>
</li>    
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" 
href="https://www.facebook.com/newtimesbpb" 
onclick="ga("send", "event", "Nav", "Click", "Facebook")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" 
href="https://www.instagram.com/newtimesbroward/" 
onclick="ga("send", "event", "Nav", "Click", "Instagram")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" 
href="https://twitter.com/newtimes_bpb" 
onclick="ga("send", "event", "Nav", "Click", "Twitter")"
target="_blank" 
rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-links">
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "California Privacy Policy")"
title="">
California Privacy Policy 
</a>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#CollectionNotice" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "California Collection Notice")"
title="">
California Collection Notice 
</a>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#DoNotSell" 
target="_self" 
onclick="ga("send", "event", "Nav", "Click", "Do Not Sell My Info")"
title="">
Do Not Sell My Info 
</a>
</div>
</div>
</div>
<div class="uk-flex uk-flex-center uk-margin-medium-top custom-footer-row-bottom custom-footer-row">
<div class="uk-text-center">
<div class="fdn-copyright-text">
Use of this website constitutes acceptance of our 
<a href="/about/terms-of-use">terms of use</a>, 
<a href="/about/cookies">our cookies policy</a>, and our 
<a href="/about/privacy-policy">privacy policy</a>
The New Times Broward-Palm Beach may earn a portion of sales from products & services purchased through links on our site from our 
affiliate partners.
©2021 
New Times BPB, LLC. All rights reserved.
</div>
<div class="fdn-copyright-text uk-margin-small-top">
<a class="fdn-copyright-link" href="https://publishwithfoundation.com/" target="_blank">
<img width="110" alt="Powered By Foundation" src="/images/PoweredByFoundation.svg">
</a>
</div>
</div>
</div>
</div><script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '578316758957526'); // Insert your pixel ID here.
  fbq('track', 'PageView');
  </script>
  <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=578316758957526&ev=PageView&noscript=1"/></noscript>

  <script type='text/javascript'>
  var _sf_async_config = _sf_async_config || {};
  var _sf_async_config = {};
  _sf_async_config.uid = 10424;
  _sf_async_config.domain = 'browardpalmbeach.com';
  _sf_async_config.useCanonical = true;
  _sf_async_config.sections = '/music';
  _sf_async_config.authors = 'Luis Gomez';

  (function() {
    function loadChartbeat() {
        window._sf_endpt = (new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
    }
    var oldonload = document.ready;
    document.ready = (typeof document.ready != 'function') ? loadChartbeat : function() {
        oldonload();
        loadChartbeat();
    };
  })();
  </script>

  <!--  Quantcast Tag -->
  <script>
   var ezt = ezt ||[];

   (function(){
     var elem = document.createElement('script');
     elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
     elem.async = true;
     elem.type = "text/javascript";
     var scpt = document.getElementsByTagName('script')[0];
     scpt.parentNode.insertBefore(elem,scpt);
   }());


   ezt.push({qacct: 'p-a4LDpi_DEopn-',
         uid: ''
             });
  </script>
  <noscript>
    <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>
  <!-- End Quantcast Tag -->

  <!-- Audigent Tagging Code -->
  <script>
  (function(w,d,t,u){
      var a=d.createElement(t);a.async=1;a.src=u+"?url="+encodeURIComponent(w.location.href)+"&ref="+encodeURIComponent(d.referrer);
      var s=d.getElementsByTagName(t)[0]; s.parentNode.insertBefore(a,s);
  })(window, document, 'script', 'https://a.ad.gt/api/v1/u/matches/322')
  </script>
  <!-- End Audigent Tagging Code -->
      </div>
    </div>

    <div class="ev-grid-zone ev-closer-zone" data-ev-zone="Closer">
      <div class="ev-grid-col uk-width-1-1">
        
      </div>
    </div>

  </div>
</div>



    </body>
</html>
  


