
<!DOCTYPE html>
<html class="uk-root" lang="en">
<head>
<script src="/cdn-cgi/apps/head/DCZQMHiqo63orxcbUvfAGIDFX1w.js"></script><link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.min.css?cb=ea68ebdd5305bde56fa0f6800681bb0a" />
<script src="/fdn-system/assets/pub/scripts/uikit.min.js"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js"></script>
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta charset="UTF-8">
<meta name="layout" content="Content Default - Multiple (Responsive, Air)" />
<meta name="oid" content="13719549" />
<script>
window.__FOUNDATION_RESPONSIVE__ = true
// 
window.__FBAPIv__ = 'v3.2'
// 
</script>
<script src="/foundation/scripts/foundation-air-2-0-1.js?cb=d8ae86dc0f7e24a877c454dcef5908f9"></script>
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: Whole Site" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: News Section" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml?oid=6305865" />
<link rel="alternate" type="application/rss+xml" title="New Times Broward-Palm Beach RSS: The Daily Pulp" href="https://www.browardpalmbeach.com/browardpalmbeach/Rss.xml?oid=6386283" />
<script>
fixupProfileLinks("https:\/\/www.browardpalmbeach.com\/browardpalmbeach\/Profile", "https:\/\/posting.browardpalmbeach.com\/browardpalmbeach\/MyProfile");
</script>
<meta name="google-signin-client_id" content="8236563300-isg7q42t0f897pmj090770umn1c5t1dt.apps.googleusercontent.com">

<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Oswald:wght@300;400;700&family=Roboto+Condensed:wght@300;400;700&family=Roboto+Slab:wght@400;700&family=Roboto:wght@100;300;400;500;700&display=swap" rel="stylesheet">
<style>
:root {
--primary-color: #009;
--alt-primary-color: #900;
}
</style>
<script>
!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.playspace.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>

<script>
var Pelcro = window.Pelcro || (window.Pelcro = {});
Pelcro.siteid = "1022";
Pelcro.environment = {
"ui": "https://js.pelcro.com/ui/plugin/west-word/main.min.js"
};
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.Pelcro = window.Foundation.Pelcro || {};
Foundation.Pelcro.init = function () {
if (typeof(Foundation.Pelcro.user) === 'undefined' &&
typeof(Pelcro) === "object" &&
typeof(Pelcro.user) === "object" &&
Pelcro.user.isAuthenticated()) {
var user = Pelcro.user.read();
if (typeof(user) === "object" && !jQuery.isEmptyObject(user)) {
Foundation.Pelcro.user = user;
if (typeof(Foundation.Pelcro.user.subscriptions) === "object" &&
!jQuery.isEmptyObject(Foundation.Pelcro.user.subscriptions) &&
Foundation.Pelcro.user.subscriptions.length > 0) {
var subscription = Foundation.Pelcro.user.subscriptions[0];
if (subscription.status == "active") {
Foundation.Pelcro.subscription = subscription.plan.product.name;
}
}
jQuery(document).ready(function($) {
$(".pelcro-logout-button").click(function() {
Pelcro.user.logout();
});
$(".pelcro-logged-in").show();
$(".pelcro-logged-out").hide();
var email = Foundation.Pelcro.user.email;
if (email) {
var username = email;
if (username.length > 26) {
username = username.split("@", 1)[0];
}
$(".pelcro-user-name").html(username);
}
});
}
}
return (typeof(Foundation.Pelcro.user) === "object");
};
document.addEventListener("PelcroUserLogin", function (e) {
});
document.addEventListener("PelcroUserLogout", function (e) {
});
document.addEventListener("PelcroUserLoaded", function (e) {
Foundation.Pelcro.init();
});
</script>
<script async="" src="https://js.pelcro.com/sdk/main.min.js" type="text/javascript"></script>


<style>
.pelcro-logged-in {display:none;}
</style>

<style>
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn {
background: #900 !important;
border-color: #900 !important;
background-image: none !important;
}
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:focus,
#pelcro-app .pelcro-prefix-view .pelcro-prefix-btn:hover
{
background: #900 !important;
border-color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-link, #pelcro-app .pelcro-prefix-view a{
color: #900 !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval .active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-plan-item.active {
background-color: #900 !important;
color: white !important;
}
#pelcro-app #list .pelcro-prefix-view .pelcro-prefix-interval button {
color: #900 !important;
}
</style>
<script>
// 
var Foundation = window.Foundation || {};
Foundation.Pelcro = window.Foundation.Pelcro || {};
console.time('Pelcro polling');
Foundation.Pelcro.pollCount = 0;
Foundation.Pelcro.pollForUser = setInterval(function() {
// 
if (Foundation.Pelcro.init() || Foundation.Pelcro.pollCount >= 100) {
// 
if (Foundation.Pelcro.init()) {
// 
jQuery('.fdn-site-header-login-block').addClass('logged-in');
var email = Foundation.Pelcro.user.email;
if (email) {
// 
jQuery(function() {
jQuery.get("https://posting.browardpalmbeach.com/browardpalmbeach/API/Sailthru/User", {"email": email}).done(function(data) {
// 
var newsletters = data.newsletters;
if (Array.isArray(newsletters) &&
newsletters.length > 0) {
jQuery("div.MySubscriptions input[type='checkbox'][name='newsletter']").each(function (i, v) {
var e = jQuery(v);
var oid = e.data("fdnOid");
if (oid) {
e.prop("checked", (jQuery.inArray(oid, newsletters) !== -1)).change();
e.closest(".fdn-subscriptions-special-member-placement").toggleClass("fdn-subscriptions-special-member-placement", (jQuery.inArray(oid, newsletters) === -1));
}
});
}
// 
var token = data.token;
if (token) {
// 
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
var oid = jQuery(this).data("fdnOid");
if (oid) {
var request = {
"token": token
};
request[this.checked?"subscribe":"unsubscribe"] = oid;
jQuery.post(
"https://posting.browardpalmbeach.com/browardpalmbeach/API/Sailthru/User",
request
);
}
}).prop('disabled', false);
}
});
});
}
}
// 
else {
// 
}
clearInterval(Foundation.Pelcro.pollForUser);
if (Foundation.Pelcro.subscription == "Member" ||
Foundation.Pelcro.subscription == "Donor") {
jQuery("div.MySubscriptions .fdn-subscriptions-special-member-placement").removeClass("fdn-subscriptions-special-member-placement");
}
// 
if (Foundation.Pelcro.subscription == "Member") {
jQuery('[fdn-ad-component]').remove()
jQuery('div[stn-embed-toc], div[stn-embed-toc-embedded]').remove();
jQuery('div[stn-embed-not-mobile], div[stn-embed-not-mobile-embedded]').remove();
jQuery('div[stn-embed-mobile-only], div[stn-embed-mobile-only-embedded]').remove();
// One more time on document ready
jQuery(function() { 
jQuery('[fdn-ad-component]').remove() 
jQuery('div[stn-embed-toc], div[stn-embed-toc-embedded]').remove();
jQuery('div[stn-embed-not-mobile], div[stn-embed-not-mobile-embedded]').remove();
jQuery('div[stn-embed-mobile-only], div[stn-embed-mobile-only-embedded]').remove();
});
// 
}
// 
else {
if(window.Foundation && Foundation.ApnAds && typeof Foundation.ApnAds.setup === 'function') {
// 
Foundation.ApnAds.setup();
}
jQuery('wheresweed-nearby-businesses').closest('[hidden]').attr('hidden', false)
Foundation.WheresWeed = true
}
console.timeEnd('Pelcro polling');
}
// 
else {
Foundation.Pelcro.pollCount++;
}
}, 30);
// 
jQuery(document).on("PelcroUserLogin", function (e) {
setTimeout(function() {
jQuery('body').removeClass('pelcro-modal-open').attr('class');
}, 10);
});
// 
jQuery(function() {
jQuery('div.MySubscriptions input[type="checkbox"][name="newsletter"]').change(function () {
jQuery(this).siblings('.fdn-subscriptions-column-item-subscribed-header').text(this.checked?'Subscribed':'Unsubscribed');
}).change();
});
</script>
<meta name="ir-site-verification-token" value="-1062343762" />
<meta property="fb:pages" content="68098170202" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script>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</script>
<script>
// Right column ads refresh every 30 seconds while in view on content pages
jQuery(function () {
var interval = 30000;
var percentVisable = 0.50; // Percent as a decimal 1 === 100%, 25% === 0.25
var refreshInterval = null;
refreshInterval = setInterval(function () {
// Only for larger layouts
if (window.innerWidth > Foundation.ApnAds.mobileWidth) {
var adList = [];
jQuery('[distribute-right-column-items] [id^=apn-tower], [distribute-right-column-items] [id^=apn-rectangle]').each(function () {
var elementHeight = jQuery(this).height()
var topOffset = elementHeight * percentVisable
var bottomOffset = elementHeight * percentVisable
// element top left right bottom edges relative to window top-left postion and dimensions
var elmentBounds = jQuery(this).get(0).getBoundingClientRect()
var elementTop = elmentBounds.top
var elementBottom = elmentBounds.bottom
var topOfView = topOffset
var bottomOfView = window.innerHeight - bottomOffset
var topInView = elementTop >= topOfView && elementTop <= bottomOfView
var bottomInView = elementBottom >= topOfView && elementBottom <= bottomOfView
var middleCoversView = elementTop < topOfView && elementBottom > bottomOfView
var inView = topInView || bottomInView || middleCoversView
// console.log(inView, topInView, topInView, element)
if (inView) {
adList.push(jQuery(this).attr('id'));
}
})
if (adList.length) {
window.apntag.anq.push(function() {
apntag.refresh(adList);
});
// console.log('refreshed ads', adList)
}
}
}, interval)
})
</script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-395255-25', { 'siteSpeedSampleRate': 5 });
ga('set', 'dimension2', 'News');
ga('set', 'dimension3', '13719549');
ga('set', 'dimension4', '2022-07-26 10:00:00');
ga('set', 'dimension5', 'Police');
ga('set', 'dimension6', 'Alex DeLuca');
ga('set', 'dimension7', 'Articles');
ga('send', 'pageview');
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-K6K4GEWM1V"></script>
<script>
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'G-K6K4GEWM1V');
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6648850737115177" crossorigin="anonymous"></script>

<script async src="https://cdn.avantisvideo.com/avm/js/video-loader.js?id=28be7cf9-a403-44c7-b272-eba9c55167ae&tagId=1" id='avantisJS'></script>
<script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
<script>
var Foundation = window.Foundation || (window.Foundation = {});
Foundation.SailthruSPM = window.Foundation.SailthruSPM || (window.Foundation.SailthruSPM = {});
Foundation.SailthruSPM.Personalize = function(options) {
const selector = options.selector;
const data = options.data;
const template = (typeof(options.template) === "function") ? options.template : (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`;
if (!selector) {
return;
}
else if (data.length == 0) {
return;
}
const elements = document.querySelectorAll(selector);
if (elements.length == 0) {
return;
}
const articles = JSON.parse(data.json);
const count = options.count ? options.count : articles.length;
const html = articles.slice(0, count).map(template);
elements.forEach(
element => {
if (!element.classList.contains("sailthruSPMLoaded")) {
element.innerHTML = html.join('');
element.classList.add("sailthruSPMLoaded");
}
}
);
}
Sailthru.init({
"isCustom": true,
"customerId": "b09c5f4a0da5ce54e5ccccb6a407cd6e"
});
</script>
<script async>
setTimeout(() => {
if (Foundation.Pelcro.subscription === "Member") {
jQuery('sellwild').remove();
}
else {
setTimeout(() => {
const sellWildScript = document.createElement('script');
sellWildScript.src = `//widget.sellwild.com/voicemedia/voicemedia-browardpalmbeach.js`;
jQuery('head').append(sellWildScript);
}, 300);
}
}, 5000);
</script>





<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Jury Exonerates Ex-BSO Deputy Who Battered Teen Delucca Rolle in 2019 | New Times Broward-Palm Beach" />
<meta name="description" content="A jury cleared former Broward County Sheriff&#39;s Deputy Christopher Krickovich in the rough arrest of then-15-year-old Delucca Rolle, whose nose was broken in the altercation." />
<meta name="keywords" content="Delucca Rolle, Broward Sheriff&#39;s Office, BSO, Christopher Krickovich, Ben Crump, J.P. Taravella High School, Sun Sentinel, rough arrest" />
<title>Jury Exonerates Ex-BSO Deputy Who Battered Teen Delucca Rolle in 2019 | New Times Broward-Palm Beach</title>
<meta name="date" content="2022-07-26 10:00:00" />
<meta name="author" content="Alex DeLuca">
<meta name="news_keywords" content="delucca rolle, broward sheriffs office, bso, christopher krickovich, ben crump, jp taravella high school, sun sentinel, rough arrest" />
<link rel="image_src" href="https://media1.browardpalmbeach.com/bpb/imager/u/slideshow/13719547/taravella.jpg" />
<meta name="thumbnail" content="https://media1.browardpalmbeach.com/bpb/imager/u/slideshow/13719547/taravella.jpg" />
<link rel="canonical" href="https://www.miaminewtimes.com/news/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-14944919" />
<meta property="og:url" content="https://www.miaminewtimes.com/news/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-14944919" />
<meta property="fb:app_id" content="835681050493442" />
<meta property="og:site_name" content="New Times Broward-Palm Beach" />
<meta property="og:title" content="Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old" />
<meta property="og:image" content="https://media1.browardpalmbeach.com/bpb/imager/u/slideshow/13719547/taravella.jpg" />
<meta property="og:image:width" content="1524" />
<meta property="og:image:height" content="677" />
<meta property="og:description" content="A jury has cleared former Broward Sheriff&#39;s deputy Christopher Krickovich of all charges stemming from the violent takedown." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media1.browardpalmbeach.com/bpb/imager/u/slideshow/13719547/taravella.jpg">
<meta name="twitter:creator" content="@alexldeluca">
<meta name="twitter:site" content="@newtimes_bpb">
<meta name="twitter:title" content="Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old">
<meta name="twitter:description" content="A jury has cleared former Broward Sheriff&#39;s deputy Christopher Krickovich of all charges stemming from the violent takedown.">

<script type="application/ld+json">
{
"mainEntityOfPage": {
"@type": "WebPage",
"@id":"https:\/\/www.browardpalmbeach.com\/news\/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549"
},
"headline": "Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old",
"description": "A jury has cleared former Broward Sheriff's deputy Christopher Krickovich of all charges stemming from the violent takedown.",
"image": {
"url": "https:\/\/media1.browardpalmbeach.com\/bpb\/imager\/u\/original\/13719547\/taravella.jpg",
"width": 1200,
"height": 533,
"@type": "ImageObject"
},
"datePublished": "2022-07-26T10:00:00",
"dateModified": "2022-07-26T10:00:07",
"author": {
"name": "Alex DeLuca",
"url": "https:\/\/www.browardpalmbeach.com\/author\/alex-deluca",
"@type": "Person"
},
"publisher": {
"name": "New Times Broward-Palm Beach",
"logo": {
"url": "https:\/\/www.browardpalmbeach.com\/imager\/b\/google-amp-logo\/808579\/99a2\/binary-viewer.png",
"width": 1320,
"height": 816,
"@type": "ImageObject"
},
"@type": "Organization"
},
"@context": "https://schema.org",
"@type": "NewsArticle"
}
</script>
<script>window.twttr = (function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0],
t = window.twttr || {};
if (d.getElementById(id)) return t;
js = d.createElement(s);
js.id = id;
js.src = "https://platform.twitter.com/widgets.js";
fjs.parentNode.insertBefore(js, fjs);
t._e = [];
t.ready = function(f) {
t._e.push(f);
};
return t;
}(document, "script", "twitter-wjs"));</script>
</head>
<script src="/fdn-system/assets/pub/scripts/ResizeSensor.js"></script>
<script src="/fdn-system/assets/pub/scripts/ElementQueries.js"></script>
<script>
ElementQueries.listen();
</script>
<body id="Content" class="bpb ContentDefault news pulp RespOneCol">
<script>
ElementQueries.init();
</script>
<div id="fdn-navigation-dropdown-hook" style="width:100%;height:0;position:fixed;"></div>
<div id="fb-root"></div>
<script>
(function () {
var app = new Foundation.Facebook.Application();
app.receiveAuthNotifications();
app.receiveLikeNotifications();
})();
</script>
<script>
(function () {
var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
//if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
}.bind(this), function(){
if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
})
})()
</script>
<div id="ContentDefault" class="grid-resp-1 page layout-ContentDefault">
<div class="ev-grid-layout ev-clamp@m ev-clamp@l">
<div class="ev-grid-zone ev-leader-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="Leader">
</div>
</div>
<div class="ev-grid-zone ev-header-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="GlobalHeader">
<div uk-sticky class="GlobalHeader ContentDefaultMultiple   uk-root fdn-margin-vert SiteHeaderGrid comp-shell-siteheader" data-component-id="SiteHeaderGrid">
<div class="fdn-site-header-flex">
<div class="fdn-site-header-nav-toggle-narrow uk-hidden@sm">
<a href="#offcanvas-slide-navigation" class="fdn-nav-toggle uk-button" uk-toggle>
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="offcanvas-slide-navigation" uk-offcanvas="overlay: true">
<div id="site-nav-target" class="fdn-nav-panel-block uk-offcanvas-bar">
<ul class="site-nav-source uk-width-1-1 uk-nav uk-nav-parent-icon" uk-nav="multiple: false;">
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestNews">
<a href="https://www.browardpalmbeach.com/news" onclick='ga("send", "event", "Nav", "Click", "Latest News")' target="_self">News<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/news" onclick='ga("send", "event", "Nav", "Click", "Latest News")' target="_self" title="">Latest News</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305865" onclick='ga("send", "event", "Nav", "Click", "News Archives")' target="_self" title="">News Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/coronavirus-10624039" onclick='ga("send", "event", "Nav", "Click", "Coronavirus")' target="_self" title="">Coronavirus</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/environmental-6386358" onclick='ga("send", "event", "Nav", "Click", "Environmental")' target="_self" title="">Environmental</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/politics-6386326" onclick='ga("send", "event", "Nav", "Click", "Politics")' target="_self" title="">Politics</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestFoodDrink">
<a href="https://www.browardpalmbeach.com/restaurants" onclick='ga("send", "event", "Nav", "Click", "Latest Food & Drink")' target="_self">Food &amp; Drink<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/restaurants" onclick='ga("send", "event", "Nav", "Click", "Latest Food & Drink")' target="_self" title="">Latest Food &amp; Drink</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305867" onclick='ga("send", "event", "Nav", "Click", "Food & Drink Archives")' target="_self" title="">Food &amp; Drink Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/food-news-6386468" onclick='ga("send", "event", "Nav", "Click", "Food News")' target="_self" title="">Food News</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/cocktails-and-spirits-6386450" onclick='ga("send", "event", "Nav", "Click", "Cocktails & Spirits")' target="_self" title="">Cocktails &amp; Spirits</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/openings-and-closings-6386445" onclick='ga("send", "event", "Nav", "Click", "Openings")' target="_self" title="">Openings</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" onclick='ga("send", "event", "Nav", "Click", "Restaurant Guide")' target="_self" title="">Restaurant Guide</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/best-miami-restaurants" onclick='ga("send", "event", "Nav", "Click", "Required Eating 2021")' target="_blank" title="">Required Eating 2021</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/miami-best-bars" onclick='ga("send", "event", "Nav", "Click", "Drink Here 2021")' target="_blank" title="">Drink Here 2021</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902044" onclick='ga("send", "event", "Nav", "Click", "Food & Drink Newsletter")' target="_self" title="">Food &amp; Drink Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestArtsCulture">
<a href="https://www.browardpalmbeach.com/arts" onclick='ga("send", "event", "Nav", "Click", "Latest Arts & Culture")' target="_self">Arts &amp; Culture<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/arts" onclick='ga("send", "event", "Nav", "Click", "Latest Arts & Culture")' target="_self" title="">Latest Arts &amp; Culture</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305869" onclick='ga("send", "event", "Nav", "Click", "Arts & Culture Archives")' target="_self" title="">Arts &amp; Culture Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?narrowByDate=today&sortType=date" onclick='ga("send", "event", "Nav", "Click", "Calendar")' target="_self" title="">Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/art-6386373" onclick='ga("send", "event", "Nav", "Click", "Art")' target="_self" title="">Art</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/MovieTimes" onclick='ga("send", "event", "Nav", "Click", "Movie Times")' target="_self" title="">Movie Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902051" onclick='ga("send", "event", "Nav", "Click", "Arts & Culture Newsletter")' target="_self" title="">Arts &amp; Culture Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-LatestMusic">
<a href="https://www.browardpalmbeach.com/music" onclick='ga("send", "event", "Nav", "Click", "Latest Music")' target="_self">Music<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/music" onclick='ga("send", "event", "Nav", "Click", "Latest Music")' target="_self" title="">Latest Music</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305870" onclick='ga("send", "event", "Nav", "Click", "Music Archives")' target="_self" title="">Music Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/concerts-6386466" onclick='ga("send", "event", "Nav", "Click", "Concerts")' target="_self" title="">Concerts</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/local-music-10849559" onclick='ga("send", "event", "Nav", "Click", "Local Music")' target="_self" title="">Local Music</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/miami/EventSearch?eventSection=6423590&feature=Concert&sortType=date&v=g" onclick='ga("send", "event", "Nav", "Click", "Concert Calendar")' target="_self" title="">Concert Calendar</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902045" onclick='ga("send", "event", "Nav", "Click", "Music Newsletter")' target="_self" title="">Music Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ThingstoDo">
<a href="https://www.browardpalmbeach.com/about" onclick='ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")' target="_self">More<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/things-to-do" onclick='ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")' target="_self" title="">Things to Do/Tickets</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/best-of" onclick='ga("send", "event", "Nav", "Click", "Best of Miami")' target="_self" title="">Best of Miami</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick='ga("send", "event", "Nav", "Click", "Cannabis")' target="_blank" title="">Cannabis</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/SlideshowArchives" onclick='ga("send", "event", "Nav", "Click", "Slideshows")' target="_self" title="">Slideshows</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/promotions" onclick='ga("send", "event", "Nav", "Click", "Promotions")' target="_self" title="">Promotions</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/lists-6386369" onclick='ga("send", "event", "Nav", "Click", "Lists")' target="_self" title="">Lists</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/careers" onclick='ga("send", "event", "Nav", "Click", "New Times Careers")' target="_self" title="">New Times Careers</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/advertise" onclick='ga("send", "event", "Nav", "Click", "Local Advertising")' target="_self" title="">Local Advertising</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/flipbooks" onclick='ga("send", "event", "Nav", "Click", "Flipbook Archives")' target="_self" title="">Flipbook Archives</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902047" onclick='ga("send", "event", "Nav", "Click", "Things To Do Newsletter")' target="_self" title="">Things To Do Newsletter</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902050" onclick='ga("send", "event", "Nav", "Click", "Best Of Newsletter")' target="_self" title="">Best Of Newsletter</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-MiamiNewTimes">
<a href="https://www.voicemediagroup.com/" onclick='ga("send", "event", "Nav", "Click", "Miami New Times")' target="_self">Voice Media Group<span class='uk-icon'><i class="far fa-chevron-left"></i></span></a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick='ga("send", "event", "Nav", "Click", "Miami New Times")' target="_blank" title="">Miami New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick='ga("send", "event", "Nav", "Click", "Dallas Observer")' target="_blank" title="">Dallas Observer</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick='ga("send", "event", "Nav", "Click", "Phoenix New Times")' target="_blank" title="">Phoenix New Times</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick='ga("send", "event", "Nav", "Click", "Westword")' target="_blank" title="">Westword</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick='ga("send", "event", "Nav", "Click", "Coupons Captain")' target="_blank" title="">Coupons Captain</a>
</li>
</ul>
</li>
</ul>
<div class="fdn-site-header-search-block">
<form action="https://www.browardpalmbeach.com/browardpalmbeach/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text" name="keywords" autocomplete="off" type="search" class="fdn-site-header-search-input" placeholder="Search">
<button class="fdn-site-header-search-submit" type="submit"><i class="far fa-search fa-flip-horizontal"></i></button>
</div>
</form>
</div>
</div>
</div>
</div>
<div class="fdn-site-header-nav-toggle-wide uk-visible@sm">
<a class="fdn-nav-toggle uk-button">
<i class="fal fa-bars fa-2x"></i>
</a>
<div id="fdn-site-header-nav-toggle-wide-modal" class="fdn-site-header-nav-wide" uk-drop="mode: click; boundary: #fdn-navigation-dropdown-hook; boundary-align: true; pos: bottom-justify; offset: 100;">
<div class="uk-width-1-1 fdn-site-header-nav-wide-columns uk-modal-dialog">
<div class=" uk-flex uk-flex-wrap fdn-site-header-nav-wide-column-wrap">
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/news" onclick='ga("send", "event", "Nav", "Click", "News")' target="_self" title="">
News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/news" onclick='ga("send", "event", "Nav", "Click", "Latest News")' target="_self" title="">
Latest News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305865" onclick='ga("send", "event", "Nav", "Click", "News Archives")' target="_self" title="">
News Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/coronavirus-10624039" onclick='ga("send", "event", "Nav", "Click", "Coronavirus")' target="_self" title="">
Coronavirus
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/environmental-6386358" onclick='ga("send", "event", "Nav", "Click", "Environmental")' target="_self" title="">
Environmental
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/politics-6386326" onclick='ga("send", "event", "Nav", "Click", "Politics")' target="_self" title="">
Politics
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/restaurants" onclick='ga("send", "event", "Nav", "Click", "Food & Drink")' target="_self" title="">
Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/restaurants" onclick='ga("send", "event", "Nav", "Click", "Latest Food & Drink")' target="_self" title="">
Latest Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305867" onclick='ga("send", "event", "Nav", "Click", "Food & Drink Archives")' target="_self" title="">
Food &amp; Drink Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/food-news-6386468" onclick='ga("send", "event", "Nav", "Click", "Food News")' target="_self" title="">
Food News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/cocktails-and-spirits-6386450" onclick='ga("send", "event", "Nav", "Click", "Cocktails & Spirits")' target="_self" title="">
Cocktails &amp; Spirits
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/openings-and-closings-6386445" onclick='ga("send", "event", "Nav", "Click", "Openings")' target="_self" title="">
Openings
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" onclick='ga("send", "event", "Nav", "Click", "Restaurant Guide")' target="_self" title="">
Restaurant Guide
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/best-miami-restaurants" onclick='ga("send", "event", "Nav", "Click", "Required Eating 2021")' target="_blank" title="">
Required Eating 2021
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/guide/miami-best-bars" onclick='ga("send", "event", "Nav", "Click", "Drink Here 2021")' target="_blank" title="">
Drink Here 2021
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902044" onclick='ga("send", "event", "Nav", "Click", "Food & Drink Newsletter")' target="_self" title="">
Food &amp; Drink Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/arts" onclick='ga("send", "event", "Nav", "Click", "Arts & Culture")' target="_self" title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/arts" onclick='ga("send", "event", "Nav", "Click", "Latest Arts & Culture")' target="_self" title="">
Latest Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305869" onclick='ga("send", "event", "Nav", "Click", "Arts & Culture Archives")' target="_self" title="">
Arts &amp; Culture Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/EventSearch?narrowByDate=today&sortType=date" onclick='ga("send", "event", "Nav", "Click", "Calendar")' target="_self" title="">
Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/art-6386373" onclick='ga("send", "event", "Nav", "Click", "Art")' target="_self" title="">
Art
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/MovieTimes" onclick='ga("send", "event", "Nav", "Click", "Movie Times")' target="_self" title="">
Movie Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902051" onclick='ga("send", "event", "Nav", "Click", "Arts & Culture Newsletter")' target="_self" title="">
Arts &amp; Culture Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/music" onclick='ga("send", "event", "Nav", "Click", "Music")' target="_self" title="">
Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/music" onclick='ga("send", "event", "Nav", "Click", "Latest Music")' target="_self" title="">
Latest Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?section=6305870" onclick='ga("send", "event", "Nav", "Click", "Music Archives")' target="_self" title="">
Music Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/concerts-6386466" onclick='ga("send", "event", "Nav", "Click", "Concerts")' target="_self" title="">
Concerts
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/local-music-10849559" onclick='ga("send", "event", "Nav", "Click", "Local Music")' target="_self" title="">
Local Music
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/miami/EventSearch?eventSection=6423590&feature=Concert&sortType=date&v=g" onclick='ga("send", "event", "Nav", "Click", "Concert Calendar")' target="_self" title="">
Concert Calendar
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902045" onclick='ga("send", "event", "Nav", "Click", "Music Newsletter")' target="_self" title="">
Music Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.browardpalmbeach.com/about" onclick='ga("send", "event", "Nav", "Click", "More")' target="_self" title="">
More
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/things-to-do" onclick='ga("send", "event", "Nav", "Click", "Things to Do\/Tickets")' target="_self" title="">
Things to Do/Tickets
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/best-of" onclick='ga("send", "event", "Nav", "Click", "Best of Miami")' target="_self" title="">
Best of Miami
</a>
</li>
<li class="fdn-nav-item">
<a href="https://herbanplanet.com/" onclick='ga("send", "event", "Nav", "Click", "Cannabis")' target="_blank" title="">
Cannabis
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/browardpalmbeach/SlideshowArchives" onclick='ga("send", "event", "Nav", "Click", "Slideshows")' target="_self" title="">
Slideshows
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/promotions" onclick='ga("send", "event", "Nav", "Click", "Promotions")' target="_self" title="">
Promotions
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/topic/lists-6386369" onclick='ga("send", "event", "Nav", "Click", "Lists")' target="_self" title="">
Lists
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/careers" onclick='ga("send", "event", "Nav", "Click", "New Times Careers")' target="_self" title="">
New Times Careers
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/advertise" onclick='ga("send", "event", "Nav", "Click", "Local Advertising")' target="_self" title="">
Local Advertising
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/about/flipbooks" onclick='ga("send", "event", "Nav", "Click", "Flipbook Archives")' target="_self" title="">
Flipbook Archives
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902047" onclick='ga("send", "event", "Nav", "Click", "Things To Do Newsletter")' target="_self" title="">
Things To Do Newsletter
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902050" onclick='ga("send", "event", "Nav", "Click", "Best Of Newsletter")' target="_self" title="">
Best Of Newsletter
</a>
</li>
</ul>
<ul class="uk-list fdn-nav-list-custom uk-padding-xsmall">
<li class="fdn-nav-item fdn-nav-item-header">
<a href="https://www.voicemediagroup.com/" onclick='ga("send", "event", "Nav", "Click", "Voice Media Group")' target="_self" title="">
Voice Media Group
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.miaminewtimes.com/" onclick='ga("send", "event", "Nav", "Click", "Miami New Times")' target="_blank" title="">
Miami New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.dallasobserver.com/" onclick='ga("send", "event", "Nav", "Click", "Dallas Observer")' target="_blank" title="">
Dallas Observer
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.phoenixnewtimes.com/" onclick='ga("send", "event", "Nav", "Click", "Phoenix New Times")' target="_blank" title="">
Phoenix New Times
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.westword.com/" onclick='ga("send", "event", "Nav", "Click", "Westword")' target="_blank" title="">
Westword
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.couponscaptain.com/" onclick='ga("send", "event", "Nav", "Click", "Coupons Captain")' target="_blank" title="">
Coupons Captain
</a>
</li>
</ul>
</div>
</div>
<div class="fdn-site-header-search-block">
<form action="https://www.browardpalmbeach.com/browardpalmbeach/Search" method="get">
<div class="fdn-site-header-search-wrap">
<input type="text" name="keywords" autocomplete="off" type="search" class="fdn-site-header-search-input" placeholder="Search browardpalmbeach.com">
<button class="fdn-site-header-search-submit" type="submit">
<i class="far fa-search fa-flip-horizontal"></i>
</button>
</div>
</form>
</div>
</div>
</div>
<div class="fdn-site-header-logo">
<div class="GlobalHeader SiteLogoresponsive  uk-root SiteLogo comp-shell-logo" data-component-id="SiteLogo">
<div class="uk-margin-remove">
<a class="uk-logo" href="https://www.browardpalmbeach.com/" title="New Times Broward-Palm Beach">
<img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
</a>
</div>
</div>
</div>
<div class="fdn-site-header-text-block">
<div class="uk-flex uk-flex-wrap uk-flex-middle">
<a class="uk-width-auto fdn-site-header-support-button" href="https://www.browardpalmbeach.com/i-support" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'News-VMG-ISupport-Header',  {'NonInteraction': 1});">
Support Us
</a>
<p class="uk-width-2-3@sm uk-width-1-2 fdn-site-header-slogan uk-margin-remove">
South Florida's independent<br>
source of local news and culture
</p>
</div>
</div>
<div class="uk-flex uk-flex-middle fdn-site-header-login-block">
<p class="uk-margin-remove uk-button">
<i class="fas fa-2x fa-user"></i>
<span class="uk-visible@sm">account</span>
<i class="fas fa-chevron-right"></i>
</p>
<div class="uk-padding-small" uk-dropdown="mode:click">
<ul class="uk-nav uk-nav-default uk-dropdown-nav">
<li class="pelcro-logged-in uk-nav-header">Welcome,<br /><span class="pelcro-user-name">Insider</span></li>
<li class="pelcro-logged-out"><a href="#" class="pelcro-login-button" data-vmgs-psource="Toolbar|News" data-vmgs-section="News">Login</a></li>
<li class="pelcro-logged-in"><a href="/profile">My Newsletters</a></li>
<li class=""><a href="/contribute">Contribute</a></li>
<li class=""><a href="/about/contact">Contact Us</a></li>
<li class="pelcro-logged-in pelcro-logout-button"><a href="">Sign out</a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="ev-grid-zone ev-primary-zone">
<div class="ev-grid-col fdn-grid-main-single fdn-primary" data-ev-zone="MainTop">
<hidden hidden>
<div class="ZoneA ContentDefaultMultiple  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirBillboardTop comp-" data-component-id="AirBillboardTop" inline-content-billboard fdn-ad-component>
<div class="uk-flex uk-flex-row uk-width-1-1 uk-flex uk-flex-center" style="
       border-top: thin solid #ccc;
       margin-top: 15px !important;
       padding-top: 15px;
       border-bottom: thin solid #ccc; 
       margin-bottom: 0px;
       padding-bottom: 15px;">
<div apn-ad-hook="billboardTop" display-targets="desktop|tablet|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</div>
</hidden>
<div class="ZoneA ContentDefaultMultiple  uk-inline uk-margin-remove-top uk-root fdn-margin-vert ContentMultipleRow comp-content-contentmultiplerow" data-component-id="ContentMultipleRow">
<div class="content-multiple-item" fdn-content-multi-item="13719549" fdn-content-multi-item-headline="Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old" fdn-content-multi-item-permalink="/news/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549" fdn-content-multi-item-canonical="https://www.miaminewtimes.com/news/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-14944919" fdn-content-multi-item-title="Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old" fdn-content-multi-item-thumb="https://media1.browardpalmbeach.com/bpb/imager/u/slideshow/13719547/taravella.jpg?cb=1658843026" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="677" fdn-content-multi-item-index="1" ga-dimension2="News" ga-dimension3="13719549" ga-dimension4="2022-07-26 10:00:00" ga-dimension5="Police" ga-dimension6="Alex DeLuca" ga-dimension7="Articles">
<div class="ZoneA StoryHeaderCustomresponsive   uk-root fdn-margin-vert StoryHeaderCustom comp-content-storyheader" data-component-id="StoryHeaderCustom">
<div class="fdn-custom-story-header">
<p class="fdn-custom-story-header-topic uk-margin-remove-top uk-margin-small-bottom">
<a href="https://www.browardpalmbeach.com/topic/police-10849566">
Police
</a>
</p>
<div class="uk-position-relative uk-visible-toggle">
<div class="uk-hidden-hover uk-position-top-right uk-padding-xsmall uk-position-absolute">
</div>
<h1 class="fdn-content-headline uk-margin-remove">
Ex-BSO Deputy Cleared in 2019 Rough Arrest of 15-Year-Old
</h1>
<p class="fdn-content-infoline">
<span class="fdn-custom-story-header-author">
<a href="https://www.browardpalmbeach.com/author/alex-deluca" rel="author">
Alex DeLuca
</a>
</span>
<span class="fdn-custom-story-header-date">
July 26, 2022
</span>
<span class="fdn-custom-story-header-time">
10:00AM
</span>
</p>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand uk-flex uk-flex-column" main-column>
<div class="uk-width-1-1">
<div class="uk-margin-remove-top fdn-magnum-block uk-clearfix magnumTest">
<img uk-img="" data-src="https://media1.browardpalmbeach.com/bpb/imager/u/magnum/13719547/taravella.jpg?cb=1658843026" alt="Videos show Broward deputies slamming 15-year-old Delucca Rolle to the ground near J.P. Taravella High School." width="1320" height="586" class="" />
<div class="fdn-caption-block uk-flex uk-flex-middle uk-flex-row">
<span class="fdn-image-caption">Videos show Broward deputies slamming 15-year-old Delucca Rolle to the ground near J.P. Taravella High School.</span>
<span class="fdn-image-credit"><a href="https://www.instagram.com/p/BwaKAe9A1is/" target="_blank">screenshot via @damn.tapoutt</a></span>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-middle uk-flex-left uk-grid-small fdn-content-multi-row-share-tools-small " uk-grid>
<div fdn-share-button-facebook="">
<a href="https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&app_id=835681050493442" onClick="window.open('https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&app_id=835681050493442','_blank','resizable,height=700,width=600'); return false;" target="_blank" uk-tooltip="title: Share on Facebook" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:facebook; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="facebook"><path d="M11,10h2.6l0.4-3H11V5.3c0-0.9,0.2-1.5,1.5-1.5H14V1.1c-0.3,0-1-0.1-2.1-0.1C9.6,1,8,2.4,8,5v2H5.5v3H8v8h3V10z"></path></svg></span>
</a>
</div>
<script> dnLoadScript("https://platform.twitter.com/widgets.js", true); </script>
<div class="" fdn-share-button-twitter="">
<a href="https://twitter.com/intent/tweet?url=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&text=Ex-BSO%20Deputy%20Cleared%20in%202019%20Rough%20Arrest%20of%2015-Year-Old" onClick="window.open('https://twitter.com/intent/tweet?url=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&redirect_uri=https:%2F%2Fwww.browardpalmbeach.com%2Fnews%2Fjury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549&text=Ex-BSO%20Deputy%20Cleared%20in%202019%20Rough%20Arrest%20of%2015-Year-Old','_blank','resizable,height=700,width=600'); return false;" uk-tooltip="title: Share on Twitter" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller uk-icon" uk-icon="icon:twitter; ratio: .77"><svg width="15.4" height="15.4" viewBox="0 0 20 20" xmlns="http://www.w3.org/2000/svg" data-svg="twitter"><path d="M19,4.74 C18.339,5.029 17.626,5.229 16.881,5.32 C17.644,4.86 18.227,4.139 18.503,3.28 C17.79,3.7 17.001,4.009 16.159,4.17 C15.485,3.45 14.526,3 13.464,3 C11.423,3 9.771,4.66 9.771,6.7 C9.771,6.99 9.804,7.269 9.868,7.539 C6.795,7.38 4.076,5.919 2.254,3.679 C1.936,4.219 1.754,4.86 1.754,5.539 C1.754,6.82 2.405,7.95 3.397,8.61 C2.79,8.589 2.22,8.429 1.723,8.149 L1.723,8.189 C1.723,9.978 2.997,11.478 4.686,11.82 C4.376,11.899 4.049,11.939 3.713,11.939 C3.475,11.939 3.245,11.919 3.018,11.88 C3.49,13.349 4.852,14.419 6.469,14.449 C5.205,15.429 3.612,16.019 1.882,16.019 C1.583,16.019 1.29,16.009 1,15.969 C2.635,17.019 4.576,17.629 6.662,17.629 C13.454,17.629 17.17,12 17.17,7.129 C17.17,6.969 17.166,6.809 17.157,6.649 C17.879,6.129 18.504,5.478 19,4.74"></path></svg></span>
</a>
</div>
<div class="" fdn-share-button-email="">
<a href="/cdn-cgi/l/email-protection#655a1610070f000611582b0012405755310c08001640575527170a120417014835040908405755270004060d405624405755201d4827362a40575521001510111c405755260900041700014057550c0b4057555755545c405755370a10020d4057552417170016114057550a034057555450483c000417482a090143070a011c58405524405524201d4827362a40575521001510111c405755260900041700014057550c0b4057555755545c405755370a10020d4057552417170016114057550a034057555450483c000417482a09014055244055240d111115165f4a4a1212124b07170a1204170115040908070004060d4b060a084a0b0012164a0f10171c48001d0a0b00170411001648001d4807160a4801001510111c48120d0a480704111100170001481100000b480100091006060448170a090900480c0b485755545c48545652545c50515c405524405524405524" onclick="mailto:?subject=New%20Times%20Broward-Palm%20Beach%3A%20Ex-BSO%20Deputy%20Cleared%20in%202019%20Rough%20Arrest%20of%2015-Year-Old&body=%0A%0AEx-BSO%20Deputy%20Cleared%20in%202019%20Rough%20Arrest%20of%2015-Year-Old%0A%0Ahttps://www.browardpalmbeach.com/news/jury-exonerates-ex-bso-deputy-who-battered-teen-delucca-rolle-in-2019-13719549%0A%0A%0A" uk-tooltip="title: Share via Email" aria-expanded="false" rel="nofollow">
<i class="fal fa-envelope fa-lg"></i>
</a>
</div>
<div class="" fdn-share-button-print>
<a href="https://www.browardpalmbeach.com/browardpalmbeach/Print?oid=13719549" target="_blank" uk-tooltip="title:Print" title="" aria-expanded="false">
<i class="fal fa-print fa-lg"></i>
</a>
</div>
<div class="" fdn-share-button-text-size>
<a class="fdn-text-size-toggle" href="#size" uk-tooltip="title:Change Font Size" aria-expanded="false" uk-toggle="target: .fdn-content-body;cls: fdn-content-body-large;">
<i class="fas fa-text-size fa-lg"></i>
</a>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand fdn-content-multi-row show-first-image">
<pre debug hidden>[
          {
            "name": "Related Stories / Support Us Combo",
            "component": "11171270",
            "insertPoint": "4",
            "requiredCountToDisplay": "6"
          },{
            "name": "Air - Leaderboard - Inline Content",
            "component": "13002605",
            "insertPoint": "2/3",
            "requiredCountToDisplay": "7"
          },{
            "name": "R1 - Beta - Mobile Only",
            "component": "12306405",
            "insertPoint": "8",
            "requiredCountToDisplay": "8"
          },{
            "name": "Air - MediumRectangle - Inline Content - Mobile Display Size 2",
            "component": "11034510",
            "insertPoint": "12",
            "requiredCountToDisplay": "12"
          },{
            "name": "Air - MediumRectangle - Inline Content - Mobile Display Size 2",
            "component": "11034510",
            "insertPoint": "4th",
            "startingPoint": "16",
            "requiredCountToDisplay": "12"
          }
          
        ]</pre>
<div class="ZoneA StoryLayoutresponsive   uk-root fdn-margin-vert StoryLayout comp-content-storylayout" data-component-id="StoryLayout">
<div class="fdn-content-body">
On April 18, 2019, Broward Sheriff's Office (BSO) deputies Christopher Krickovich and Greg LaCerra were&nbsp;captured on video pepper spraying 15-year-old&nbsp;Delucca Rolle and then&nbsp;smashing his face into the pavement outside a McDonald's in Tamarac. <br>
<br>
The rough arrest began when Rolle&nbsp;tried to pick up a cell phone dropped by a fellow student whom police were arresting for fighting.&nbsp;Rolle, whose nose was broken in the incident, was initially charged with trespassing, resisting arrest, and assault of a police officer. But after footage of the encounter went viral, <a href="https://www.browardpalmbeach.com/news/broward-deputies-charged-with-battery-falsifying-records-in-delucca-rolle-case-10297876" target="_blank">the Broward State Attorney's Office&nbsp;dropped all charges&nbsp;against the then-J.P. Taravella High School student</a> and charged the officers instead: Krickovich with&nbsp;two counts of battery, and&nbsp;LaCerra&nbsp;with one battery charge. (The charge against the latter was dismissed last month.)<br>
<br>
Images of the deputies slamming the Black teen to the ground sparked national outrage, leading to an outcry from local&nbsp;NAACP&nbsp;leaders and&nbsp;civil rights attorney Ben Crump. <br>
<br>
Nearly three years after the violent takedown, a <a href="https://www.local10.com/news/local/2022/07/25/ex-bso-deputy-found-not-guilty-in-teens-rough-arrest-in-tamarac/" target="_blank">Broward jury has cleared Krickovich&nbsp;on both charges</a>.<br>
<br>
“The law in the state of Florida is that Chris Krickovich’s actions that day were 100 percent legal [and] 100 percent justifiable,” Krickovich's attorney, Jeremy Kroll, <a href="https://wsvn.com/news/local/closing-arguments-in-former-bso-deputy-christopher-krickovichs-trial-leaves-jury-with-final-decision/" target="_blank">said during closing arguments</a> on Monday. <br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">NOT GUILTY: Former <a href="https://twitter.com/browardsheriff?ref_src=twsrc%5Etfw">@browardsheriff</a> deputy Christopher Krickovich was acquitted by a jury today. He was on trial for misdemeanor battery after the rough arrest of Delucca Rolle back in 2019. <a href="https://twitter.com/TJParkeron7?ref_src=twsrc%5Etfw">@TJParkeron7</a></p>&mdash; Frank Guzman (@fguzmanon7) <a href="https://twitter.com/fguzmanon7/status/1551634648962408449?ref_src=twsrc%5Etfw">July 25, 2022</a></blockquote> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>Crump, who is representing Rolle, did not immediately respond to <i>New Times</i>' request for comment. <br>
<br>
The verdict came in on day four of the trial, which began on July 20. A&nbsp;six-member jury unanimously found&nbsp;Krickovich not guilty of slamming Rolle's head into the pavement and punching him in the head.&nbsp;If convicted, Krickovich could have faced up to one year in the county jail and a $1,000 fine.<br>
<br>
The jury viewed body camera footage and heard witness accounts from BSO officials, former J.P. Taravella students, and expert testimony, including a sheriff's training sergeant who testified that Krickovich “performed perfectly” in light of the circumstances.&nbsp;Kroll also told jurors that the site of the arrest was a “literal war zone” of “mayhem”&nbsp;and that Krickovich&nbsp;responded appropriately to defend himself in a&nbsp;“mob situation.”<br>
<br>
The state contended that Krickovich acted illegally during the arrest and that the defense was trying to “oversell” jurors on the idea that the location was a war zone.<br>
<br>
“This isn’t the Ukraine.... It’s a shopping plaza in Tamarac,”&nbsp;prosecutors said. <br>
<br>
As <i>New Times</i>&nbsp;previously reported,&nbsp;Krickovich, LaCerra, and a third officer, Deputy Ralph Mackey, also faced charges of falsifying records and conspiracy to falsify records after allegedly fabricating details in the police report about what happened during Rolle's arrest. <br>
<br>
The BSO fired&nbsp;Krickovich in December 2019. The sheriff's office confirmed that as of July 25, LaCerra and Mackey remain on the force.&nbsp;
</div>
<script>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</script>
<script>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</script>
<script>
        jQuery(function () {
          Foundation.Content['13719549'].setupInlineComponents();
        });
        </script>
</div>
</div>
</div>
<div class="uk-width-1-1">
<div class="ZoneA KeepFreeresponsive   uk-root fdn-margin-vert KeepFree comp-content-keepfree" data-component-id="KeepFree">
<div class="uk-position-relative uk-overflow-hidden">
<div class="fdn-keep-free-blue-bar-top" uk-scrollspy="cls: fdn-animation-blue-bar-top; delay: 300;"></div>
<div class="fdn-keep-free-blue-bar-left" uk-scrollspy="cls:fdn-animation-blue-bar-left; delay:1500"></div>
<div class="fdn-keep-free-body">
<strong>KEEP NEW TIMES BROWARD-PALM BEACH FREE...</strong>
Since we started <i>New Times Broward-Palm Beach</i>, it has been defined as the free, independent voice of South Florida, and we'd like to keep it that way. With local media under siege, it's more important than ever for us to rally support behind funding our local journalism. You can help by participating in our "I Support" program, allowing us to keep offering readers access to our incisive coverage of local news, food and culture with no paywalls.
</div>
<div class="uk-position-relative fdn-keep-free-link">
<a href="https://www.browardpalmbeach.com/i-support" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'News-VMG-ISupport-AfterArticle',  {'NonInteraction': 1});">
Make a one-time donation today for as little as $1.
</a>
<div class="fdn-keep-free-text-mask" uk-scrollspy="cls:fdn-animation-text-mask"></div>
</div>
</div>
</div>
<div yieldmo-embed id="Yieldmo-ym_927398799965101214-13719549"></div>
<script>
setTimeout(() => {
  if (Foundation.Pelcro.subscription === "Member") {
    jQuery('div[yieldmo-embed], div[yieldmo-embed-embedded]').remove();
  }
  else {

    window.Foundation = window.Foundation || (window.Foundation = {});
    Foundation.Yieldmo = (typeof(Foundation.Yieldmo) === 'undefined') ? {} : Foundation.Yieldmo;
    Foundation.Yieldmo.unique_id = (typeof(Foundation.Yieldmo.unique_id) === 'undefined') ? Date.now() : Foundation.Yieldmo.unique_id;
    jQuery('#Yieldmo-ym_927398799965101214-13719549').html(`
      <div id="ym_927398799965101214" class="ym ym_scroll" data-id="13719549-${Foundation.Yieldmo.unique_id}"></div>
    `);

    setTimeout(() => {
      (function(e,t){if(t._ym===void 0){t._ym="";var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)}else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);

    }, 300);
  }
}, 1000);
</script>
<div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-content-footer-row">
<div class="uk-first-column text-links-hook">
<div class="ZoneA SailthruRecommendationsresponsive  uk-width-medium@s uk-margin-remove SailthruRecommendations-13719549 uk-root fdn-margin-vert SailthruRecommendations comp-content-sailthrurecommendations" data-component-id="SailthruRecommendations">
<h3 class="uk-margin-remove uk-heading-line uk-text-uppercase">
<span>
Trending News
</span>
</h3>
<ul class="uk-list fdn-list-bullet" sailthru-hook>
<li><a href="https://www.browardpalmbeach.com/news/scottie-pippen-adds-five-year-old-girl-to-broward-lawsuit-10278933" data-objid="10278933" title="Scottie Pippen Adds Comedian Lindsay Glazer&#39;s 5-Year-Old Daughter to Pending Lawsuit">Scottie Pippen Adds Comedian Lindsay Glazer's 5-Year-Old Daughter to Pending Lawsuit</a></li>
<li><a href="https://www.browardpalmbeach.com/news/dalia-dippolito-may-have-tried-to-kill-him-but-michael-dippolito-is-no-saint-6343534" data-objid="6343534" title="Dalia Dippolito May Have Tried to Kill Him, But Michael Dippolito Is No Saint">Dalia Dippolito May Have Tried to Kill Him, But Michael Dippolito Is No Saint</a></li>
<li><a href="https://www.browardpalmbeach.com/news/judge-who-signed-deadly-swat-warrant-once-married-to-admitted-drug-dealer-6973500" data-objid="6973500" title="Judge Who Signed Deadly SWAT Warrant Once Married to Admitted Drug Dealer">Judge Who Signed Deadly SWAT Warrant Once Married to Admitted Drug Dealer</a></li>
</ul>
<hidden hidden>
<ul class="uk-list fdn-list-bullet">
<li>
<div class="ZoneA AirNativeArticleresponsive   uk-root fdn-margin-vert AirNativeArticle comp-" data-component-id="AirNativeArticle">
<div apn-ad-hook="nativeArticle" display-targets="desktop|tablet|mobile">
<div class="xandr-text-only">

<div class="xandr-txt-wrapper">

<span class="xandr-sponsored-by">Sponsored Content From: [%sponsoredBy%]</span>

<h1 class="xandr-title">[%title%]</h1>
</div>
</div>
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</li>
</ul>
</hidden>
<script>
      jQuery(document).ready(function($) {

        Sailthru.personalize({
          "sections": [
        
          {
            "id":  "f247a52c-6ae2-11e6-9abe-002590d1a41a",
            "selector": ".SailthruRecommendations-13719549 > ul[sailthru-hook]",
            "onSuccess":  function(response) {
              Foundation.SailthruSPM.Personalize({
                "selector": ".SailthruRecommendations-13719549 > ul[sailthru-hook]", 
                "data": response,
                
                  "count": 3,
                
                "template": (article) => `<li><a href="${article.url}" data-objid="${article.vars.objid}" title="${article.title}">${article.title}</a></li>`
              });
            }
          }
        
      ],
          "vars": {
            "placed": "13719549"  
          }
        });
      });
    </script>
</div>
</div>
<div class="uk-width-expand@s fdn-content-placeholder avantis-hook">
<div class="ZoneA RevContentR1responsive   uk-root fdn-margin-vert RevContentR1 comp-" data-component-id="RevContentR1" rev-r1-embed-wrapper>
<script>
  (() => {
    const embedWrapper = jQuery(jQuery('[rev-r1-embed-wrapper]').get(0));
    const displaySizeNotMobile = window.innerWidth >= Foundation.ApnAds.tabletWidth;
    const isIos = window.navigator.userAgent.match(/iphone|iPad/i) !== null;

    embedWrapper.removeAttr('rev-r1-embed-wrapper')

    if (displaySizeNotMobile || isIos) {
      let embedDiv = jQuery(`<div id="rc-widget-b3a2af" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="268929"></div>`)
      let embedScript = jQuery(`<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"><`+`/script>`)
      embedWrapper.append(embedDiv);
      embedWrapper.append(embedScript);
    }
    else {
      let embedR1 = jQuery(`<!-- myItemIndex: 1 -->

















  
  

  
  

    

    
    

    

    

    <script r1-script-hook-mobile>
      if (window.innerWidth < 998) {
        (function () {
          var realOneHookElement = document.querySelector('[r1-script-hook-mobile]');
          var realOneScriptElement = document.createElement('script');
          realOneScriptElement.defer = true;
          realOneScriptElement.src = 'https://www.voqally.com/hub/app/r.js?key=c6ef7031ed64f8991f3be28247bfcfac';
          document.querySelector('[r1-script-hook-mobile]').after(realOneScriptElement);
          realOneHookElement.remove();
        })();
      } else {
          let realOneHookElement = document.querySelector('[r1-script-hook-mobile]');
          if (realOneHookElement !== null) {
            let prevNode = null;
            let prevPrevNode = null;
            let currentNode = realOneHookElement;

            const doubleBrAfter = document.querySelector('[r1-script-hook-mobile]+br+br');
            if (doubleBrAfter) {
              doubleBrAfter.remove();
              document.querySelector('[r1-script-hook-mobile]+br').remove();
            }

            realOneHookElement.remove();
          }
      }
    <`+`/script>
  

`)
      embedWrapper.append(embedR1);
    }
  })();
  </script>
</div>
</div>
</div>
<div class="ZoneA NewsletterSignup657responsive   uk-root fdn-margin-vert NewsletterSignup657 comp-newsletter-newslettersignup" data-component-id="NewsletterSignup657">
<div class="uk-flex uk-flex-wrap uk-width-1-1 fdn-newsletter-signup-medium">
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-main">
<div class="fdn-newsletter-signup-logo">
<img src="/images/air/newsletter-icon-bpb.png" alt="">
</div>
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-text-block">
<div class="fdn-newsletter-signup-text">
<div class="fdn-newsletter-signup-text-large-only">
Don't Miss Out
</div>
<strong>SIGN UP</strong> for the latest
news, free stuff and more!
</div>
<div class="fdn-newsletter-signup-button-block">
<div class="pelcro-logged-out">
<a href="#newsletterSignUp" class="pelcro-subscribe-button fdn-newsletter-signup-button" data-product-id="553" data-vmgs-psource="In-Article Sign Up|News" data-vmgs-section="News" onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-News', {'NonInteraction': 1});">
Join Today <i class="fas fa-caret-right"></i>
</a>
</div>
<div class="pelcro-logged-in">
<a href="/profile" class="fdn-newsletter-signup-button" onCLick="ga('send', 'event', 'VMG-Widget', 'Click', 'In-Article Sign Up-News', {'NonInteraction': 1});">
Sign Up
</a>
</div>
</div>
</div>
</div>
<div class="uk-flex uk-flex-wrap fdn-newsletter-signup-secondary">
<div class="fdn-newsletter-signup-secondary-text">
Become a member to support the independent voice of South Florida
and help keep the future of New Times <strong>FREE</strong>
</div>
<div class="fdn-newsletter-signup-secondary-link-block uk-flex uk-flex-wrap uk-flex-middle uk-width-1-1">
<a href="/i-support" class="fdn-newsletter-signup-secondary-link">I Support
<img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
</a>
<a href="/i-support" class="fdn-newsletter-signup-secondary-link-learn-more">Learn More</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="uk-width-auto uk-visible@sm uk-margin-left" style="width: 300px;" distribute-right-column-items>
<div class="beforeBillboard uk-flex uk-flex-column">
<div class="stickCeption1" style="z-index: 1;">
<hidden hidden>
<div class="ZoneA AirRectangleTopRightColumnresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirRectangleTopRightColumn comp-" data-component-id="AirRectangleTopRightColumn" fdn-ad-component>
<div apn-ad-hook="tower" display-targets="desktop">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
</div>
<div class="stickCeption2 uk-margin-remove" style="z-index: 10;" uk-sticky="
           offset: 100;
           bottom: true;">
<script r1-script-hook-desktop>
      if (window.innerWidth >= 998) {
        (function () {
          var realOneHookElement = document.querySelector('[r1-script-hook-desktop]');
          var realOneScriptElement = document.createElement('script');
          realOneScriptElement.defer = true;
          realOneScriptElement.src = 'https://www.voqally.com/hub/app/r.js?key=c6ef7031ed64f8991f3be28247bfcfac';
          document.querySelector('[r1-script-hook-desktop]').after(realOneScriptElement);
          realOneHookElement.remove();
        })();
      } else {
          let realOneHookElement = document.querySelector('[r1-script-hook-mobile]');
          if (realOneHookElement !== null) {
            let prevNode = null;
            let prevPrevNode = null;
            let currentNode = realOneHookElement;

            const doubleBrAfter = document.querySelector('[r1-script-hook-mobile]+br+br');
            if (doubleBrAfter) {
              doubleBrAfter.remove();
              document.querySelector('[r1-script-hook-mobile]+br').remove();
            }

            realOneHookElement.remove();
          }
      }
    </script>
<hidden hidden>
<div class="ZoneA AirMediumRectangleRightColAFterR1responsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleRightColAFterR1 comp-" data-component-id="AirMediumRectangleRightColAFterR1" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="desktop">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
</div>
</div>
<div class="billboardSpacer" style="pointerEvents: none;"></div>
<div class="afterBillboard uk-flex uk-flex-column">
<div class="stickCeption" style="z-index: 1;" uk-sticky="
           offset: 100;
           bottom: true;">
<div class="ZoneA LatestInCategoryresponsive  fdn-component-related-items uk-root fdn-margin-vert LatestInCategory comp-content-latestincategory" data-component-id="LatestInCategory">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Latest Stories
</h3>
</div>
<ul class="pres-ContentListSquareBrief uk-list uk-list-divider">
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.browardpalmbeach.com/news/catalytic-converter-theft-is-on-the-rise-but-florida-lawmakers-have-no-plans-to-combat-it-13697092">
<p class="fdn-teaser-headline">
Someone Please Tell Tallahassee About Catalytic Converter Theft
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex DeLuca
</p>
<time>
Jul 21, 2022
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.browardpalmbeach.com/news/catalytic-converter-theft-is-on-the-rise-but-florida-lawmakers-have-no-plans-to-combat-it-13697092">
<img uk-img="" data-src="https://media2.browardpalmbeach.com/bpb/imager/u/r-bigsquare/13697090/catalyticconvertercourtesy.jpg?cb=1658436618" alt="Catalytic Converter Theft Is on the Rise &mdash; And the Legislature Doesn&#39;t Seem to Care" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.browardpalmbeach.com/news/floating-abortion-clinic-could-soon-come-to-gulf-of-mexico-13697096">
<p class="fdn-teaser-headline">
Floating Abortion Clinic Proposed in Gulf of Mexico
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex DeLuca
</p>
<time>
Jul 21, 2022
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.browardpalmbeach.com/news/floating-abortion-clinic-could-soon-come-to-gulf-of-mexico-13697096">
<img uk-img="" data-src="https://media1.browardpalmbeach.com/bpb/imager/u/r-bigsquare/13697095/miami_roe_v_wade_protest_062422_gettyimages-1404946782_joe_raedle.jpg?cb=1658436632" alt="All Abort! Floating Abortion Clinic May Serve Florida Via Gulf of Mexico" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.browardpalmbeach.com/news/where-in-miami-to-get-your-toddler-vaccinated-for-covid-19-13597091">
<p class="fdn-teaser-headline">
Here's Where to COVID-Proof Your Kid!
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex DeLuca
</p>
<time>
Jul 21, 2022
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.browardpalmbeach.com/news/where-in-miami-to-get-your-toddler-vaccinated-for-covid-19-13597091">
<img uk-img="" data-src="https://media2.browardpalmbeach.com/bpb/imager/u/r-bigsquare/13597090/toddlergettingvaxxed.jpg?cb=1656632511" alt="Where to Get Your Toddler Vaccinated in South Florida" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
</ul>
<div class="uk-margin-small uk-clearfix uk-text-right ">
<a class="uk-align-right uk-margin-remove fdn-more-link uk-flex-inline uk-flex-middle" href="https://www.browardpalmbeach.com/browardpalmbeach/ArticleArchives?category=6386283">
More &raquo;
</a>
</div>
</div>
<div class="ZoneA AirAvantisRightColBelowBillboardresponsive  uk-margin-remove-top uk-margin-medium-bottom uk-root fdn-margin-vert AirAvantisRightColBelowBillboard comp-shell-avantis" data-component-id="AirAvantisRightColBelowBillboard">
<div id="avantis-test-1" class="avantis"></div>
</div>
<hidden hidden>
<div class="ZoneA AirMediumRectangleRightColBelowBillboardresponsive  uk-margin-remove fdn-labeled uk-root fdn-margin-vert AirMediumRectangleRightColBelowBillboard comp-" data-component-id="AirMediumRectangleRightColBelowBillboard" fdn-ad-component>
<div apn-ad-hook="rectangle" display-targets="desktop">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
</div>
</div>
</div>
</div>
</div>
<div class="ZoneA AirSellWildBetweenContentresponsive Leaderboard   uk-root fdn-margin-vert AirSellWildBetweenContent comp-" data-component-id="AirSellWildBetweenContent">
<sellwild></sellwild>
</div>
<div class="content-multiple-item" fdn-content-multi-item="13719544" fdn-content-multi-item-headline="Lawn Weekend: Mow the Grass at This Luxury Miami Home, Stay for Free" fdn-content-multi-item-permalink="/news/mow-the-grass-at-this-luxury-miami-home-stay-for-free-13719544" fdn-content-multi-item-canonical="https://www.miaminewtimes.com/news/mow-the-grass-at-this-luxury-miami-home-stay-for-free-14945688" fdn-content-multi-item-title="Lawn Weekend: Mow the Grass at This Luxury Miami Home, Stay for Free" fdn-content-multi-item-thumb="https://media2.browardpalmbeach.com/bpb/imager/u/slideshow/13719542/toro.png?cb=1658843163" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="983" fdn-content-multi-item-index="2" ga-dimension2="News" ga-dimension3="13719544" ga-dimension4="2022-07-26 09:47:00" ga-dimension5="Things To Do" ga-dimension6="Nicole Danna" ga-dimension7="Articles" fdn-content-multi-item-loader="fetch">
</div>
<hidden hidden>
<div class="ZoneA AirBillboardBetweenContentresponsive Leaderboard  uk-width-1-1 fdn-labeled uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirBillboardBetweenContent comp-" data-component-id="AirBillboardBetweenContent" fdn-ad-component>
<div apn-ad-hook="billboardBetweenContent" display-targets="desktop|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<div class="content-multiple-item" fdn-content-multi-item="13697103" fdn-content-multi-item-headline="Things to Know Before Attending Miami Dolphins Training Camp" fdn-content-multi-item-permalink="/news/miami-dolphins-training-camp-2022-know-before-you-go-13697103" fdn-content-multi-item-canonical="https://www.miaminewtimes.com/news/miami-dolphins-training-camp-2022-know-before-you-go-14874676" fdn-content-multi-item-title="Things to Know Before Attending Miami Dolphins Training Camp" fdn-content-multi-item-thumb="https://media2.browardpalmbeach.com/bpb/imager/u/slideshow/13697099/tua_tagovailoa_salvon_ahmed_gettyimages-1331513500_mark_brown_2021.jpg?cb=1658436654" fdn-content-multi-item-thumb-width="1524" fdn-content-multi-item-thumb-height="1071" fdn-content-multi-item-index="3" ga-dimension2="News" ga-dimension3="13697103" ga-dimension4="2022-07-21 17:11:00" ga-dimension5="Sports" ga-dimension6="Ryan Yousefi" ga-dimension7="Articles" fdn-content-multi-item-loader="fetch">
</div>
<hidden hidden>
<div class="ZoneA AirBillboardBetweenContentresponsive Leaderboard  uk-width-1-1 fdn-labeled uk-flex uk-flex-row uk-flex-around uk-root fdn-margin-vert AirBillboardBetweenContent comp-" data-component-id="AirBillboardBetweenContent" fdn-ad-component>
<div apn-ad-hook="billboardBetweenContent" display-targets="desktop|mobile">
<script>
      if (typeof apntag === 'object') {
        apntag.anq.push(function() {
          if (typeof Foundation.ApnAds.fillAds === 'function') {
            Foundation.ApnAds.fillAds()
          }
        })
      }
      </script>
</div>
</div>
</hidden>
<script>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</script>
</div>
</div>
</div>
<div class="ev-grid-zone ev-column-zone uk-flex uk-flex-wrap uk-child-width-1-2@m">
<div class="ev-grid-col" data-ev-zone="ZoneB">
</div>
<div class="ev-grid-col" data-ev-zone="ZoneC">
</div>
</div>
<div class="ev-grid-zone ev-secondary-zone" data-ev-zone="ZoneD">
<div class="ev-grid-col uk-width-1-1">
</div>
</div>
<div class="ev-grid-zone ev-footer-zone" data-ev-zone="GlobalFooter">
<div class="ev-grid-col uk-width-1-1">
<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert NewsletterModal comp-newsletter-newslettermodal" data-component-id="NewsletterModal">
<div id="NewsletterModal" class="uk-flex-top" uk-modal>
<div class="uk-modal-dialog uk-modal-body uk-padding-remove">
<div class="uk-flex uk-flex-right">
<button class="uk-modal-close-default uk-position-top-right" type="button" uk-close onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'CloseX', {'nonInteraction': 1});"></button>
</div>
<div class="uk-flex fdn-newsletter-modal-wrap">
<div class="fdn-newsletter-modal-left uk-flex uk-flex-middle">
<p class="uk-margin-auto">Join the New Times community and help support independent
local Journalism in South Florida.</p>
</div>
<div class="fdn-newsletter-modal-right uk-flex-1 uk-flex uk-flex-column uk-flex-wrap uk-padding-small">
<div class="fdn-newsletter-modal-logo uk-flex uk-flex-bottom uk-margin-medium-top uk-margin-medium uk-margin-small">
<img src="/images/bpb-main-logo.png" alt="New Times Broward-Palm Beach">
<span>Insiders</span>
</div>
<div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
<p class="uk-margin-xsmall">
Get the latest updates in news, food, music and culture, and receive special offers direct to your inbox.
</p>
<div class="uk-flex uk-flex-wrap fdn-newsletter-modal-sign-up-block">
<a href="#newsletterSignUp" class="pelcro-subscribe-button fdn-newsletter-modal-sign-up-link" data-product-id="553" data-vmgs-psource="Pop Up|News" data-vmgs-section="News" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'News', {'NonInteraction': 1});">
Sign Up Now <i class="far fa-sm fa-chevron-right"></i>
</a>
<a href="#noThanks" class="fdn-newsletter-modal-no-thanks-link uk-modal-close" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'NoThanks', {'nonInteraction': 1});">
No Thanks
</a>
</div>
</div>
<div class="fdn-newsletter-modal-text-block uk-margin-xsmall">
<p class="uk-margin-xsmall">
Become a member and go ad-free!
</p>
<div class="uk-flex uk-width-1-1">
<a href="/i-support" class="fdn-newsletter-modal-support-link" onClick="ga('send', 'event', 'SubscribeModal', 'Click', 'Pelcro-Support', {'NonInteraction': 1});">
Support Our Journalism <i class="far fa-sm fa-chevron-right"></i>
</a>
</div>
</div>
<div class="fdn-newsletter-modal-footer uk-text-right uk-margin-auto-top">
<a href="/about/privacy-policy" target="_blank">Privacy Policy</a>
</div>
</div>
</div>
</div>
</div>
<script>
  if (window.innerWidth < Foundation.ApnAds.tabletWidth) {
    const psourceAttr = `data-vmgs-psource`;
    const psource = jQuery(`[${psourceAttr}]`);
    psource.attr(psourceAttr, `${psource.attr(psourceAttr)}-Mobile`);
  }

  jQuery(document).on('PelcroSiteLoaded', function (e) {
    var modalElement = jQuery('#NewsletterModal')

    var modalCookieKey = 'fdn_nlmc'
    var modalCookieValue = null
    var modalCookieValueDisplayed = 'displayed'
    var modalCookieValueClosed = 'CloseX'
    var modalCookieValueNoThanks = 'NoThanks'

    var closeForDays = 15
    var closeForDaysInSeconds = 60 * 60 * 24 * closeForDays
    var closeForDaysMaxAge = 'max-age=' + closeForDaysInSeconds

    var dateNow = new Date()
    var dateInTwoCenturies = new Date(dateNow.setFullYear(dateNow.getFullYear() + 200))
    var dateExpiresLongTime = 'expires=' + dateInTwoCenturies

    var cookieList = document.cookie.split('; ')
    var modalCookie = cookieList.find(item => item.startsWith(modalCookieKey))

    if (modalCookie) {
      modalCookieValue = modalCookie.split('=')[1]
    }

    var alreadyShown = new RegExp(`^${modalCookieValueDisplayed}|${modalCookieValueClosed}|${modalCookieValueNoThanks}$`)

    var domainValue = 'domain=' + ('.' + window.location.host.match(/[\w\d_]*\.[\w\d_]*$/)[0] || window.location.host);

    var modalTimeout = setTimeout(function () {
      if (window.Foundation && Foundation.Pelcro && Foundation.Pelcro.init) {
        // Make sure pelcro is ready so signup links work
        if (typeof(Pelcro) === "object") {
          if (modalCookieValue && modalCookieValue?.match(alreadyShown)) {
            // console.log('Newsletter signup modal already displayed.')
            return
          }
          else {
            UIkit.modal(modalElement).show();
            document.cookie = `${modalCookieKey}=${modalCookieValueDisplayed}; ${domainValue}`
          }
        }
      }
    }, 10000)

    modalElement.on('click', '[uk-close]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueClosed}; ${closeForDaysMaxAge}; ${domainValue}`
    })

    modalElement.on('click', '[href="#noThanks"]', function () {
      document.cookie = `${modalCookieKey}=${modalCookieValueNoThanks}; ${dateExpiresLongTime}; ${domainValue}`
    })

    // modalElement.on('click', '[href=#newsletterSignUp]', function () {
    //   UIkit.modal(modalElement).hide()
    // })
  })
  </script>
</div>
<div class="GlobalFooter ContentDefaultMultiple   uk-root fdn-margin-vert CookieConsent comp-shell-cookieconsent" data-component-id="CookieConsent">
<link rel="stylesheet" type="text/css" href="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.css" />
<script src="https://cdn.jsdelivr.net/npm/cookieconsent@3/build/cookieconsent.min.js" data-cfasync="false"></script>
<script>
  jQuery(() => {
    window.cookieconsent.initialise({
      "palette": {
        "popup": {
          "background": "#000"
        },
        "button": {
          "background": "#f1d600"
        }
      },
      "content": {
        
          "message": "We use cookies to collect and analyze information \n  on site performance and usage, and to enhance and \n  customize content and advertisements. \n  By clicking 'Got it' or continuing to use the site, \n  you agree to allow cookies to be placed. \n  To find out more, visit our \n  <a href=\"\/about\/cookies\">cookies policy<\/a> and our \n  <a href=\"\/about\/privacy-policy\">privacy policy<\/a>.",
        
        

        
          "link": "",
          "href": ""
        
      }
    });
  });
  </script>
</div>
<div class="GlobalFooter ContentDefaultMultiple  uk-margin-remove uk-root fdn-margin-vert SiteFooterCustom comp-shell-sitefooter" data-component-id="SiteFooterCustom">
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-wide uk-visible@s">
<div class="uk-flex uk-child-width-1-5 fdn-custom-footer-navigation-link-block-wide-columns">
<div class="fdn-custom-footer-navigation-link-block-column fdn-custom-footer-navigation-link-block-issue-block">
<a href="" class="uk-display-block" onclick="ga('send', 'event', 'VMG-Widget', 'Click', 'News-VMG-Flipbook-Cover',  {'NonInteraction': 1});" title="Finally Seen">
<img uk-img="" data-src="/imager/b/r-cover/13716179/3921/01COVER.jpeg" alt="Finally Seen" width="440" height="496" class="" />
<h4 class="uk-margin-small-top uk-margin-remove-bottom">
This Week's Issue
</h4>
</a>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/" title="" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Editorial')">
Editorial
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Homepage')" title="">
Homepage
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/news" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'News')" title="">
News
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/restaurants" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Food & Drink')" title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/arts" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Arts & Culture')" title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/music" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Music')" title="">
Music
</a>
</li>
<li>
<a href="https://herbanplanet.com/" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Cannabis')" title="">
Cannabis
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-of" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Best of Miami')" title="">
Best of Miami
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-miami-restaurants" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Required Eating 2021')" title="">
Required Eating 2021
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/miami-best-bars" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Best Bars 2020')" title="">
Best Bars 2020
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Restaurant Guide')" title="">
Restaurant Guide
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/promotions" title="" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Marketing')">
Marketing
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/promotions" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Promotions')" title="">
Promotions
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/coupons" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Coupons')" title="">
Coupons
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902046" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Promotions Newsletter')" title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/flipbooks" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Flipbooks')" title="">
Flipbooks
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="https://www.browardpalmbeach.com/about" title="" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'More')">
More
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'About Us')" title="">
About Us
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/staff" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Staff')" title="">
Staff
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/careers" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'New Times Careers')" title="">
New Times Careers
</a>
</li>
<li>
<a href="https://adindex.browardpalmbeach.com/" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Classifieds')" title="">
Classifieds
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/advertise" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Local Advertising')" title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/terms-of-use" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Terms of Use')" title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/privacy-policy" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Privacy Policy')" title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/contact" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Contact Us')" title="">
Contact Us
</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-navigation-link-block-column">
<ul class="uk-list">
<li class="fdn-custom-footer-navigation-link-block-column-header">
<a href="#" title="" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Back to Top')" uk-totop uk-scroll>
Back to Top
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'California Privacy Policy')" title="">
California Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#CollectionNotice" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'California Collection Notice')" title="">
California Collection Notice
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#DoNotSell" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Do Not Sell My Info')" title="">
Do Not Sell My Info
</a>
</li>
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" href="https://www.facebook.com/newtimesbpb" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Facebook')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" href="https://www.instagram.com/newtimesbroward/" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Instagram')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" href="https://twitter.com/newtimes_bpb" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Twitter')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block fdn-custom-footer-navigation-link-block-narrow uk-hidden@s">
<div class="fdn-custom-footer-navigation-link-block-narrow-rows">
<div class="fdn-custom-footer-navigation-link-block-row">
<ul class="uk-nav-default uk-nav-parent-icon" uk-nav="multiple: false">
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
Editorial
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Homepage')" title="">
Homepage
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/news" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'News')" title="">
News
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/restaurants" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Food & Drink')" title="">
Food &amp; Drink
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/arts" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Arts & Culture')" title="">
Arts &amp; Culture
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/music" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Music')" title="">
Music
</a>
</li>
<li>
<a href="https://herbanplanet.com/" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Cannabis')" title="">
Cannabis
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-of" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Best of Miami')" title="">
Best of Miami
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/best-miami-restaurants" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Required Eating 2021')" title="">
Required Eating 2021
</a>
</li>
<li>
<a href="https://www.miaminewtimes.com/miami-best-bars" target="_blank" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Best Bars 2020')" title="">
Best Bars 2020
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/guide/broward-palm-beach-restaurants" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Restaurant Guide')" title="">
Restaurant Guide
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/promotions" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
Marketing
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/promotions" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Promotions')" title="">
Promotions
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/coupons" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Coupons')" title="">
Coupons
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/profile?newsletter=10902046" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Promotions Newsletter')" title="">
Promotions Newsletter
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/flipbooks" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Flipbooks')" title="">
Flipbooks
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="https://www.browardpalmbeach.com/about" target="_self" class="fdn-custom-footer-navigation-link-block-row-header">
More
</a>
<ul class="uk-nav-sub uk-child-width-1-2 uk-flex uk-flex-wrap">
<li>
<a href="https://www.browardpalmbeach.com/about" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'About Us')" title="">
About Us
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/staff" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Staff')" title="">
Staff
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/careers" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'New Times Careers')" title="">
New Times Careers
</a>
</li>
<li>
<a href="https://adindex.browardpalmbeach.com/" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Classifieds')" title="">
Classifieds
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/advertise" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Local Advertising')" title="">
Local Advertising
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/terms-of-use" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Terms of Use')" title="">
Terms of Use
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/privacy-policy" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Privacy Policy')" title="">
Privacy Policy
</a>
</li>
<li>
<a href="https://www.browardpalmbeach.com/about/contact" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Contact Us')" title="">
Contact Us
</a>
</li>
</ul>
</li>
<li class="uk-parent">
<a href="#" target="_self" class="fdn-custom-footer-navigation-link-block-row-header" uk-totop uk-scroll>
Back to Top
</a>
</li>
</ul>
<div class="fdn-custom-footer-navigation-link-social-block">
<a class="fdn-custom-footer-navigation-link-social-facebook" href="https://www.facebook.com/newtimesbpb" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Facebook')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-facebook"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-instagram" href="https://www.instagram.com/newtimesbroward/" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Instagram')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-instagram"></i>
</a>
<a class="fdn-custom-footer-navigation-link-social-twitter" href="https://twitter.com/newtimes_bpb" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Twitter')" target="_blank" rel="nofollow">
<i class="fab fa-2x fa-twitter"></i>
</a>
</div>
</div>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-links">
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'California Privacy Policy')" title="">
California Privacy Policy
</a>
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#CollectionNotice" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'California Collection Notice')" title="">
California Collection Notice
</a>
</div>
<div class="fdn-custom-footer-navigation-link-block-narrow-legal-link-row">
<a href="https://www.browardpalmbeach.com/about/californiaPrivacyPolicy#DoNotSell" target="_self" onclick="ga('send', 'event', 'Nav-Bottom', 'Click', 'Do Not Sell My Info')" title="">
Do Not Sell My Info
</a>
</div>
</div>
</div>
<div class="uk-flex uk-flex-center uk-margin-medium-top custom-footer-row-bottom custom-footer-row">
<div class="uk-text-center">
<div class="fdn-copyright-text">
Use of this website constitutes acceptance of our
<a href="/about/terms-of-use">terms of use</a>,
<a href="/about/cookies">our cookies policy</a>, and our
<a href="/about/privacy-policy">privacy policy</a>
The New Times Broward-Palm Beach may earn a portion of sales from products & services purchased through links on our site from our
affiliate partners.
©2022
New Times BPB, LLC. All rights reserved.
</div>
<div class="fdn-copyright-text uk-margin-small-top">
<a class="fdn-copyright-link" href="https://publishwithfoundation.com/" target="_blank">
<img width="110" alt="Powered By Foundation" src="/images/PoweredByFoundation.svg">
</a>
</div>
</div>
</div>
</div><script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '578316758957526'); // Insert your pixel ID here.
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=578316758957526&ev=PageView&noscript=1"/></noscript>
<script type='text/javascript'>
  (function() {
    window._sf_async_config = window._sf_async_config || {};
    _sf_async_config.uid = 10424;
    _sf_async_config.domain = 'browardpalmbeach.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = '/news';
    _sf_async_config.authors = 'Alex DeLuca';

    function loadChartbeat() {
      window._sf_endpt = (new Date()).getTime();
      var e = document.createElement('script');
      var n = document.getElementsByTagName('script')[0];
      e.type = 'text/javascript';
      e.async = true;
      e.src = '//static.chartbeat.com/js/chartbeat.js';
      n.parentNode.insertBefore(e, n);
    }
    loadChartbeat();
  })();
  </script>

<script>
   var ezt = ezt ||[];

   (function(){
     var elem = document.createElement('script');
     elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
     elem.async = true;
     elem.type = "text/javascript";
     var scpt = document.getElementsByTagName('script')[0];
     scpt.parentNode.insertBefore(elem,scpt);
   }());


   ezt.push({qacct: 'p-a4LDpi_DEopn-',
         uid: ''
             });
  </script>
<noscript>
    <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
  </noscript>


<script>
  (function(w,d,t,u){
      var a=d.createElement(t);a.async=1;a.src=u+"?url="+encodeURIComponent(w.location.href)+"&ref="+encodeURIComponent(d.referrer);
      var s=d.getElementsByTagName(t)[0]; s.parentNode.insertBefore(a,s);
  })(window, document, 'script', 'https://a.ad.gt/api/v1/u/matches/322')
  </script>

</div>
</div>
<div class="ev-grid-zone ev-closer-zone" data-ev-zone="Closer">
<div class="ev-grid-col uk-width-1-1">
</div>
</div>
</div>
</div>
<script>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</script>
</body>
</html>
